- Update to version 0.11.1
This commit is contained in:
parent
db65b9c993
commit
585dc28b8b
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=47910
5 changed files with 791 additions and 772 deletions
|
@ -6,7 +6,7 @@
|
|||
#
|
||||
|
||||
PORTNAME= 4suite
|
||||
PORTVERSION= 0.11
|
||||
PORTVERSION= 0.11.1
|
||||
CATEGORIES= textproc python
|
||||
MASTER_SITES= ftp://ftp.4suite.org/pub/4Suite/
|
||||
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
|
||||
|
@ -29,19 +29,21 @@ PLIST_SUB+= PACKAGE_DIR=_xmlplus PYTHON2_ONLY=""
|
|||
|
||||
post-patch:
|
||||
@ ${PERL} -pi -e \
|
||||
's#(copy_to=.)docs#$$1doc/py-${PORTNAME}#; \
|
||||
s#(copy_to=.)(test_suite|demo)#$$1examples/py-${PORTNAME}/$$2#' \
|
||||
's#(copy_to=.)docs#$$1doc/${PORTNAME}#; \
|
||||
s#(copy_to=.)(test_suite|demo)#$$1examples/${PORTNAME}/$$2#' \
|
||||
${WRKSRC}/setup.py
|
||||
.if defined(NOPORTDOCS)
|
||||
@ ${PERL} -pi -e 's/(data_files=)data_files + /$$1/' \
|
||||
@ ${PERL} -pi -e 's/(data_files=)data_files/$$1/' \
|
||||
${WRKSRC}/setup.py
|
||||
.endif
|
||||
|
||||
do-build:
|
||||
@ cd ${WRKSRC} && ${PYTHON_CMD} setup.py build
|
||||
@ cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${PYTHON_CMD} \
|
||||
setup.py build
|
||||
|
||||
do-install:
|
||||
@ cd ${WRKSRC} && ${PYTHON_CMD} setup.py install -c -O1 \
|
||||
--prefix=${PREFIX} --install-data=${PREFIX}/share
|
||||
@ cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${PYTHON_CMD} \
|
||||
setup.py install -c -O1 --prefix=${PREFIX} \
|
||||
--install-data=${PREFIX}/share
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
|
|
|
@ -1 +1 @@
|
|||
MD5 (4Suite-0.11.tar.gz) = 7155f58e9ff2e05b4b83ca1d2ad52211
|
||||
MD5 (4Suite-0.11.1.tar.gz) = 169274870a10c233851383faa7a9eddb
|
||||
|
|
|
@ -1,17 +0,0 @@
|
|||
A small bug that surfaced during the creation of this port. As it happens,
|
||||
this does not actually affect the port in its final submitted form, but...
|
||||
a fix is a fix, and it may impact the port later.
|
||||
|
||||
-- Johann Visagie <johann@egenetics.com>
|
||||
|
||||
|
||||
--- admin/DistExt.py.orig Mon Feb 19 21:40:30 2001
|
||||
+++ admin/DistExt.py Fri Mar 16 18:29:11 2001
|
||||
@@ -145,6 +145,7 @@
|
||||
package_dir = [self.build_lib] + list(package)
|
||||
package_dir = apply(os.path.join, package_dir)
|
||||
for po_file in po_list:
|
||||
+ self.mkpath(package_dir)
|
||||
(out, _) = self.copy_file(po_file, package_dir)
|
||||
self.outfiles.append(out)
|
||||
locale = os.path.split(po_file)[1][:-3]
|
|
@ -7,18 +7,15 @@ the "correct" location:
|
|||
|
||||
- It removes some redundant documentation.
|
||||
|
||||
- It splits data_files into two parts, one which contains only documentation,
|
||||
and one which contains all other files (currently, juse one!)
|
||||
|
||||
Note that setup.py is processed further in the port Makefile's post-patch
|
||||
target.
|
||||
|
||||
-- Johann Visagie <johann@egenetics.com>
|
||||
-- Johann Visagie <wjv@FreeBSD.org>
|
||||
|
||||
|
||||
--- setup.py.orig Tue May 1 00:38:56 2001
|
||||
+++ setup.py Fri May 4 17:23:15 2001
|
||||
@@ -304,21 +304,7 @@
|
||||
--- setup.py.orig Thu Sep 13 20:21:05 2001
|
||||
+++ setup.py Fri Sep 14 16:40:29 2001
|
||||
@@ -228,22 +228,7 @@
|
||||
#
|
||||
############################################################
|
||||
|
||||
|
@ -27,6 +24,7 @@ target.
|
|||
- 'docs/text/CREDITS',
|
||||
- 'docs/text/PACKAGES',
|
||||
- 'docs/text/README',
|
||||
- 'docs/text/ReleaseNotes',
|
||||
- 'docs/text/REBUILDING',
|
||||
- 'docs/text/TODO',
|
||||
- 'docs/ChangeLog',
|
||||
|
@ -41,35 +39,31 @@ target.
|
|||
files=['docs/text/COPYRIGHT',
|
||||
'docs/text/CREDITS',
|
||||
'docs/text/PACKAGES',
|
||||
@@ -435,9 +421,6 @@
|
||||
Data_Files(copy_to='test_suite/4ODS/Tools',
|
||||
files=glob.glob('Ods/Tools/test_suite/*.*')),
|
||||
@@ -330,7 +315,7 @@
|
||||
files=get_files('test_suite/Rdf/Inference/*.*')),
|
||||
|
||||
- Data_Files(use_install_cmd='install_lib',
|
||||
- copy_to='Ft/DbDom',
|
||||
- files=['DbDom/dom.odl']),
|
||||
Data_Files(copy_to='test_suite/DbDom',
|
||||
files=['Lib/TestSuite.py']),
|
||||
Data_Files(copy_to='test_suite/DbDom',
|
||||
@@ -457,8 +440,10 @@
|
||||
Data_Files(copy_to='demo/4ODS/book_mark_manager',
|
||||
files=glob.glob('Ods/demo/book_mark_manager/*.*')),
|
||||
|
||||
- Data_Files(copy_to='profile/Rdf',
|
||||
+ Data_Files(copy_to='test_suite/profile/Rdf',
|
||||
files=get_files('profile/Rdf/*.*')),
|
||||
|
||||
|
||||
@@ -353,7 +338,7 @@
|
||||
Data_Files(copy_to='test_suite/Ods/borrowed',
|
||||
files=get_files('test_suite/Ods/borrowed/*.*')),
|
||||
|
||||
- Data_Files(copy_to='profile/Ods',
|
||||
+ Data_Files(copy_to='test_suite/profile/Ods',
|
||||
files=get_files('profile/Ods/*.*')),
|
||||
|
||||
|
||||
@@ -377,9 +362,6 @@
|
||||
Data_Files(copy_to='demos/4ODS/tutorial',
|
||||
files=get_files('demos/4ODS/tutorial/*.*')),
|
||||
]
|
||||
-
|
||||
-for df in data_files:
|
||||
- df.base_dir = '$base/doc/$dist_name-$dist_version'
|
||||
+data_files2 = [Data_Files(use_install_cmd='install_lib',
|
||||
+ copy_to='Ft/DbDom',
|
||||
+ files=['DbDom/dom.odl'])
|
||||
+ ]
|
||||
|
||||
############################################################
|
||||
#
|
||||
@@ -545,7 +530,7 @@
|
||||
py_files=py_files,
|
||||
l10n=l10n,
|
||||
|
||||
- data_files=data_files,
|
||||
+ data_files=data_files + data_files2,
|
||||
ext_modules=ext_modules,
|
||||
scripts=DistExt.EnsureScripts('Xslt/bin/4xslt',
|
||||
'Rdf/exec/4rdf',
|
||||
|
|
File diff suppressed because it is too large
Load diff
Loading…
Reference in a new issue