Remmina is a remote desktop client written in GTK+, aiming to be useful for

system administrators and travellers, who need to work with lots of remote
computers in front of either large monitors or tiny netbooks. Remmina supports
multiple network protocols in an integrated and consistant user interface.

This metaport installs Remmina plugins for RDP, Telepathy, VNC and
XDMCP protocols.

WWW: http://remmina.sourceforge.net/
This commit is contained in:
Alexander Logvinov 2010-08-10 02:56:20 +00:00
parent 809014e15c
commit 5860331b15
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=259041
7 changed files with 155 additions and 0 deletions

View file

@ -885,6 +885,7 @@
SUBDIR += relayd
SUBDIR += remmina
SUBDIR += remmina-applet
SUBDIR += remmina-plugins
SUBDIR += remotedesk
SUBDIR += repeater
SUBDIR += rexx-sock

View file

@ -0,0 +1,51 @@
# New ports collection makefile for: remmina-plugins
# Date created: 24 June 2010
# Whom: Alexander Logvinov <avl@FreeBSD.org>
#
# $FreeBSD$
#
PORTNAME?= remmina-plugins
PORTVERSION= 0.8.2
CATEGORIES= net gnome
MASTER_SITES= # Empty
DISTFILES?= # Empty
MAINTAINER= avl@FreeBSD.org
COMMENT?= Remmina plugin system
.if defined(PKGNAMESUFFIX)
.include "${.CURDIR}/../remmina-plugins/bsd.plugin.mk"
.else
OPTIONS= RDP "Install RDP protocol plugin" on \
VNC "Install VNC protocol plugin" on \
XDMCP "Install XDMCP protocol plugin" on \
TELEP "Install Telepathy protocol plugin" on
NO_BUILD= yes
PATCHDIR= # none
.include <bsd.port.options.mk>
.if !defined(WITHOUT_RDP)
#RUN_DEPENDS+= ${LOCALBASE}/lib/remmina/plugins/remmina-plugin-rdp.so:${PORTSDIR}/net/remmina-plugin-rdp
.endif
.if !defined(WITHOUT_VNC)
#RUN_DEPENDS+= ${LOCALBASE}/lib/remmina/plugins/remmina-plugin-vnc.so:${PORTSDIR}/net/remmina-plugin-vnc
.endif
.if !defined(WITHOUT_XDMCP)
#RUN_DEPENDS+= ${LOCALBASE}/lib/remmina/plugins/remmina-plugin-xdmcp.so:${PORTSDIR}/net/remmina-plugin-xdmcp
.endif
.if !defined(WITHOUT_TELEP)
#RUN_DEPENDS+= ${LOCALBASE}/lib/remmina/plugins/remmina-plugin-telepathy.so:${PORTSDIR}/net/remmina-plugin-telepathy
.endif
do-install: # empty
.include <bsd.port.mk>
.endif

View file

@ -0,0 +1,58 @@
.if defined(PKGNAMESUFFIX)
PORTNAME= remmina-plugin
MASTER_SITES= SF/remmina/0.8
DISTNAME= remmina-plugins-${PORTVERSION}
DISTFILES= ${DISTNAME}.tar.gz
BUILD_DEPENDS+= ${LOCALBASE}/include/remmina/plugin.h:${PORTSDIR}/net/remmina
RUN_DEPENDS+= remmina:${PORTSDIR}/net/remmina
GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_GNOME= glib20 gtk20
INSTALLS_ICONS= yes
LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
LDFLAGS="${LDFLAGS}"
CONFIGURE_ARGS+=--disable-nx --disable-rdp --disable-ssh --disable-telepathy \
--disable-vnc --disable-xdmcp --disable-nls
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
.include <bsd.port.pre.mk>
.if ${PKGNAMESUFFIX} == "-i18n"
CONFIGURE_ARGS+=--enable-nls
PLIST= ${.CURDIR}/pkg-plist
.else
CONFIGURE_ARGS+=--enable${PKGNAMESUFFIX}
PLIST_SUB+= PLUGIN="${PKGNAMESUFFIX:S,-,,}"
PLIST= ${PKGDIR}/pkg-plist.plugin
.if defined(WITH_TELEP)
PLIST_SUB+= TELEP="" ICONS="@comment "
.else
PLIST_SUB+= TELEP="@comment " ICONS=""
.endif
.if defined(WITH_SSH)
LIB_DEPENDS+= ssh.4:${PORTSDIR}/security/libssh
CONFIGURE_ARGS+=--enable-ssh
PLIST_SUB+= SSH="@comment "
.if ${OSVERSION} >= 800040
LDFLAGS+= -fstack-protector
.endif
.else
PLIST_SUB+= SSH=""
.endif
.if !defined(WITHOUT_NLS)
RUN_DEPENDS+= ${LOCALBASE}/share/locale/bg/LC_MESSAGES/remmina-plugins.mo:${PORTSDIR}/net/remmina-plugin-i18n
.endif
.endif
.include <bsd.port.post.mk>
.endif

View file

@ -0,0 +1,3 @@
MD5 (remmina-plugins-0.8.2.tar.gz) = ee2c0398ed8ef40562a24f1ae45688aa
SHA256 (remmina-plugins-0.8.2.tar.gz) = f99789590ce00c44092f09289779fd6e3034ab4b70c21556e0512c22f8429ff0
SIZE (remmina-plugins-0.8.2.tar.gz) = 522737

View file

@ -0,0 +1,16 @@
--- vnc/Makefile.in.orig 2010-06-22 14:55:04.000000000 +1000
+++ vnc/Makefile.in 2010-06-24 12:32:00.000000000 +1000
@@ -372,11 +372,11 @@
@am__fastdepCC_FALSE@ $(LTCOMPILE) -c -o $@ $<
remmina_plugin_vnc_la-remminapluginvnc.lo: remminapluginvnc.c
-@am__fastdepCC_TRUE@ $(LIBTOOL) --tag=CC $(AM_LIBTOOLFLAGS) $(LIBTOOLFLAGS) --mode=compile $(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(remmina_plugin_vnc_la_CFLAGS) $(CFLAGS) -MT remmina_plugin_vnc_la-remminapluginvnc.lo -MD -MP -MF $(DEPDIR)/remmina_plugin_vnc_la-remminapluginvnc.Tpo -c -o remmina_plugin_vnc_la-remminapluginvnc.lo `test -f 'remminapluginvnc.c' || echo '$(srcdir)/'`remminapluginvnc.c
+@am__fastdepCC_TRUE@ $(LIBTOOL) --tag=CC $(AM_LIBTOOLFLAGS) $(LIBTOOLFLAGS) --mode=compile $(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) $(remmina_plugin_vnc_la_CFLAGS) $(CPPFLAGS) $(CFLAGS) -MT remmina_plugin_vnc_la-remminapluginvnc.lo -MD -MP -MF $(DEPDIR)/remmina_plugin_vnc_la-remminapluginvnc.Tpo -c -o remmina_plugin_vnc_la-remminapluginvnc.lo `test -f 'remminapluginvnc.c' || echo '$(srcdir)/'`remminapluginvnc.c
@am__fastdepCC_TRUE@ $(am__mv) $(DEPDIR)/remmina_plugin_vnc_la-remminapluginvnc.Tpo $(DEPDIR)/remmina_plugin_vnc_la-remminapluginvnc.Plo
@AMDEP_TRUE@@am__fastdepCC_FALSE@ source='remminapluginvnc.c' object='remmina_plugin_vnc_la-remminapluginvnc.lo' libtool=yes @AMDEPBACKSLASH@
@AMDEP_TRUE@@am__fastdepCC_FALSE@ DEPDIR=$(DEPDIR) $(CCDEPMODE) $(depcomp) @AMDEPBACKSLASH@
-@am__fastdepCC_FALSE@ $(LIBTOOL) --tag=CC $(AM_LIBTOOLFLAGS) $(LIBTOOLFLAGS) --mode=compile $(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(remmina_plugin_vnc_la_CFLAGS) $(CFLAGS) -c -o remmina_plugin_vnc_la-remminapluginvnc.lo `test -f 'remminapluginvnc.c' || echo '$(srcdir)/'`remminapluginvnc.c
+@am__fastdepCC_FALSE@ $(LIBTOOL) --tag=CC $(AM_LIBTOOLFLAGS) $(LIBTOOLFLAGS) --mode=compile $(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) $(remmina_plugin_vnc_la_CFLAGS) $(CPPFLAGS) $(CFLAGS) -c -o remmina_plugin_vnc_la-remminapluginvnc.lo `test -f 'remminapluginvnc.c' || echo '$(srcdir)/'`remminapluginvnc.c
mostlyclean-libtool:
-rm -f *.lo

View file

@ -0,0 +1,6 @@
Remmina is a remote desktop client written in GTK+, aiming to be useful for
system administrators and travellers, who need to work with lots of remote
computers in front of either large monitors or tiny netbooks. Remmina supports
multiple network protocols in an integrated and consistant user interface.
WWW: http://remmina.sourceforge.net/

View file

@ -0,0 +1,20 @@
lib/remmina/plugins/remmina-plugin-%%PLUGIN%%.a
lib/remmina/plugins/remmina-plugin-%%PLUGIN%%.la
lib/remmina/plugins/remmina-plugin-%%PLUGIN%%.so
%%TELEP%%share/dbus-1/services/org.freedesktop.Telepathy.Client.Remmina.service
%%ICONS%%share/remmina/icons/hicolor/16x16/emblems/remmina-%%PLUGIN%%.png
%%ICONS%%%%SSH%%share/remmina/icons/hicolor/16x16/emblems/remmina-%%PLUGIN%%-ssh.png
%%ICONS%%share/remmina/icons/hicolor/22x22/emblems/remmina-%%PLUGIN%%.png
%%ICONS%%%%SSH%%share/remmina/icons/hicolor/22x22/emblems/remmina-%%PLUGIN%%-ssh.png
%%TELEP%%share/telepathy/clients/Remmina.client
@dirrmtry lib/remmina/plugins
@dirrmtry lib/remmina
@dirrmtry share/remmina/icons/hicolor/22x22/emblems
@dirrmtry share/remmina/icons/hicolor/22x22
@dirrmtry share/remmina/icons/hicolor/16x16/emblems
@dirrmtry share/remmina/icons/hicolor/16x16
@dirrmtry share/remmina/icons/hicolor
@dirrmtry share/remmina/icons
@dirrmtry share/remmina
%%TELEP%%@dirrmtry share/telepathy/clients
%%TELEP%%@dirrmtry share/telepathy