Update to 2.39

This commit is contained in:
Emanuel Haupt 2007-01-02 17:37:36 +00:00
parent ea94111b3c
commit 587c8c414d
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=181283
7 changed files with 103 additions and 40 deletions

View file

@ -6,7 +6,7 @@
#
PORTNAME= filters
PORTVERSION= 2.34
PORTVERSION= 2.39
CATEGORIES= games perl5
MASTER_SITES= http://ftp.debian.org/debian/pool/main/f/filters/ \
http://critical.ch/distfiles/ \
@ -16,52 +16,58 @@ DISTNAME= ${PORTNAME}_${PORTVERSION}
MAINTAINER= ehaupt@FreeBSD.org
COMMENT= A collection of filters, including B1FF and the Swedish Chef
CONFLICTS= talkfilters-* jive-* chef-*
CONFLICTS= talkfilters-* jive-* chef-* kenny-*
USE_PERL5= yes
USE_GMAKE= yes
ALL_TARGET+= samples
CFLAGS+= -lfl
WRKSRC= ${WRKDIR}/${PORTNAME}
PERLFILTERS= b1ff censor chef eleet fudd jibberish rasterman \
MAKE_ENV+= CC="${CC}"
PERLFILTERS= b1ff censor chef eleet fudd jibberish kenny pirate rasterman \
spammer studly uniencode upside-down
CFILTERS= jethro kraut cockney jive nyc ken ky00te newspeak
MAN6= filters.6
CFILTERS= jethro kraut cockney jive nyc ken ky00te newspeak nethackify
.include <bsd.port.pre.mk>
MAN1= filters.1
MLINKS= filters.1 b1ff.1 \
filters.1 censor.1 \
filters.1 chef.1 \
filters.1 eleet.1 \
filters.1 fudd.1 \
filters.1 jibberish.1 \
filters.1 kenny.1 \
filters.1 pirate.1 \
filters.1 rasterman.1 \
filters.1 spammer.1 \
filters.1 studly.1 \
filters.1 uniencode.1 \
filters.1 upside-down.1 \
filters.1 jethro.1 \
filters.1 kraut.1 \
filters.1 cockney.1 \
filters.1 jive.1 \
filters.1 nyc.1 \
filters.1 ken.1 \
filters.1 ky00te.1 \
filters.1 newspeak.1 \
filters.1 nethackify.1
EXTRACFLAGS!= ${ECHO} ${CFLAGS} | ${SED} -e 's|\-lfl||'
post-extract:
@${MV} ${WRKSRC}/${PORTNAME}.6 ${WRKSRC}/${MAN1}
post-patch:
.for f in ${FILTERS}
@${REINPLACE_CMD} -e 's|/usr/local/bin/perl|${PERL}|' \
${WRKSRC}/${f}
.for f in ${PERLFILTERS}
@${REINPLACE_CMD} -e '1s|.*perl|#!${PERL}|' ${WRKSRC}/${f}
.endfor
@${REINPLACE_CMD} -e 's|^\(CFLAGS\).*=|\1?=|' \
${WRKSRC}/Makefile
@${REINPLACE_CMD} -e 's|/usr/share/doc/filters|${EXAMPLESDIR}|' \
${WRKSRC}/${MAN6}
@${REINPLACE_CMD} \
-e 's|\([[:space:]]\)cc\ |\1${CC}\ |' \
-e 's|..CFLAGS.\(\ -o\ \.\{2\}\)|${EXTRACFLAGS}\1|' \
${WRKSRC}/ky00te.dir/makefile
do-install:
.for f in ${PERLFILTERS}
${INSTALL_SCRIPT} ${WRKSRC}/${f} ${PREFIX}/bin
.endfor
.for f in ${CFILTERS}
${INSTALL_PROGRAM} ${WRKSRC}/${f} ${PREFIX}/bin
.endfor
${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.6 ${MANPREFIX}/man/man6
${MKDIR} ${EXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/SAMPLES ${EXAMPLESDIR}
.for f in ${PERLFILTERS}
${INSTALL_SCRIPT} ${WRKSRC}/${f} ${PREFIX}/bin
.endfor
${INSTALL_MAN} ${WRKSRC}/${MAN1} ${MANPREFIX}/man/man1
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
.endif
.include <bsd.port.post.mk>
.include <bsd.port.mk>

View file

@ -1,3 +1,3 @@
MD5 (filters_2.34.tar.gz) = c781394c0d4c5ff4cbf551827e99ee72
SHA256 (filters_2.34.tar.gz) = 9f2db8d8aa91209b50c095f3f09d21d63def3e9f48e1e8d3326e4db4d9f22ba1
SIZE (filters_2.34.tar.gz) = 43654
MD5 (filters_2.39.tar.gz) = d8db32b761110380a0a224e67c76611d
SHA256 (filters_2.39.tar.gz) = 5a9c2881f4633ee0fff0b112fdd52eeea470f107582ff02c56701eee6ac59c6d
SIZE (filters_2.39.tar.gz) = 49669

View file

@ -0,0 +1,20 @@
--- ./Makefile.orig Mon Feb 20 22:30:52 2006
+++ ./Makefile Tue Jan 2 18:06:34 2007
@@ -2,7 +2,7 @@
BUILD = jethro kraut cockney jive nyc ken ky00te newspeak nethackify
OTHER = eleet b1ff chef jibberish upside-down rasterman studly fudd \
censor spammer uniencode pirate kenny
-CFLAGS = -O2 -lfl
+LDFLAGS+= -lfl
INSTALL_PROGRAM = install
# DEB_BUILD_OPTIONS suport, to control binary stripping.
@@ -41,7 +41,7 @@
.l:
$(RM) $*.c
$(LEX) -t $< > $*.c
- $(CC) -o $@ $*.c $(CFLAGS)
+ $(CC) -o $@ $*.c $(CFLAGS) $(LDFLAGS)
$(RM) $*.c
.SUFFIXES: .dir

View file

@ -0,0 +1,8 @@
--- ./filters.1.orig Tue Jan 2 18:06:45 2007
+++ ./filters.1 Tue Jan 2 18:06:51 2007
@@ -1,4 +1,4 @@
-.TH FILTERS 6
+.TH FILTERS 1
.SH NAME
ken, b1ff, censor, chef, cockney, eleet, fudd, jethro, jibberish, jive, kenny, kraut, ky00te, nethack, newspeak, nyc, pirate, rasterman, spammer, studly, uniencode, upside\-down \- assorted text filters
.SH SYNOPSIS

View file

@ -0,0 +1,19 @@
--- ./ky00te.dir/makefile.orig Wed Jan 25 05:54:34 2006
+++ ./ky00te.dir/makefile Tue Jan 2 18:06:34 2007
@@ -5,13 +5,13 @@
rm -f ../ky00te
../ky00te: y.tab.o lex.yy.o
- cc $(CFLAGS) -o ../ky00te lex.yy.o y.tab.o -lfl
+ $(CC) $(CFLAGS) -o ../ky00te lex.yy.o y.tab.o -lfl
lex.yy.o: lex.yy.c y.tab.h
- cc $(CFLAGS) -c lex.yy.c
+ $(CC) $(CFLAGS) -c lex.yy.c
y.tab.o: y.tab.c
- cc $(CFLAGS) -c y.tab.c
+ $(CC) $(CFLAGS) -c y.tab.c
lex.yy.c: ky00te.lex
flex ky00te.lex

View file

@ -0,0 +1,11 @@
--- ./nethackify.dir/makefile.orig Wed Jan 25 05:54:47 2006
+++ ./nethackify.dir/makefile Tue Jan 2 18:06:34 2007
@@ -1,5 +1,7 @@
+CFLAGS+= -trigraphs
+
../nethackify:
- gcc nethackify.c -o ../nethackify
+ $(CC) $(CFLAGS) nethackify.c -o ../nethackify
test:
@../nethackify The kitten bites.--More--

View file

@ -8,16 +8,15 @@ bin/jethro
bin/jibberish
bin/jive
bin/ken
bin/kenny
bin/kraut
bin/ky00te
bin/nethackify
bin/newspeak
bin/nyc
bin/pirate
bin/rasterman
bin/spammer
bin/studly
bin/uniencode
bin/upside-down
%%EXAMPLESDIR%%/SAMPLES
%%PORTDOCS%%%%DOCSDIR%%/README
@dirrm %%EXAMPLESDIR%%
%%PORTDOCS%%@dirrm %%DOCSDIR%%