net/glusterfs: Update to 3.9.0

PR:		215033
Submitted by:	craig001@lerwick.hopto.org (maintainer)
This commit is contained in:
Steve Wills 2017-01-21 03:08:30 +00:00
parent a5a836d24b
commit 58efcc8181
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=432008
6 changed files with 184 additions and 38 deletions

View file

@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= glusterfs
PORTVERSION= 3.7.6
PORTVERSION= 3.9.0
PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= http://bits.gluster.org/pub/gluster/glusterfs/src/
@ -16,11 +16,15 @@ LIB_DEPENDS= libargp.so:devel/argp-standalone liburcu-bp.so:sysutils/liburcu
USE_GCC= any
USES= bison gettext libtool pkgconfig python:build readline \
shebangfix sqlite
SHEBANG_FILES= extras/peer_add_secret_pub.in \
tools/glusterfind/S57glusterfind-delete-post.py \
extras/ganesha/scripts/ganesha-ha.sh
USES= bison gettext libtool pkgconfig python readline shebangfix \
sqlite
SHEBANG_FILES= extras/ganesha/scripts/create-export-ganesha.sh \
extras/ganesha/scripts/dbus-send.sh \
extras/ganesha/scripts/ganesha-ha.sh \
extras/ganesha/scripts/generate-epoch.py \
extras/peer_add_secret_pub.in \
tools/glusterfind/S57glusterfind-delete-post.py
USE_GNOME= glib20 libxml2
USE_LDCONFIG= yes
@ -39,7 +43,7 @@ CONFIGURE_ARGS= --with-pkgconfigdir=${PREFIX}/libdata/pkgconfig \
CPPFLAGS+= -I"${LOCALBASE}/include"
LDFLAGS+= -L"${LOCALBASE}/lib" -largp
INSTALL_TARGET= install-strip
PLIST_SUB= GLUSTERLIBDIR="lib/${PORTNAME}/3.7.6"
PLIST_SUB= GLUSTERLIBDIR="lib/${PORTNAME}/${PORTVERSION}"
KMODDIR?= /boot/modules
.include <bsd.port.mk>

View file

@ -1,2 +1,3 @@
SHA256 (glusterfs-3.7.6.tar.gz) = bb83f0b6bd95599d3742d1c7c12dbbe7b4ef4d4908c5056ee97b3f32c508cf05
SIZE (glusterfs-3.7.6.tar.gz) = 7690697
TIMESTAMP = 1479924003
SHA256 (glusterfs-3.9.0.tar.gz) = b417c674454b17d1851828a1ca395cb9e7ab198378391da04e2fb8911cc1fb14
SIZE (glusterfs-3.9.0.tar.gz) = 8709782

View file

@ -1,6 +1,6 @@
--- configure.orig 2015-11-08 21:57:53 UTC
--- configure.orig 2016-11-15 14:54:31 UTC
+++ configure
@@ -17172,6 +17172,9 @@ case $host_os in
@@ -13428,6 +13428,9 @@ case $host_os in
linux*)
#do nothing
;;
@ -10,12 +10,3 @@
netbsd*)
#do nothing
;;
@@ -20758,7 +20761,7 @@ CPPFLAGS=$CFLAGS
LDFLAGS="${PYTHON_LIBS} -L`${PYTHON}-config --prefix`/lib -L`${PYTHON}-config --prefix`/$libdir `${PYTHON}-config --ldflags`"
-for ac_header in python$PYTHON_VERSION/Python.h
+for ac_header in python$PYTHON_VERSION/Python.h Python.h
do
as_ac_Header=`$as_echo "ac_cv_header_$ac_header" | $as_tr_sh`
if { as_var=$as_ac_Header; eval "test \"\${$as_var+set}\" = set"; }; then

View file

@ -1,10 +1,10 @@
--- contrib/fuse-lib/mount.c.orig 2015-11-08 21:57:46 UTC
--- contrib/fuse-lib/mount.c.orig 2016-11-15 14:54:27 UTC
+++ contrib/fuse-lib/mount.c
@@ -256,6 +256,7 @@ fuse_mount_sys (const char *mountpoint,
build_iovec (&iov, &iovlen, "from", "/dev/fuse", -1);
build_iovec (&iov, &iovlen, "volname", source, -1);
build_iovec (&iov, &iovlen, "fd", fdstr, -1);
+ build_iovec (&iov, &iovlen, "allow_other", NULL, -1);
+ build_iovec (&iov, &iovlen, "allow_other", NULL, -1);
ret = nmount (iov, iovlen, mountflags);
#else
ret = mount (source, mountpoint, fstype, mountflags,

View file

@ -1,6 +1,6 @@
--- extras/Makefile.in.orig 2015-11-08 21:57:56 UTC
--- extras/Makefile.in.orig 2016-11-15 14:54:33 UTC
+++ extras/Makefile.in
@@ -529,8 +529,8 @@ install-volDATA: $(vol_DATA)
@@ -635,8 +635,8 @@ install-volDATA: $(vol_DATA)
echo "$$d$$p"; \
done | $(am__base_list) | \
while read files; do \
@ -11,9 +11,9 @@
done
uninstall-volDATA:
@@ -865,7 +865,7 @@ install-data-local:
@@ -935,7 +935,7 @@ install-data-local:
fi
$(MKDIR_P) $(DESTDIR)$(GLUSTERD_WORKDIR)/groups
$(mkdir_p) $(DESTDIR)$(GLUSTERD_WORKDIR)/groups
$(INSTALL_DATA) $(top_srcdir)/extras/group-virt.example \
- $(DESTDIR)$(GLUSTERD_WORKDIR)/groups/virt
+ $(DESTDIR)$(GLUSTERD_WORKDIR)/groups/virt.sample

View file

@ -1,5 +1,6 @@
bin/glusterfind
@sample etc/ganesha/ganesha-ha.conf.sample
%%ETCDIR%%/eventsconfig.json
%%ETCDIR%%/gluster-rsyslog-5.8.conf
%%ETCDIR%%/gluster-rsyslog-7.2.conf
@sample %%ETCDIR%%/glusterd.vol.sample
@ -9,6 +10,28 @@ bin/glusterfind
%%ETCDIR%%/logger.conf.example
include/glusterfs/api/glfs-handles.h
include/glusterfs/api/glfs.h
include/glusterfs/byte-order.h
include/glusterfs/call-stub.h
include/glusterfs/checksum.h
include/glusterfs/circ-buff.h
include/glusterfs/cli1-xdr.h
include/glusterfs/client_t.h
include/glusterfs/cluster-syncop.h
include/glusterfs/common-utils.h
include/glusterfs/compat-errno.h
include/glusterfs/compat-uuid.h
include/glusterfs/compat.h
include/glusterfs/compound-fop-utils.h
include/glusterfs/daemon.h
include/glusterfs/default-args.h
include/glusterfs/defaults.h
include/glusterfs/dict.h
include/glusterfs/event-history.h
include/glusterfs/event.h
include/glusterfs/events.h
include/glusterfs/fd-lk.h
include/glusterfs/fd.h
include/glusterfs/gf-dirent.h
include/glusterfs/gfchangelog/changelog.h
include/glusterfs/gfdb/gfdb_data_store.h
include/glusterfs/gfdb/gfdb_data_store_helper.h
@ -16,6 +39,82 @@ include/glusterfs/gfdb/gfdb_data_store_types.h
include/glusterfs/gfdb/gfdb_mem-types.h
include/glusterfs/gfdb/gfdb_sqlite3.h
include/glusterfs/gfdb/gfdb_sqlite3_helper.h
include/glusterfs/gidcache.h
include/glusterfs/glfs-message-id.h
include/glusterfs/globals.h
include/glusterfs/glusterfs-acl.h
include/glusterfs/glusterfs-fops.h
include/glusterfs/glusterfs.h
include/glusterfs/graph-utils.h
include/glusterfs/hashfn.h
include/glusterfs/iatt.h
include/glusterfs/inode.h
include/glusterfs/iobuf.h
include/glusterfs/latency.h
include/glusterfs/libglusterfs-messages.h
include/glusterfs/list.h
include/glusterfs/lkowner.h
include/glusterfs/locking.h
include/glusterfs/logging.h
include/glusterfs/lvm-defaults.h
include/glusterfs/mem-pool.h
include/glusterfs/mem-types.h
include/glusterfs/options.h
include/glusterfs/parse-utils.h
include/glusterfs/quota-common-utils.h
include/glusterfs/rbthash.h
include/glusterfs/refcount.h
include/glusterfs/revision.h
include/glusterfs/rot-buffs.h
include/glusterfs/rpc/acl3-xdr.h
include/glusterfs/rpc/changelog-xdr.h
include/glusterfs/rpc/cli1-xdr.h
include/glusterfs/rpc/glusterd1-xdr.h
include/glusterfs/rpc/glusterfs-fops.h
include/glusterfs/rpc/glusterfs3-xdr.h
include/glusterfs/rpc/glusterfs3.h
include/glusterfs/rpc/mount3udp.h
include/glusterfs/rpc/msg-nfs3.h
include/glusterfs/rpc/nlm4-xdr.h
include/glusterfs/rpc/nsm-xdr.h
include/glusterfs/rpc/portmap-xdr.h
include/glusterfs/rpc/protocol-common.h
include/glusterfs/rpc/rpc-clnt-ping.h
include/glusterfs/rpc/rpc-clnt.h
include/glusterfs/rpc/rpc-common-xdr.h
include/glusterfs/rpc/rpc-drc.h
include/glusterfs/rpc/rpc-lib-messages.h
include/glusterfs/rpc/rpc-transport.h
include/glusterfs/rpc/rpcsvc-common.h
include/glusterfs/rpc/rpcsvc.h
include/glusterfs/rpc/xdr-common.h
include/glusterfs/rpc/xdr-generic.h
include/glusterfs/rpc/xdr-nfs3.h
include/glusterfs/rpc/xdr-rpc.h
include/glusterfs/rpc/xdr-rpcclnt.h
include/glusterfs/run.h
include/glusterfs/server/authenticate.h
include/glusterfs/server/server-common.h
include/glusterfs/server/server-helpers.h
include/glusterfs/server/server-mem-types.h
include/glusterfs/server/server-messages.h
include/glusterfs/server/server.h
include/glusterfs/stack.h
include/glusterfs/statedump.h
include/glusterfs/store.h
include/glusterfs/strfd.h
include/glusterfs/syncop-utils.h
include/glusterfs/syncop.h
include/glusterfs/syscall.h
include/glusterfs/template-component-messages.h
include/glusterfs/throttle-tbf.h
include/glusterfs/timer.h
include/glusterfs/timespec.h
include/glusterfs/trie.h
include/glusterfs/tw.h
include/glusterfs/upcall-utils.h
include/glusterfs/xlator.h
include/glusterfs/y.tab.h
%%GLUSTERLIBDIR%%/auth/addr.so
%%GLUSTERLIBDIR%%/auth/login.so
%%GLUSTERLIBDIR%%/rpc-transport/socket.so
@ -43,7 +142,6 @@ include/glusterfs/gfdb/gfdb_sqlite3_helper.h
%%GLUSTERLIBDIR%%/xlator/features/cdc.so
%%GLUSTERLIBDIR%%/xlator/features/changelog.so
%%GLUSTERLIBDIR%%/xlator/features/changetimerecorder.so
%%GLUSTERLIBDIR%%/xlator/features/ganesha.so
%%GLUSTERLIBDIR%%/xlator/features/gfid-access.so
%%GLUSTERLIBDIR%%/xlator/features/glupy.so
%%GLUSTERLIBDIR%%/xlator/features/glupy/debug-trace.py
@ -56,6 +154,7 @@ include/glusterfs/gfdb/gfdb_sqlite3_helper.h
%%GLUSTERLIBDIR%%/xlator/features/glupy/negative.pyc
%%GLUSTERLIBDIR%%/xlator/features/glupy/negative.pyo
%%GLUSTERLIBDIR%%/xlator/features/index.so
%%GLUSTERLIBDIR%%/xlator/features/leases.so
%%GLUSTERLIBDIR%%/xlator/features/locks.so
%%GLUSTERLIBDIR%%/xlator/features/mac-compat.so
%%GLUSTERLIBDIR%%/xlator/features/marker.so
@ -63,7 +162,6 @@ include/glusterfs/gfdb/gfdb_sqlite3_helper.h
%%GLUSTERLIBDIR%%/xlator/features/prot_client.so
%%GLUSTERLIBDIR%%/xlator/features/prot_dht.so
%%GLUSTERLIBDIR%%/xlator/features/prot_server.so
%%GLUSTERLIBDIR%%/xlator/features/qemu-block.so
%%GLUSTERLIBDIR%%/xlator/features/quiesce.so
%%GLUSTERLIBDIR%%/xlator/features/quota.so
%%GLUSTERLIBDIR%%/xlator/features/quotad.so
@ -79,6 +177,7 @@ include/glusterfs/gfdb/gfdb_sqlite3_helper.h
%%GLUSTERLIBDIR%%/xlator/mount/api.so
%%GLUSTERLIBDIR%%/xlator/mount/fuse.so
%%GLUSTERLIBDIR%%/xlator/nfs/server.so
%%GLUSTERLIBDIR%%/xlator/performance/decompounder.so
%%GLUSTERLIBDIR%%/xlator/performance/io-cache.so
%%GLUSTERLIBDIR%%/xlator/performance/io-threads.so
%%GLUSTERLIBDIR%%/xlator/performance/md-cache.so
@ -120,6 +219,12 @@ lib/ocf/resource.d/heartbeat/ganesha_nfsd
%%PYTHON_SITELIBDIR%%/gluster/__init__.py
%%PYTHON_SITELIBDIR%%/gluster/__init__.pyc
%%PYTHON_SITELIBDIR%%/gluster/__init__.pyo
%%PYTHON_SITELIBDIR%%/gluster/cliutils/__init__.py
%%PYTHON_SITELIBDIR%%/gluster/cliutils/__init__.pyc
%%PYTHON_SITELIBDIR%%/gluster/cliutils/__init__.pyo
%%PYTHON_SITELIBDIR%%/gluster/cliutils/cliutils.py
%%PYTHON_SITELIBDIR%%/gluster/cliutils/cliutils.pyc
%%PYTHON_SITELIBDIR%%/gluster/cliutils/cliutils.pyo
%%PYTHON_SITELIBDIR%%/gluster/glupy/__init__.py
%%PYTHON_SITELIBDIR%%/gluster/glupy/__init__.pyc
%%PYTHON_SITELIBDIR%%/gluster/glupy/__init__.pyo
@ -129,6 +234,26 @@ libdata/pkgconfig/libgfdb.pc
libexec/ganesha/create-export-ganesha.sh
libexec/ganesha/dbus-send.sh
libexec/ganesha/ganesha-ha.sh
libexec/ganesha/generate-epoch.py
libexec/glusterfs/events/__init__.py
libexec/glusterfs/events/__init__.pyc
libexec/glusterfs/events/__init__.pyo
libexec/glusterfs/events/eventsapiconf.py
libexec/glusterfs/events/eventsapiconf.pyc
libexec/glusterfs/events/eventsapiconf.pyo
libexec/glusterfs/events/eventtypes.py
libexec/glusterfs/events/eventtypes.pyc
libexec/glusterfs/events/eventtypes.pyo
libexec/glusterfs/events/gf_event.py
libexec/glusterfs/events/gf_event.pyc
libexec/glusterfs/events/gf_event.pyo
libexec/glusterfs/events/glustereventsd.py
libexec/glusterfs/events/handlers.py
libexec/glusterfs/events/handlers.pyc
libexec/glusterfs/events/handlers.pyo
libexec/glusterfs/events/utils.py
libexec/glusterfs/events/utils.pyc
libexec/glusterfs/events/utils.pyo
libexec/glusterfs/gfind_missing_files/gcrawler
libexec/glusterfs/gfind_missing_files/gfid_to_path.py
libexec/glusterfs/gfind_missing_files/gfid_to_path.sh
@ -157,40 +282,65 @@ libexec/glusterfs/glusterfind/utils.py
libexec/glusterfs/glusterfind/utils.pyc
libexec/glusterfs/glusterfind/utils.pyo
libexec/glusterfs/peer_add_secret_pub
libexec/glusterfs/peer_eventsapi.py
man/man8/gluster.8.gz
man/man8/glusterd.8.gz
man/man8/glusterfs.8.gz
man/man8/glusterfsd.8.gz
man/man8/mount.glusterfs.8.gz
sbin/conf.py
sbin/gcron.py
sbin/gfind_missing_files
sbin/glfsheal
sbin/gluster
sbin/gluster-eventsapi
sbin/glusterd
sbin/glustereventsd
sbin/glusterfs
sbin/glusterfsd
sbin/mount_glusterfs
sbin/snap_scheduler.py
sbin/umountd
%%DOCSDIR%%/benchmarking/README
%%DOCSDIR%%/benchmarking/glfs-bm.c
%%DOCSDIR%%/benchmarking/launch-script.sh
%%DOCSDIR%%/benchmarking/local-script.sh
%%DOCSDIR%%/benchmarking/rdd.c
%%DOCSDIR%%/glusterfs-mode.el
%%DOCSDIR%%/glusterfs.vim
%%PORTDOCS%%%%DOCSDIR%%/benchmarking/README
%%PORTDOCS%%%%DOCSDIR%%/benchmarking/glfs-bm.c
%%PORTDOCS%%%%DOCSDIR%%/benchmarking/launch-script.sh
%%PORTDOCS%%%%DOCSDIR%%/benchmarking/local-script.sh
%%PORTDOCS%%%%DOCSDIR%%/benchmarking/rdd.c
%%PORTDOCS%%%%DOCSDIR%%/glusterfs-mode.el
%%PORTDOCS%%%%DOCSDIR%%/glusterfs.vim
%%DATADIR%%/scripts/eventsdash.py
%%DATADIR%%/scripts/post-upgrade-script-for-quota.sh
%%DATADIR%%/scripts/pre-upgrade-script-for-quota.sh
%%DATADIR%%/scripts/stop-all-gluster-processes.sh
@sample /var/db/glusterd/groups/virt.sample
/var/db/glusterd/hooks/1/delete/post/S57glusterfind-delete-post.py
/var/db/glusterd/hooks/1/add-brick/post/disabled-quota-root-xattr-heal.sh
/var/db/glusterd/hooks/1/add-brick/pre/S28Quota-enable-root-xattr-heal.sh
/var/db/glusterd/hooks/1/delete/post/S57glusterfind-delete-post
/var/db/glusterd/hooks/1/reset/post/S31ganesha-reset.sh
/var/db/glusterd/hooks/1/set/post/S30samba-set.sh
/var/db/glusterd/hooks/1/set/post/S32gluster_enable_shared_storage.sh
/var/db/glusterd/hooks/1/start/post/S29CTDBsetup.sh
/var/db/glusterd/hooks/1/start/post/S30samba-start.sh
/var/db/glusterd/hooks/1/start/post/S31ganesha-start.sh
/var/db/glusterd/hooks/1/stop/pre/S29CTDB-teardown.sh
/var/db/glusterd/hooks/1/stop/pre/S30samba-stop.sh
@dir /var/db/glusterd/events
@dir /var/db/glusterd/glusterfind/.keys
@dir /var/db/glusterd/glusterfind
@dir /var/db/glusterd/groups
@dir /var/db/glusterd/hooks/1/add-brick/post
@dir /var/db/glusterd/hooks/1/add-brick/pre
@dir /var/db/glusterd/hooks/1/add-brick
@dir /var/db/glusterd/hooks/1/delete/post
@dir /var/db/glusterd/hooks/1/delete
@dir /var/db/glusterd/hooks/1/gsync-create/post
@dir /var/db/glusterd/hooks/1/gsync-create
@dir /var/db/glusterd/hooks/1/reset/post
@dir /var/db/glusterd/hooks/1/reset
@dir /var/db/glusterd/hooks/1/set/post
@dir /var/db/glusterd/hooks/1/set
@dir /var/db/glusterd/hooks/1/start/post
@dir /var/db/glusterd/hooks/1/start
@dir /var/db/glusterd/hooks/1/stop/pre
@dir /var/db/glusterd/hooks/1/stop
@dir /var/db/glusterd/hooks/1
@dir /var/db/glusterd/hooks
@dir /var/db/glusterd