Add UP-Imap-proxy, a caching IMAP proxy server.

This commit is contained in:
Martin Blapp 2004-05-12 12:47:19 +00:00
parent 9e63beafa4
commit 590fbecfba
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=109000
9 changed files with 136 additions and 0 deletions

View file

@ -0,0 +1,41 @@
# New ports collection makefile for: imapproxy
# Date created: 11.05.04
# Whom: Martin Blapp
#
# $FreeBSD$
#
PORTNAME= up-imapproxy
PORTVERSION= 1.2.1
CATEGORIES= mail
MASTER_SITES= http://www.imapproxy.org/downloads/
DISTNAME= ${PORTNAME}-${PORTVERSION}
EXTRACT_SUFX= .tar.gz
MAINTAINER= mbr@FreeBSD.org
COMMENT= A caching IMAP proxy server
GNU_CONFIGURE= YES
USE_AUTOCONF= YES
USE_RC_SUBR= YES
SAMPLE_EXT= sample
.include <bsd.port.pre.mk>
RC_SCRIPTS_SUB= PREFIX=${PREFIX} \
RC_SUBR=${RC_SUBR}
post-install:
@${SED} ${RC_SCRIPTS_SUB:S/$/!g/:S/^/ -e s!%%/:S/=/%%!/} \
< ${FILESDIR}/imapproxyd.conf > ${WRKSRC}/imapproxyd.conf ;
@if [ ! -f ${PREFIX}/etc/imapproxyd.conf ]; then \
${INSTALL} -c ${WRKSRC}/imapproxyd.conf ${PREFIX}/etc/imapproxyd.conf ; \
fi
${INSTALL} -c ${WRKSRC}/scripts/imapproxy.conf ${PREFIX}/etc/imapproxyd.conf.${SAMPLE_EXT} ;
@${SED} ${RC_SCRIPTS_SUB:S/$/!g/:S/^/ -e s!%%/:S/=/%%!/} \
< ${FILESDIR}/imapproxyd.sh > ${WRKSRC}/imapproxyd.sh
${INSTALL_SCRIPT} ${WRKSRC}/imapproxyd.sh ${PREFIX}/etc/rc.d/imapproxyd.sh
@${CAT} ${PKGMESSAGE}
.include <bsd.port.post.mk>

View file

@ -0,0 +1,2 @@
MD5 (up-imapproxy-1.2.1.tar.gz) = debd3edeb7441b9f713aaa9e9d7f2329
SIZE (up-imapproxy-1.2.1.tar.gz) = 111393

View file

@ -0,0 +1,11 @@
server_hostname yourserver.host.com
cache_size 10000
listen_port 10143
server_port 143
cache_expiration_time 60
proc_username nobody
proc_groupname nogroup
stat_filename /var/run/pimpstats
protocol_log_filename /var/log/imapproxy_protocol.log
syslog_facility LOG_MAIL
send_tcp_keepalives no

View file

@ -0,0 +1,25 @@
#!/bin/sh
#
# $FreeBSD$
#
# PROVIDE: imapproxyd
# REQUIRE: LOGIN
# BEFORE: mail
# KEYWORD: FreeBSD shutdown
#
# Add the following line to /etc/rc.conf to enable imapproxyd:
#
#imapproxyd_enable="YES"
#
. %%RC_SUBR%%
name=imapproxyd
rcvar=`set_rcvar`
command=%%PREFIX%%/sbin/in.imapproxyd
load_rc_config $name
run_rc_command "$1"

View file

@ -0,0 +1,11 @@
--- Makefile.in.orig Fri Nov 7 17:36:05 2003
+++ Makefile.in Wed May 12 14:37:33 2004
@@ -24,7 +24,7 @@
rpm_prefix = @rpm_prefix@
CC = @CC@
-CPPFLAGS = @CPPFLAGS@
+CPPFLAGS = @CPPFLAGS@ -DDEFAULT_CONFIG_FILE=\"$(prefix)/etc/imapproxyd.conf\"
LDFLAGS = @LDFLAGS@
LIBS = @LIBS@
DEFINES = @DEFINES@

View file

@ -0,0 +1,26 @@
--- configure.in.orig Wed May 12 14:17:03 2004
+++ configure.in Wed May 12 14:17:15 2004
@@ -86,23 +86,6 @@
LDFLAGS="${LDFLAGS} -L${with_libwrap}/lib"
fi
-
-dnl Check for libwrap
-save_LIBS="$LIBS"
-if test "$with_libwrap" != no; then
- AC_CHECK_LIB(nsl, yp_get_default_domain, , [
- with_libwrap=no
- AC_WARN([nsl library not found!!! Wrappers will be disabled.])
- ])
- if test "$with_libwrap" != no; then
- AC_CHECK_LIB(wrap, request_init, , [
- LIBS="$save_LIBS"
- AC_WARN([Wrappers library not found!!! Wrappers will be disabled.])
- ])
- fi
-fi
-
-
dnl Check for crypto library
AC_CHECK_LIB(crypto, EVP_DigestInit, ,
AC_ERROR([Can't compile without OpenSSL crypto library!!!])

View file

@ -0,0 +1,7 @@
The IMAP Proxy server is a caching IMAP proxy server.
It was written to reduce the load that Webmail clients
put on an IMAP server by keeping server connections
alive for reuse, thus avoiding a new server connection
for each Webmail transaction.
WWW: http://www.imapproxy.org

View file

@ -0,0 +1,9 @@
****************************************************************************
Please change the name of your mailserver in the imapproxyd.conf and setup
the correct ports.
To run the imapproxyd from startup, add imapproxyd_enable="YES" in your
/etc/rc.conf.
****************************************************************************

View file

@ -0,0 +1,4 @@
sbin/pimpstat
sbin/in.imapproxyd
etc/rc.d/imapproxyd.sh
etc/imapproxyd.conf.sample