- Add explicit dependency on gettext and phonon

- Remove no longer needed patch
- Use option helpers
- Support staging
This commit is contained in:
Max Brazhnikov 2013-10-10 20:31:30 +00:00
parent b71656f19e
commit 593046cbb1
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=330033
2 changed files with 13 additions and 35 deletions

View file

@ -10,34 +10,23 @@ MAINTAINER= makc@FreeBSD.org
COMMENT= Subtitle editor for KDE
USE_BZIP2= yes
USES= cmake
USES= cmake:outsource gettext
USE_KDE4= kdeprefix kdelibs automoc4 sharedmime
USE_QT4= gui qmake_build moc_build rcc_build uic_build
USE_QT4= qmake_build moc_build rcc_build uic_build phonon
OPTIONS_DEFINE= GSTREAMER MPLAYER XINE
OPTIONS_DEFAULT= MPLAYER
OPTIONS_GROUP= BACKEND
BACKEND_DESC= Additional video backens
OPTIONS_GROUP_BACKEND= GSTREAMER MPLAYER XINE
MPLAYER_DESC= Enable MPlayer backend (recommended)
XINE_DESC= Enable Xine backend
GSTREAMER_DESC= Enable GStreamer backend (broken)
MPLAYER_DESC= Install MPlayer
MPLAYER_RUN_DEPENDS= mplayer:${PORTSDIR}/multimedia/mplayer
NO_STAGE= yes
.include <bsd.port.options.mk>
XINE_DESC= Build Xine backend
XINE_LIB_DEPENDS= libxine.so:${PORTSDIR}/multimedia/libxine
XINE_CMAKE_OFF= -DWITH_Xine:Bool=Off
.if ${PORT_OPTIONS:MMPLAYER}
RUN_DEPENDS+= mplayer:${PORTSDIR}/multimedia/mplayer
.endif
.if ${PORT_OPTIONS:MXINE}
LIB_DEPENDS+= libxine.so:${PORTSDIR}/multimedia/libxine
.else
CMAKE_ARGS+= -DWITH_Xine:Bool=Off
.endif
.if ${PORT_OPTIONS:MGSTREAMER}
USE_GSTREAMER= yes
.else
CMAKE_ARGS+= -DWITH_GStreamer:Bool=Off
.endif
GSTREAMER_DESC= Build GStreamer backend (broken)
GSTREAMER_USE= GSTREAMER=yes
GSTREAMER_CMAKE_OFF= -DWITH_GStreamer:Bool=Off
.include <bsd.port.mk>

View file

@ -1,11 +0,0 @@
--- ./src/core/subtitleline.cpp.orig 2008-01-08 09:16:27.000000000 +0300
+++ ./src/core/subtitleline.cpp 2008-01-08 15:54:39.000000000 +0300
@@ -41,7 +41,7 @@
if ( flag < 1 )
return ErrorUNKNOWN;
- int id = (int)log2( flag );
+ int id = int( log( flag ) * M_LN2 );
return id < ErrorSIZE ? (ErrorID)id : ErrorUNKNOWN;
}