o Update to 0.9.6
o bump PORTEPOCH since this version number is smaller than former one o Update WWW
This commit is contained in:
parent
e72e92318b
commit
595d305be5
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=53416
14 changed files with 97 additions and 215 deletions
|
@ -6,15 +6,46 @@
|
|||
#
|
||||
|
||||
PORTNAME= kwebwatch
|
||||
PORTVERSION= 0.72
|
||||
PORTVERSION= 0.9.6
|
||||
PORTEPOCH= 1
|
||||
CATEGORIES= www kde
|
||||
MASTER_SITES= http://linuxberg.uol.com.br/files/kde/network/
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
|
||||
MASTER_SITE_SUBDIR= ${PORTNAME}
|
||||
|
||||
MAINTAINER= lioux@FreeBSD.org
|
||||
|
||||
USE_KDELIBS_VER=1
|
||||
LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
|
||||
png.5:${PORTSDIR}/graphics/png
|
||||
|
||||
USE_BZIP2= yes
|
||||
USE_KDELIBS_VER= 2
|
||||
USE_XLIB= yes
|
||||
GNU_CONFIGURE= yes
|
||||
USE_GMAKE= yes
|
||||
CONFIGURE_ARGS= --with-qt-dir=${X11BASE} \
|
||||
--with-qt-includes=${X11BASE}/include \
|
||||
--with-qt-libraries=${X11BASE}/lib \
|
||||
--with-extra-includes=${LOCALBASE}/include \
|
||||
--with-extra-libs=${LOCALBASE}/lib \
|
||||
--x-includes=${X11BASE}/include \
|
||||
--x-libraries=${X11BASE}/lib
|
||||
CONFIGURE_ENV= KDEDIR="${LOCALBASE}" CFLAGS="${CFLAGS} -g" \
|
||||
CXXFLAGS="${CXXFLAGS} -g"
|
||||
|
||||
MAN1= kwebwatch.1
|
||||
|
||||
post-patch:
|
||||
@${PERL} -pi -e "s!-O2!!;s!-pthread!${PTHREAD_LIBS} \
|
||||
${PTHREAD_CFLAGS}!" ${WRKSRC}/configure
|
||||
@${PERL} -pi -e 's!/usr/bin/perl!${PERL}!' \
|
||||
${WRKSRC}/kwebwatch/kwebdiff
|
||||
@${PERL} -pi -e 's!(#define.+$$)!\1\n#include <sys/types.h>!' \
|
||||
${WRKSRC}/libwebwatch/url.h
|
||||
@${PERL} -pi.orig -e 's!^(#include "util.h".*)$$!\1\n#include <time.h>!' ${WRKSRC}/libwebwatch/util.cpp
|
||||
@${PERL} -pi.orig -e 's!^(#include <stdlib.h>.*)$$!\1\n#include <sys/types.h>!' ${WRKSRC}/libwebwatch/web.cpp
|
||||
@${PERL} -pi.orig -e \
|
||||
's!(ln -s )\$$\(kde_htmldir\)(/en/common)/( \$$\(kde_htmldir\)/en/kwebwatch/)!\1${LOCALBASE}/share/doc/HTML/\2\3!' \
|
||||
${WRKSRC}/kwebwatch/Makefile.in
|
||||
@${FIND} ${WRKSRC} -type f | ${XARGS} -n 10 ${PERL} -pi -e 's!kdiff!kwebdiff!g'
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1 +1 @@
|
|||
MD5 (kwebwatch-0.72.tar.gz) = ae4b4fad8ad7e8fa3d4ee3e38f1e74a2
|
||||
MD5 (kwebwatch-0.9.6.tar.bz2) = b48e5bbd8a891d9e95aa66bd8e2b1ab0
|
||||
|
|
|
@ -1,42 +0,0 @@
|
|||
--- kwebwatch/main.cpp.orig Sun Aug 8 19:10:47 1999
|
||||
+++ kwebwatch/main.cpp Sat Jun 17 02:49:46 2000
|
||||
@@ -23,14 +23,20 @@
|
||||
|
||||
/* main.cpp */
|
||||
|
||||
+#if defined(HAVE_CONFIG_H)
|
||||
+#include <../config.h>
|
||||
+#endif
|
||||
|
||||
+#if defined(HAVE_SYS_PARAM_H)
|
||||
+#include <sys/param.h>
|
||||
+#endif
|
||||
|
||||
#include <kapp.h>
|
||||
#include <signal.h>
|
||||
|
||||
#include "mainwidget.h"
|
||||
|
||||
-#if defined(__hpux)
|
||||
+#if defined(__hpux) || (defined(BSD) && (BSD >= 199103))
|
||||
static void SigChild(int)
|
||||
{
|
||||
int pid;
|
||||
@@ -69,6 +75,9 @@
|
||||
// With SysV all we need to do is ignore the signal.
|
||||
// With BSD, however, we have to catch each signal
|
||||
// and execute the wait3() system call.
|
||||
+#if (defined(BSD) && (BSD >= 199103))
|
||||
+ signal(SIGCHLD, SigChild);
|
||||
+#else
|
||||
#if defined(__hpux)
|
||||
signal(SIGCLD, SigChild);
|
||||
#else
|
||||
@@ -82,6 +91,7 @@
|
||||
sigignore(SIGCHLD);
|
||||
#else
|
||||
signal(SIGCLD, SIG_IGN);
|
||||
+#endif
|
||||
#endif
|
||||
#endif
|
||||
|
|
@ -1,11 +0,0 @@
|
|||
--- configure.in.orig Wed Aug 19 21:29:58 1998
|
||||
+++ configure.in Sat Jun 17 02:46:57 2000
|
||||
@@ -41,7 +41,7 @@
|
||||
dnl Checks for header files.
|
||||
AC_HEADER_DIRENT
|
||||
AC_HEADER_STDC
|
||||
-AC_CHECK_HEADERS(fcntl.h sys/time.h unistd.h sys/types.h sys/stat.h re_comp.h net/errno.h getopt.h sys/param.h)
|
||||
+AC_CHECK_HEADERS(fcntl.h ndbm.h sys/time.h unistd.h sys/types.h sys/stat.h re_comp.h net/errno.h getopt.h sys/param.h)
|
||||
AC_CHECK_FUNCS(flock)
|
||||
|
||||
dnl Checks for typedefs, structures, and compiler characteristics.
|
|
@ -1,48 +0,0 @@
|
|||
--- kwebwatch/mainwidget.cpp.orig Sat Jun 17 02:52:31 2000
|
||||
+++ kwebwatch/mainwidget.cpp Sat Jun 17 02:52:41 2000
|
||||
@@ -24,6 +24,14 @@
|
||||
|
||||
#define DB_DBM_HSEARCH 1
|
||||
|
||||
+#if defined(HAVE_CONFIG_H)
|
||||
+#include <../config.h>
|
||||
+#endif
|
||||
+
|
||||
+#if defined(HAVE_NDBM_H)
|
||||
+#include <ndbm.h>
|
||||
+#endif
|
||||
+
|
||||
#include "mainwidget.h"
|
||||
#include <qdatetm.h>
|
||||
#include <qpainter.h>
|
||||
@@ -662,7 +670,7 @@
|
||||
|
||||
void MainWidget::UpdateListBox( UrlItem* pItem, bool checked_this_session )
|
||||
{
|
||||
- QColor color;
|
||||
+ QColor color,nullcolor;
|
||||
int position;
|
||||
QString item_text = pItem->GetAlias();
|
||||
int result;
|
||||
@@ -695,7 +703,7 @@
|
||||
switch( result )
|
||||
{
|
||||
case NOT_YET_CHECKED:
|
||||
- color = NULL;
|
||||
+ color = nullcolor;
|
||||
break;
|
||||
case UPDATE_FOUND: /* FALLTHRU */
|
||||
case CHECK_NOT_NEEDED:
|
||||
@@ -704,10 +712,10 @@
|
||||
pPix = new QPixmap( g_pics_dir+ "/kww_new.xpm" );
|
||||
break;
|
||||
case UPDATE_READ:
|
||||
- color = NULL;
|
||||
+ color = nullcolor;
|
||||
break;
|
||||
case NO_CHANGE:
|
||||
- color = NULL;
|
||||
+ color = nullcolor;
|
||||
break;
|
||||
case CONNECT_FAILED:
|
||||
color = CONNECT_FAILED_COLOR;
|
|
@ -1,12 +0,0 @@
|
|||
--- kwebwatch/options.h.orig Sat Jul 1 01:51:18 2000
|
||||
+++ kwebwatch/options.h Sat Jul 1 01:53:11 2000
|
||||
@@ -26,6 +26,9 @@
|
||||
#ifndef OPTIONS_H
|
||||
#define OPTIONS_H
|
||||
|
||||
+#include <sys/types.h>
|
||||
+#include <limits.h>
|
||||
+
|
||||
#include <qdialog.h>
|
||||
#include <qpushbt.h>
|
||||
#include <qlined.h>
|
|
@ -1,11 +0,0 @@
|
|||
--- kwebwatch/urlitem.h.orig Sat Jul 1 01:51:42 2000
|
||||
+++ kwebwatch/urlitem.h Sat Jul 1 01:57:26 2000
|
||||
@@ -29,7 +29,7 @@
|
||||
#define DB_DBM_HSEARCH 1
|
||||
|
||||
#include <kmsgbox.h>
|
||||
-#include <db.h>
|
||||
+#include <ndbm.h>
|
||||
#include <fcntl.h>
|
||||
#include <stdlib.h>
|
||||
#include <unistd.h>
|
|
@ -1,11 +0,0 @@
|
|||
--- kwebwatch/utils.cpp.orig Sat Jul 1 02:03:06 2000
|
||||
+++ kwebwatch/utils.cpp Sat Jul 1 02:06:15 2000
|
||||
@@ -133,7 +133,7 @@
|
||||
bool FirstInstance(long* pid)
|
||||
{
|
||||
bool first_instance = true;
|
||||
- flock lock;
|
||||
+ struct flock lock;
|
||||
int fd = 0;
|
||||
|
||||
QString local_data_dir = kapp->localkdedir() + "/share/apps/kwebwatch";
|
|
@ -1,10 +0,0 @@
|
|||
--- kwebwatch/web.h.orig Sat Jul 1 02:16:56 2000
|
||||
+++ kwebwatch/web.h Sat Jul 1 02:17:12 2000
|
||||
@@ -26,6 +26,7 @@
|
||||
#ifndef WEB_H
|
||||
#define WEB_H
|
||||
|
||||
+#include <sys/types.h>
|
||||
#include <sys/socket.h> /* basic socket definitions */
|
||||
#include <sys/time.h> /* timeval{} for select() */
|
||||
#include <errno.h>
|
|
@ -1,12 +0,0 @@
|
|||
--- kwebwatch/web.cpp.orig Sat Jul 1 02:16:33 2000
|
||||
+++ kwebwatch/web.cpp Sat Jul 1 02:16:40 2000
|
||||
@@ -27,8 +27,8 @@
|
||||
// by W. Richard Stevens
|
||||
#include <stdlib.h>
|
||||
#include <qapp.h>
|
||||
-#include <netinet/in.h> /* if I include this from web.h, compile fails !?! */
|
||||
#include "web.h"
|
||||
+#include <netinet/in.h> /* if I include this from web.h, compile fails !?! */
|
||||
|
||||
/* Write "n" bytes to a descriptor. */
|
||||
ssize_t writen(int fd, const void *vptr, size_t n)
|
|
@ -1,11 +0,0 @@
|
|||
--- kwebwatch/Makefile.in.orig Sat Jul 1 02:26:48 2000
|
||||
+++ kwebwatch/Makefile.in Sat Jul 1 02:26:56 2000
|
||||
@@ -169,7 +169,7 @@
|
||||
|
||||
# the libraries to link against. Be aware of the order. First the libraries,
|
||||
# that depend on the following ones.
|
||||
-kwebwatch_LDADD = -ldb -lkdeui -lkdecore -lkfile -lkfm -lqt -lX11 -lXext @LIBSOCKET@
|
||||
+kwebwatch_LDADD = -lkdeui -lkdecore -lkfile -lkfm -lqt -lX11 -lXext @LIBSOCKET@
|
||||
|
||||
# this option you can leave out. Just, if you use "make dist", you need it
|
||||
#noinst_HEADERS = main.h mainwidget.h dockwidget.h mainlistbox.h \
|
|
@ -1,19 +0,0 @@
|
|||
--- kwebwatch/utils.h.orig Sat Jul 1 03:35:28 2000
|
||||
+++ kwebwatch/utils.h Sat Jul 1 03:44:47 2000
|
||||
@@ -37,10 +37,14 @@
|
||||
"Jul", "Aug", "Sep", "Oct", "Nov", "Dec" };
|
||||
|
||||
const char* const timechoices[] = { "6 hours", "24 hours", "12 hours", "3 hours",
|
||||
- "1 hour", "30 minutes", "10 minutes", 0 };
|
||||
+ "1 hour", "30 minutes", "10 minutes",
|
||||
+ "1 week", "1 month", "3 months",
|
||||
+ "6 months", "1 year", 0 };
|
||||
|
||||
const int time_in_seconds[] = { 6*60*60, 24*60*60, 12*60*60,
|
||||
- 3*60*60, 60*60, 30*60, 10*60 };
|
||||
+ 3*60*60, 60*60, 30*60, 10*60,
|
||||
+ 7*24*60*60, 30*24*60*60, 3*30*24*60*60,
|
||||
+ 6*30*24*60*60, 365*24*60*60 };
|
||||
|
||||
QDateTime* GetDateTimeFromString( QString str );
|
||||
QString StripTime( QDateTime dt );
|
|
@ -4,4 +4,4 @@ Additionally, KWebWatch serves as a launching pad for viewing
|
|||
favorite web sites, using whatever browser is preferred on a URL
|
||||
by URL basis.
|
||||
|
||||
WWW: http://linuxberg.uol.com.br/kdehtml/preview/021-008-008-013C.html
|
||||
WWW: http://kwebwatch.sourceforge.net/
|
||||
|
|
|
@ -1,25 +1,63 @@
|
|||
bin/kwebdiff
|
||||
bin/kwebwatch
|
||||
share/applnk/Internet/kwebwatch.kdelnk
|
||||
share/apps/kwebwatch/pics/kww_eye.xpm
|
||||
share/apps/kwebwatch/pics/kww_eye_new.xpm
|
||||
share/apps/kwebwatch/pics/kww_green-bullet.xpm
|
||||
share/apps/kwebwatch/pics/kww_grey-bullet.xpm
|
||||
share/apps/kwebwatch/pics/kww_new.xpm
|
||||
share/apps/kwebwatch/pics/kww_red-bullet.xpm
|
||||
share/doc/HTML/en/kwebwatch/index.html
|
||||
share/doc/HTML/en/kwebwatch/kwebwatch-1.html
|
||||
share/doc/HTML/en/kwebwatch/kwebwatch-10.html
|
||||
share/doc/HTML/en/kwebwatch/kwebwatch-2.html
|
||||
share/doc/HTML/en/kwebwatch/kwebwatch-3.html
|
||||
share/doc/HTML/en/kwebwatch/kwebwatch-4.html
|
||||
share/doc/HTML/en/kwebwatch/kwebwatch-5.html
|
||||
share/doc/HTML/en/kwebwatch/kwebwatch-6.html
|
||||
share/doc/HTML/en/kwebwatch/kwebwatch-7.html
|
||||
share/doc/HTML/en/kwebwatch/kwebwatch-8.html
|
||||
share/doc/HTML/en/kwebwatch/kwebwatch-9.html
|
||||
share/doc/HTML/en/kwebwatch/logotp3.gif
|
||||
share/icons/kwebwatch.xpm
|
||||
share/icons/mini/kwebwatch.xpm
|
||||
@dirrm share/apps/kwebwatch/pics
|
||||
@dirrm share/apps/kwebwatch
|
||||
lib/libwebwatch.la
|
||||
lib/libwebwatch.so
|
||||
lib/libwebwatch.so.0
|
||||
share/applnk/Applications/kwebwatch.desktop
|
||||
share/apps/kwebwatch/icons/hicolor/16x16/actions/file_broken.png
|
||||
share/apps/kwebwatch/icons/hicolor/16x16/actions/filenew.png
|
||||
share/apps/kwebwatch/icons/hicolor/16x16/actions/folder.png
|
||||
share/apps/kwebwatch/icons/hicolor/16x16/actions/folder_new.png
|
||||
share/apps/kwebwatch/icons/hicolor/16x16/actions/html.png
|
||||
share/apps/kwebwatch/icons/hicolor/16x16/actions/kicker.png
|
||||
share/apps/kwebwatch/icons/hicolor/16x16/actions/kww_eye.png
|
||||
share/apps/kwebwatch/icons/hicolor/16x16/actions/kww_eye_new.png
|
||||
share/apps/kwebwatch/icons/hicolor/16x16/actions/kww_new.png
|
||||
share/apps/kwebwatch/icons/hicolor/16x16/actions/remove.png
|
||||
share/apps/kwebwatch/icons/hicolor/16x16/actions/socket.png
|
||||
share/apps/kwebwatch/icons/hicolor/16x16/actions/view_text.png
|
||||
share/apps/kwebwatch/icons/hicolor/16x16/apps/kwebwatch.png
|
||||
share/apps/kwebwatch/icons/locolor/16x16/actions/file_broken.png
|
||||
share/apps/kwebwatch/icons/locolor/16x16/actions/filenew.png
|
||||
share/apps/kwebwatch/icons/locolor/16x16/actions/folder.png
|
||||
share/apps/kwebwatch/icons/locolor/16x16/actions/html.png
|
||||
share/apps/kwebwatch/icons/locolor/16x16/actions/kicker.png
|
||||
share/apps/kwebwatch/icons/locolor/16x16/actions/kww_eye.png
|
||||
share/apps/kwebwatch/icons/locolor/16x16/actions/kww_eye_new.png
|
||||
share/apps/kwebwatch/icons/locolor/16x16/actions/kww_new.png
|
||||
share/apps/kwebwatch/icons/locolor/16x16/actions/remove.png
|
||||
share/apps/kwebwatch/icons/locolor/16x16/actions/socket.png
|
||||
share/apps/kwebwatch/icons/locolor/16x16/actions/view_text.png
|
||||
share/apps/kwebwatch/icons/locolor/16x16/apps/kwebwatch.png
|
||||
share/apps/kwebwatch/icons/locolor/32x32/apps/kwebwatch.png
|
||||
share/apps/kwebwatch/kwebwatchui.rc
|
||||
share/doc/HTML/en/kwebwatch/common
|
||||
share/doc/HTML/en/kwebwatch/index.docbook
|
||||
share/doc/HTML/en/kwebwatch/popup.png
|
||||
share/doc/HTML/en/kwebwatch/status.png
|
||||
share/icons/locolor/16x16/apps/kwebwatch.png
|
||||
share/icons/locolor/32x32/apps/kwebwatch.png
|
||||
@unexec rmdir %D/share/icons/locolor/32x32/apps 2>/dev/null || true
|
||||
@unexec rmdir %D/share/icons/locolor/32x32 2>/dev/null || true
|
||||
@unexec rmdir %D/share/icons/locolor/16x16/apps 2>/dev/null || true
|
||||
@unexec rmdir %D/share/icons/locolor/16x16 2>/dev/null || true
|
||||
@unexec rmdir %D/share/icons/locolor 2>/dev/null || true
|
||||
@unexec rmdir %D/share/icons 2>/dev/null || true
|
||||
@dirrm share/doc/HTML/en/kwebwatch
|
||||
@unexec rmdir %D/share/doc/HTML/en 2>/dev/null || true
|
||||
@unexec rmdir %D/share/doc/HTML 2>/dev/null || true
|
||||
@dirrm share/apps/kwebwatch/icons/locolor/32x32/apps
|
||||
@dirrm share/apps/kwebwatch/icons/locolor/32x32
|
||||
@dirrm share/apps/kwebwatch/icons/locolor/16x16/apps
|
||||
@dirrm share/apps/kwebwatch/icons/locolor/16x16/actions
|
||||
@dirrm share/apps/kwebwatch/icons/locolor/16x16
|
||||
@dirrm share/apps/kwebwatch/icons/locolor
|
||||
@dirrm share/apps/kwebwatch/icons/hicolor/16x16/apps
|
||||
@dirrm share/apps/kwebwatch/icons/hicolor/16x16/actions
|
||||
@dirrm share/apps/kwebwatch/icons/hicolor/16x16
|
||||
@dirrm share/apps/kwebwatch/icons/hicolor
|
||||
@dirrm share/apps/kwebwatch/icons
|
||||
@dirrm share/apps/kwebwatch
|
||||
@unexec rmdir %D/share/apps 2>/dev/null || true
|
||||
@unexec rmdir %D/share/applnk/Applications 2>/dev/null || true
|
||||
@unexec rmdir %D/share/applnk 2>/dev/null || true
|
||||
|
|
Loading…
Reference in a new issue