Update to 0.15.
PR: 131782 Submitted by: maintainer
This commit is contained in:
parent
5e1787a59d
commit
5969150174
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=228584
3 changed files with 46 additions and 6 deletions
|
@ -6,14 +6,16 @@
|
||||||
#
|
#
|
||||||
|
|
||||||
PORTNAME= btpd
|
PORTNAME= btpd
|
||||||
PORTVERSION= 0.13
|
PORTVERSION= 0.15
|
||||||
CATEGORIES= net-p2p
|
CATEGORIES= net-p2p
|
||||||
MASTER_SITES= http://www.murmeldjur.se/btpd/
|
MASTER_SITES= http://www.murmeldjur.se/btpd/
|
||||||
|
|
||||||
MAINTAINER= baptiste.daroussin@gmail.com
|
MAINTAINER= baptiste.daroussin@gmail.com
|
||||||
COMMENT= Bittorrent client consisting of a daemon and client commands
|
COMMENT= Bittorrent client consisting of a daemon and client commands
|
||||||
|
|
||||||
|
USE_AUTOTOOLS= autoconf:262 aclocal:110
|
||||||
GNU_CONFIGURE= yes
|
GNU_CONFIGURE= yes
|
||||||
|
|
||||||
PLIST_FILES= bin/btcli \
|
PLIST_FILES= bin/btcli \
|
||||||
bin/btinfo \
|
bin/btinfo \
|
||||||
bin/btpd
|
bin/btpd
|
||||||
|
@ -22,8 +24,8 @@ PORTDOCS= README
|
||||||
|
|
||||||
post-install:
|
post-install:
|
||||||
.if !defined(NOPORTDOCS)
|
.if !defined(NOPORTDOCS)
|
||||||
${MKDIR} ${DOCSDIR}
|
@${MKDIR} ${DOCSDIR}
|
||||||
@${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${DOCSDIR}/
|
${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${DOCSDIR}/
|
||||||
.endif
|
.endif
|
||||||
|
|
||||||
.include <bsd.port.mk>
|
.include <bsd.port.mk>
|
||||||
|
|
|
@ -1,3 +1,3 @@
|
||||||
MD5 (btpd-0.13.tar.gz) = 0d9c4a672eea6f298fa6e44d94da1657
|
MD5 (btpd-0.15.tar.gz) = b64e2e8b9936e99685bc1e7246655561
|
||||||
SHA256 (btpd-0.13.tar.gz) = 4409ec8e34eaba5d51e53bf94ce8551e438a4b2c5a55924299edf012c189ebfc
|
SHA256 (btpd-0.15.tar.gz) = c2229244c3cb370ac95560e2e9ff7f5d094612ee2b2a1e36237ec7f27707db9d
|
||||||
SIZE (btpd-0.13.tar.gz) = 273814
|
SIZE (btpd-0.15.tar.gz) = 144706
|
||||||
|
|
38
net-p2p/btpd/files/patch-configure.ac
Normal file
38
net-p2p/btpd/files/patch-configure.ac
Normal file
|
@ -0,0 +1,38 @@
|
||||||
|
--- ./configure.ac.orig 2009-02-09 22:04:53.000000000 +0100
|
||||||
|
+++ ./configure.ac 2009-02-17 15:00:30.648730460 +0100
|
||||||
|
@@ -56,7 +56,7 @@
|
||||||
|
int main(void) { return clock_gettime(CLOCK_MONOTONIC, (void *)0); }
|
||||||
|
], clock_gettime=yes, clock_gettime=no)
|
||||||
|
AC_MSG_RESULT($clock_gettime)
|
||||||
|
-if test $clock_gettime == yes; then
|
||||||
|
+if test $clock_gettime = yes; then
|
||||||
|
old_LIBS=$LIBS
|
||||||
|
LIBS=""
|
||||||
|
AC_SEARCH_LIBS(clock_gettime,rt,clock_gettime=yes,clock_gettime=no)
|
||||||
|
@@ -64,7 +64,7 @@
|
||||||
|
LIBS=$old_LIBS
|
||||||
|
AC_DEFINE(HAVE_CLOCK_MONOTONIC)
|
||||||
|
fi
|
||||||
|
-if test $clock_gettime == no; then
|
||||||
|
+if test $clock_gettime = no; then
|
||||||
|
AC_CHECK_FUNCS(mach_absolute_time,,
|
||||||
|
AC_MSG_FAILURE(no supported time mechanism found))
|
||||||
|
fi
|
||||||
|
@@ -108,7 +108,7 @@
|
||||||
|
;;
|
||||||
|
esac
|
||||||
|
done
|
||||||
|
-if test x"$EVLOOP_METHOD" == x; then
|
||||||
|
+if test x"$EVLOOP_METHOD" = x; then
|
||||||
|
AC_MSG_FAILURE(no suitable evloop method found)
|
||||||
|
exit 1
|
||||||
|
else
|
||||||
|
@@ -117,7 +117,7 @@
|
||||||
|
|
||||||
|
for i in 0 1 2 3 4 5 6 7; do
|
||||||
|
case $i in
|
||||||
|
- 0) if test x"$TD_CFLAGS$TD_LIBS" == x; then continue; fi;;
|
||||||
|
+ 0) if test x"$TD_CFLAGS$TD_LIBS" = x; then continue; fi;;
|
||||||
|
1) TD_CFLAGS=-pthread;;
|
||||||
|
2) TD_CFLAGS=-pthreads;;
|
||||||
|
3) TD_CFLAGS=-kthread;;
|
Loading…
Reference in a new issue