- Unbreak on amd64: sneak template config.* files into bundled tarball
of libnids - Unbreak on ia64: add -fPIC for shared library Approved by: portmgr (marcus)
This commit is contained in:
parent
870498d268
commit
5983d1b71c
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=140807
2 changed files with 28 additions and 0 deletions
|
@ -22,6 +22,14 @@ USE_PYTHON= yes
|
|||
USE_PYDISTUTILS= yes
|
||||
USE_PYTHON_PREFIX= yes
|
||||
|
||||
CFLAGS+= -fPIC
|
||||
|
||||
PLIST_FILES= %%PYTHON_SITELIBDIR%%/nidsmodule.so
|
||||
|
||||
post-patch:
|
||||
${CP} -f ${TEMPLATES}/config.guess ${WRKSRC}
|
||||
${CHMOD} a+rx ${WRKSRC}/config.guess
|
||||
${CP} -f ${TEMPLATES}/config.sub ${WRKSRC}
|
||||
${CHMOD} a+rx ${WRKSRC}/config.sub
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
20
net/pynids/files/patch-setup.py
Normal file
20
net/pynids/files/patch-setup.py
Normal file
|
@ -0,0 +1,20 @@
|
|||
--- setup.py.orig Tue Feb 1 06:50:11 2005
|
||||
+++ setup.py Sun Aug 7 00:08:43 2005
|
||||
@@ -9,7 +9,7 @@
|
||||
from distutils.core import setup, Extension
|
||||
from distutils.command.build import build # nidsMaker
|
||||
from distutils.spawn import spawn # nidsMaker.run()
|
||||
-import os, os.path
|
||||
+import os, os.path, shutil
|
||||
|
||||
pathjoin = os.path.join
|
||||
|
||||
@@ -38,6 +38,8 @@
|
||||
pass
|
||||
|
||||
spawn(['tar', '-xf', self.NIDSTAR], search_path = 1)
|
||||
+ shutil.copyfile("config.guess",pathjoin(self.NIDSDIR,"config.guess"))
|
||||
+ shutil.copyfile("config.sub",pathjoin(self.NIDSDIR,"config.sub"))
|
||||
os.chdir(self.NIDSDIR)
|
||||
for p in self.patches:
|
||||
spawn(['patch', '-c', '-p1', '-i', pathjoin('..', p)], search_path = 1)
|
Loading…
Reference in a new issue