devel/rubygem-execjs-node16: Remove obsoleted port
Use devel/rubygem-execjs instead.
This commit is contained in:
parent
2fb04e7f07
commit
59878ea317
6 changed files with 1 additions and 42 deletions
1
MOVED
1
MOVED
|
@ -17500,3 +17500,4 @@ misc/cxxmatrix|games/cxxmatrix|2022-07-10|Move to a more appropriate category
|
|||
devel/ChipmunkPhysics|science/ChipmunkPhysics|2022-07-13|Move to a more appropriate category
|
||||
textproc/rubygem-escape_utils12|textproc/rubygem-escape_utils|2022-07-13|Remove obsoleted port. Use textproc/rubygem-escape_utils instead
|
||||
net/rubygem-omniauth-oauth2-v1|net/rubygem-omniauth-oauth2|2022-07-13|Remove obsoleted port. Use net/rubygem-omniauth-oauth2 instead
|
||||
devel/rubygem-execjs-node16|devel/rubygem-execjs|2022-07-13|Remove obsoleted port. Use devel/rubygem-execjs instead
|
||||
|
|
|
@ -6342,7 +6342,6 @@
|
|||
SUBDIR += rubygem-eventmachine
|
||||
SUBDIR += rubygem-excon
|
||||
SUBDIR += rubygem-execjs
|
||||
SUBDIR += rubygem-execjs-node16
|
||||
SUBDIR += rubygem-extlib
|
||||
SUBDIR += rubygem-extras
|
||||
SUBDIR += rubygem-facets
|
||||
|
|
|
@ -1,24 +0,0 @@
|
|||
# Created by: Steve Wills <swills@FreeBSD.org>
|
||||
|
||||
PORTNAME= execjs
|
||||
PORTVERSION= 2.8.1
|
||||
PORTREVISION= 2
|
||||
CATEGORIES= devel rubygems
|
||||
MASTER_SITES= RG
|
||||
PKGNAMESUFFIX= -node16
|
||||
|
||||
MAINTAINER= sunpoet@FreeBSD.org
|
||||
COMMENT= ExecJS lets you run JavaScript code from Ruby
|
||||
|
||||
LICENSE= MIT
|
||||
LICENSE_FILE= ${WRKSRC}/MIT-LICENSE
|
||||
|
||||
USES= gem nodejs:16,run
|
||||
USE_RUBY= yes
|
||||
|
||||
NO_ARCH= yes
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|' ${WRKSRC}/lib/execjs/runtimes.rb
|
||||
|
||||
.include <bsd.port.mk>
|
|
@ -1,3 +0,0 @@
|
|||
TIMESTAMP = 1624630282
|
||||
SHA256 (rubygem/execjs-2.8.1.gem) = 6d939919cfd81bcc4d6556f322c3995a70cfe4289ea0bd3b1f999b489c323088
|
||||
SIZE (rubygem/execjs-2.8.1.gem) = 17408
|
|
@ -1,11 +0,0 @@
|
|||
--- lib/execjs/runtimes.rb.orig 2021-06-28 15:24:59 UTC
|
||||
+++ lib/execjs/runtimes.rb
|
||||
@@ -17,7 +17,7 @@ module ExecJS
|
||||
|
||||
Node = ExternalRuntime.new(
|
||||
name: "Node.js (V8)",
|
||||
- command: ["node", "nodejs"],
|
||||
+ command: ["%%LOCALBASE%%/bin/node", "node", "nodejs"],
|
||||
runner_path: ExecJS.root + "/support/node_runner.js",
|
||||
encoding: 'UTF-8'
|
||||
)
|
|
@ -1,3 +0,0 @@
|
|||
ExecJS lets you run JavaScript code from Ruby.
|
||||
|
||||
WWW: https://github.com/rails/execjs
|
Loading…
Reference in a new issue