Add net/smcroute, a simple, static multicast routing tool.
This commit is contained in:
parent
7c2f52cc85
commit
59b3260bfc
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=396339
7 changed files with 140 additions and 0 deletions
|
@ -1168,6 +1168,7 @@
|
|||
SUBDIR += slurm
|
||||
SUBDIR += smb4k-kde4
|
||||
SUBDIR += smbldap-tools
|
||||
SUBDIR += smcroute
|
||||
SUBDIR += smm++
|
||||
SUBDIR += sniffit
|
||||
SUBDIR += sntop
|
||||
|
|
28
net/smcroute/Makefile
Normal file
28
net/smcroute/Makefile
Normal file
|
@ -0,0 +1,28 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME= smcroute
|
||||
PORTVERSION= 2.0.0
|
||||
CATEGORIES= net
|
||||
|
||||
MAINTAINER= hrs@FreeBSD.org
|
||||
COMMENT= Static multicast routing tool
|
||||
|
||||
LICENSE= GPLv2
|
||||
|
||||
USES= tar:bzip2
|
||||
USE_RC_SUBR= ${PORTNAME}
|
||||
USE_GITHUB= yes
|
||||
GH_ACCOUNT= troglobit
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ARGS= --bindir=${PREFIX}/sbin
|
||||
INSTALL_TARGET= install-exec-am install-man
|
||||
PORTDOCS= AUTHORS COPYING ChangeLog README TODO
|
||||
|
||||
OPTIONS_DEFINE= DOCS
|
||||
DOCS_INSTALL_TARGET= install
|
||||
|
||||
post-install:
|
||||
${INSTALL_DATA} ${WRKSRC}/${PORTNAME}.conf \
|
||||
${STAGEDIR}${PREFIX}/etc/${PORTNAME}.conf.sample
|
||||
|
||||
.include <bsd.port.mk>
|
2
net/smcroute/distinfo
Normal file
2
net/smcroute/distinfo
Normal file
|
@ -0,0 +1,2 @@
|
|||
SHA256 (troglobit-smcroute-2.0.0_GH0.tar.bz2) = 0c1cec2df56ef4da06d7f919b5ba663a994b94db322b9eeece1093f5d2b2f658
|
||||
SIZE (troglobit-smcroute-2.0.0_GH0.tar.bz2) = 125925
|
66
net/smcroute/files/patch-Makefile.in
Normal file
66
net/smcroute/files/patch-Makefile.in
Normal file
|
@ -0,0 +1,66 @@
|
|||
--- Makefile.in.orig 2014-09-30 21:11:41 UTC
|
||||
+++ Makefile.in
|
||||
@@ -50,7 +50,7 @@ POST_INSTALL = :
|
||||
NORMAL_UNINSTALL = :
|
||||
PRE_UNINSTALL = :
|
||||
POST_UNINSTALL = :
|
||||
-bin_PROGRAMS = smcroute$(EXEEXT) mcsender$(EXEEXT)
|
||||
+bin_PROGRAMS = smcroute$(EXEEXT)
|
||||
subdir = .
|
||||
DIST_COMMON = README $(am__configure_deps) $(dist_man8_MANS) \
|
||||
$(srcdir)/Makefile.am $(srcdir)/Makefile.in \
|
||||
@@ -69,9 +69,6 @@ CONFIG_CLEAN_VPATH_FILES =
|
||||
am__installdirs = "$(DESTDIR)$(bindir)" "$(DESTDIR)$(man8dir)" \
|
||||
"$(DESTDIR)$(docdir)"
|
||||
PROGRAMS = $(bin_PROGRAMS)
|
||||
-am_mcsender_OBJECTS = mcsender.$(OBJEXT) syslog.$(OBJEXT)
|
||||
-mcsender_OBJECTS = $(am_mcsender_OBJECTS)
|
||||
-mcsender_LDADD = $(LDADD)
|
||||
am_smcroute_OBJECTS = smcroute.$(OBJEXT) mroute-api.$(OBJEXT) \
|
||||
ifvc.$(OBJEXT) cmdpkt.$(OBJEXT) ipc.$(OBJEXT) \
|
||||
mcgroup.$(OBJEXT) parse-conf.$(OBJEXT) syslog.$(OBJEXT) \
|
||||
@@ -98,8 +95,8 @@ am__v_CCLD_0 = @echo " CCLD " $@;
|
||||
AM_V_GEN = $(am__v_GEN_@AM_V@)
|
||||
am__v_GEN_ = $(am__v_GEN_@AM_DEFAULT_V@)
|
||||
am__v_GEN_0 = @echo " GEN " $@;
|
||||
-SOURCES = $(mcsender_SOURCES) $(smcroute_SOURCES)
|
||||
-DIST_SOURCES = $(mcsender_SOURCES) $(smcroute_SOURCES)
|
||||
+SOURCES = $(smcroute_SOURCES)
|
||||
+DIST_SOURCES = $(smcroute_SOURCES)
|
||||
am__can_run_installinfo = \
|
||||
case $$AM_UPDATE_INFO_DIR in \
|
||||
n|no|NO) false;; \
|
||||
@@ -240,12 +237,10 @@ target_alias = @target_alias@
|
||||
top_build_prefix = @top_build_prefix@
|
||||
top_builddir = @top_builddir@
|
||||
top_srcdir = @top_srcdir@
|
||||
-dist_man8_MANS = smcroute.8 mcsender.8
|
||||
-doc_DATA = README AUTHORS TODO ChangeLog COPYING \
|
||||
- smcroute.conf smcroute.init
|
||||
+dist_man8_MANS = smcroute.8
|
||||
+doc_DATA = README AUTHORS TODO ChangeLog COPYING
|
||||
|
||||
-EXTRA_DIST = autogen.sh smcroute.conf smcroute.init
|
||||
-mcsender_SOURCES = mcsender.c syslog.c
|
||||
+EXTRA_DIST = autogen.sh
|
||||
smcroute_SOURCES = smcroute.c mroute-api.c ifvc.c cmdpkt.c ipc.c \
|
||||
mcgroup.c parse-conf.c syslog.c pidfile.c mclab.h
|
||||
|
||||
@@ -346,9 +341,6 @@ uninstall-binPROGRAMS:
|
||||
|
||||
clean-binPROGRAMS:
|
||||
-test -z "$(bin_PROGRAMS)" || rm -f $(bin_PROGRAMS)
|
||||
-mcsender$(EXEEXT): $(mcsender_OBJECTS) $(mcsender_DEPENDENCIES) $(EXTRA_mcsender_DEPENDENCIES)
|
||||
- @rm -f mcsender$(EXEEXT)
|
||||
- $(AM_V_CCLD)$(LINK) $(mcsender_OBJECTS) $(mcsender_LDADD) $(LIBS)
|
||||
smcroute$(EXEEXT): $(smcroute_OBJECTS) $(smcroute_DEPENDENCIES) $(EXTRA_smcroute_DEPENDENCIES)
|
||||
@rm -f smcroute$(EXEEXT)
|
||||
$(AM_V_CCLD)$(LINK) $(smcroute_OBJECTS) $(smcroute_LDADD) $(LIBS)
|
||||
@@ -363,7 +355,6 @@ distclean-compile:
|
||||
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/ifvc.Po@am__quote@
|
||||
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/ipc.Po@am__quote@
|
||||
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/mcgroup.Po@am__quote@
|
||||
-@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/mcsender.Po@am__quote@
|
||||
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/mroute-api.Po@am__quote@
|
||||
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/parse-conf.Po@am__quote@
|
||||
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/pidfile.Po@am__quote@
|
32
net/smcroute/files/smcroute.in
Normal file
32
net/smcroute/files/smcroute.in
Normal file
|
@ -0,0 +1,32 @@
|
|||
#!/bin/sh
|
||||
# $FreeBSD$
|
||||
#
|
||||
# PROVIDE: smcroute
|
||||
# REQUIRE: netif routing
|
||||
# KEYWORD: nojail
|
||||
|
||||
#
|
||||
# Add the following to /etc/rc.conf[.local] to enable this service
|
||||
#
|
||||
# smcroute_enable="YES"
|
||||
#
|
||||
|
||||
. /etc/rc.subr
|
||||
|
||||
name="smcroute"
|
||||
rcvar="${name}_enable"
|
||||
command="%%PREFIX%%/sbin/${name}"
|
||||
start_precmd="${name}_precmd"
|
||||
|
||||
smcroute_precmd()
|
||||
{
|
||||
|
||||
rc_flags="$rc_flags -d"
|
||||
}
|
||||
|
||||
load_rc_config $name
|
||||
|
||||
: ${smcroute_enable="NO"}
|
||||
: ${smcroute_flags=""}
|
||||
|
||||
run_rc_command "$1"
|
8
net/smcroute/pkg-descr
Normal file
8
net/smcroute/pkg-descr
Normal file
|
@ -0,0 +1,8 @@
|
|||
SMCRoute is a command line tool to manipulate the multicast routes of a
|
||||
UNIX kernel. It supports both IPv4 and IPv6 multicast routing.
|
||||
|
||||
SMCRoute can be used as an alternative to dynamic multicast routers like
|
||||
mrouted or pimd in setups where static multicast routes should be
|
||||
maintained and/or no proper IGMP or MLD signaling exists.
|
||||
|
||||
WWW: https://github.com/troglobit/smcroute/
|
3
net/smcroute/pkg-plist
Normal file
3
net/smcroute/pkg-plist
Normal file
|
@ -0,0 +1,3 @@
|
|||
sbin/smcroute
|
||||
@sample etc/smcroute.conf.sample
|
||||
man/man8/smcroute.8.gz
|
Loading…
Reference in a new issue