Update to make jserver work. Needed to "wnntouch" dictionary files
here and there.
This commit is contained in:
parent
2a6d7ba804
commit
59d082981f
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=502
6 changed files with 52 additions and 21 deletions
|
@ -8,8 +8,10 @@
|
|||
|
||||
DISTNAME= Wnn4.2
|
||||
MASTER_SITES= ftp://utsun.s.u-tokyo.ac.jp/fj/
|
||||
PKG_CMD= pkg_create -N
|
||||
IS_INTERACTIVE= yes
|
||||
WRKSRC= ${WRKDIR}/Xsi
|
||||
PKG_ARGS?= -v -c ${PKGDIR}/COMMENT -d ${PKGDIR}/DESCR -f ${PKGDIR}/PLIST \
|
||||
-r ${PKGDIR}/REQ -i ${PKGDIR}/INSTALL -p ${PREFIX}
|
||||
|
||||
# These are necesary because this package uses a different Makefile for
|
||||
# building and installing etc.
|
||||
|
@ -19,9 +21,12 @@ pre-build:
|
|||
build: configure pre-build depends ${BUILD_COOKIE}
|
||||
@${TOUCH} ${TOUCH_FLAGS} ${BUILD_COOKIE}
|
||||
|
||||
pre-install:
|
||||
@PREFIX=${PREFIX} ${SCRIPTDIR}/pre-install
|
||||
# This package uses imake's "install.man" target to install man pages but
|
||||
# I can't define USE_IMAKE because it doesn't involve xmkmf
|
||||
pre-install:
|
||||
@(cd ${WRKSRC}; ${MAKE} ${MAKE_FLAGS} ${MAKEFILE} install.man)
|
||||
|
||||
pre-reinstall: pre-install
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,5 +1,20 @@
|
|||
--- ./Wnn/pubdic/Imakefile.org Mon Aug 22 19:21:30 1994
|
||||
+++ ./Wnn/pubdic/Imakefile Thu Nov 24 22:00:29 1994
|
||||
@@ -109,6 +109,12 @@
|
||||
WnnInstallDicMultiple($(DIC),$(JWNNPUBDICDIR))
|
||||
#endif
|
||||
InstallMultiple($(FZKDATA),$(JWNNPUBDICDIR))
|
||||
+install::
|
||||
+ @for i in $(FZKDATA); \
|
||||
+ do \
|
||||
+ $(WNNTOUCH) $(DESTDIR)$(JWNNPUBDICDIR)/$$i ;\
|
||||
+ done
|
||||
+
|
||||
InstallMultiple($(FZK_SRC),$(JWNNFZKSRCDIR))
|
||||
|
||||
depend::
|
||||
--- ./config/Project.tmpl.org Mon Aug 29 01:40:17 1994
|
||||
+++ ./config/Project.tmpl Tue Nov 22 09:56:34 1994
|
||||
+++ ./config/Project.tmpl Thu Nov 24 21:53:26 1994
|
||||
@@ -389,6 +389,7 @@
|
||||
XCOMM -----------------------------------------------------------------------
|
||||
XCOMM X Window System make variables; these need to be coordinated with rules
|
||||
|
@ -18,7 +33,7 @@
|
|||
INSTAPPFLAGS = $(INSTDATFLAGS) /* XXX - this should go away - XXX */
|
||||
|
||||
#ifdef UseInstalled
|
||||
@@ -1134,21 +1138,28 @@
|
||||
@@ -1134,17 +1138,20 @@
|
||||
$(WNNTOUCH) $(DESTDIR)dest/$$i); fi \ @@\
|
||||
done
|
||||
|
||||
|
@ -41,13 +56,4 @@
|
|||
+#define BuildXwnmo NO
|
||||
#endif
|
||||
|
||||
+/*
|
||||
+ * Jserver doesn't seem to work
|
||||
+ * - Satoshi
|
||||
+ */
|
||||
#ifndef BuildJserver
|
||||
-#define BuildJserver YES
|
||||
+#define BuildJserver NO
|
||||
#endif
|
||||
#ifndef BuildJlib
|
||||
#define BuildJlib YES
|
||||
|
|
|
@ -8,8 +8,10 @@
|
|||
|
||||
DISTNAME= Wnn4.2
|
||||
MASTER_SITES= ftp://utsun.s.u-tokyo.ac.jp/fj/
|
||||
PKG_CMD= pkg_create -N
|
||||
IS_INTERACTIVE= yes
|
||||
WRKSRC= ${WRKDIR}/Xsi
|
||||
PKG_ARGS?= -v -c ${PKGDIR}/COMMENT -d ${PKGDIR}/DESCR -f ${PKGDIR}/PLIST \
|
||||
-r ${PKGDIR}/REQ -i ${PKGDIR}/INSTALL -p ${PREFIX}
|
||||
|
||||
# These are necesary because this package uses a different Makefile for
|
||||
# building and installing etc.
|
||||
|
@ -19,9 +21,12 @@ pre-build:
|
|||
build: configure pre-build depends ${BUILD_COOKIE}
|
||||
@${TOUCH} ${TOUCH_FLAGS} ${BUILD_COOKIE}
|
||||
|
||||
pre-install:
|
||||
@PREFIX=${PREFIX} ${SCRIPTDIR}/pre-install
|
||||
# This package uses imake's "install.man" target to install man pages but
|
||||
# I can't define USE_IMAKE because it doesn't involve xmkmf
|
||||
pre-install:
|
||||
@(cd ${WRKSRC}; ${MAKE} ${MAKE_FLAGS} ${MAKEFILE} install.man)
|
||||
|
||||
pre-reinstall: pre-install
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -8,8 +8,10 @@
|
|||
|
||||
DISTNAME= Wnn4.2
|
||||
MASTER_SITES= ftp://utsun.s.u-tokyo.ac.jp/fj/
|
||||
PKG_CMD= pkg_create -N
|
||||
IS_INTERACTIVE= yes
|
||||
WRKSRC= ${WRKDIR}/Xsi
|
||||
PKG_ARGS?= -v -c ${PKGDIR}/COMMENT -d ${PKGDIR}/DESCR -f ${PKGDIR}/PLIST \
|
||||
-r ${PKGDIR}/REQ -i ${PKGDIR}/INSTALL -p ${PREFIX}
|
||||
|
||||
# These are necesary because this package uses a different Makefile for
|
||||
# building and installing etc.
|
||||
|
@ -19,9 +21,12 @@ pre-build:
|
|||
build: configure pre-build depends ${BUILD_COOKIE}
|
||||
@${TOUCH} ${TOUCH_FLAGS} ${BUILD_COOKIE}
|
||||
|
||||
pre-install:
|
||||
@PREFIX=${PREFIX} ${SCRIPTDIR}/pre-install
|
||||
# This package uses imake's "install.man" target to install man pages but
|
||||
# I can't define USE_IMAKE because it doesn't involve xmkmf
|
||||
pre-install:
|
||||
@(cd ${WRKSRC}; ${MAKE} ${MAKE_FLAGS} ${MAKEFILE} install.man)
|
||||
|
||||
pre-reinstall: pre-install
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -8,8 +8,10 @@
|
|||
|
||||
DISTNAME= Wnn4.2
|
||||
MASTER_SITES= ftp://utsun.s.u-tokyo.ac.jp/fj/
|
||||
PKG_CMD= pkg_create -N
|
||||
IS_INTERACTIVE= yes
|
||||
WRKSRC= ${WRKDIR}/Xsi
|
||||
PKG_ARGS?= -v -c ${PKGDIR}/COMMENT -d ${PKGDIR}/DESCR -f ${PKGDIR}/PLIST \
|
||||
-r ${PKGDIR}/REQ -i ${PKGDIR}/INSTALL -p ${PREFIX}
|
||||
|
||||
# These are necesary because this package uses a different Makefile for
|
||||
# building and installing etc.
|
||||
|
@ -19,9 +21,12 @@ pre-build:
|
|||
build: configure pre-build depends ${BUILD_COOKIE}
|
||||
@${TOUCH} ${TOUCH_FLAGS} ${BUILD_COOKIE}
|
||||
|
||||
pre-install:
|
||||
@PREFIX=${PREFIX} ${SCRIPTDIR}/pre-install
|
||||
# This package uses imake's "install.man" target to install man pages but
|
||||
# I can't define USE_IMAKE because it doesn't involve xmkmf
|
||||
pre-install:
|
||||
@(cd ${WRKSRC}; ${MAKE} ${MAKE_FLAGS} ${MAKEFILE} install.man)
|
||||
|
||||
pre-reinstall: pre-install
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -8,8 +8,10 @@
|
|||
|
||||
DISTNAME= Wnn4.2
|
||||
MASTER_SITES= ftp://utsun.s.u-tokyo.ac.jp/fj/
|
||||
PKG_CMD= pkg_create -N
|
||||
IS_INTERACTIVE= yes
|
||||
WRKSRC= ${WRKDIR}/Xsi
|
||||
PKG_ARGS?= -v -c ${PKGDIR}/COMMENT -d ${PKGDIR}/DESCR -f ${PKGDIR}/PLIST \
|
||||
-r ${PKGDIR}/REQ -i ${PKGDIR}/INSTALL -p ${PREFIX}
|
||||
|
||||
# These are necesary because this package uses a different Makefile for
|
||||
# building and installing etc.
|
||||
|
@ -19,9 +21,12 @@ pre-build:
|
|||
build: configure pre-build depends ${BUILD_COOKIE}
|
||||
@${TOUCH} ${TOUCH_FLAGS} ${BUILD_COOKIE}
|
||||
|
||||
pre-install:
|
||||
@PREFIX=${PREFIX} ${SCRIPTDIR}/pre-install
|
||||
# This package uses imake's "install.man" target to install man pages but
|
||||
# I can't define USE_IMAKE because it doesn't involve xmkmf
|
||||
pre-install:
|
||||
@(cd ${WRKSRC}; ${MAKE} ${MAKE_FLAGS} ${MAKEFILE} install.man)
|
||||
|
||||
pre-reinstall: pre-install
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
Loading…
Reference in a new issue