deskutils/rubrica: Remove expired port
2024-03-11 deskutils/rubrica: Upstream WWW redirects to a different site not related to the application
This commit is contained in:
parent
ea934ef642
commit
59e85cf058
10 changed files with 1 additions and 290 deletions
1
MOVED
1
MOVED
|
@ -3041,3 +3041,4 @@ net-p2p/sonarr-devel|net-p2p/sonarr|2024-03-03|Has expired: Use net-p2p/sonarr i
|
|||
security/py-pyblake2||2024-03-03|Has expired: Reached it's End Of Life. Integrated into Python Standard Library
|
||||
net-im/gtkcord4|net-im/dissent|2024-03-03|Project renamed
|
||||
devel/anjuta|devel/gnome-builder|2024-03-12|Has expired: Unmaintained, upstream WWW owned by gambling site, use devel/gnome-builder
|
||||
deskutils/rubrica||2024-03-12|Has expired: Upstream WWW redirects to a different site not related to the application
|
||||
|
|
|
@ -248,7 +248,6 @@
|
|||
SUBDIR += rednotebook
|
||||
SUBDIR += remind
|
||||
SUBDIR += rolo
|
||||
SUBDIR += rubrica
|
||||
SUBDIR += rubygem-shellplay
|
||||
SUBDIR += rubygem-taskjuggler
|
||||
SUBDIR += semantik
|
||||
|
|
|
@ -1,64 +0,0 @@
|
|||
PORTNAME= rubrica
|
||||
PORTVERSION= 2.1.6
|
||||
PORTREVISION= 3
|
||||
CATEGORIES= deskutils gnome
|
||||
MASTER_SITES= BERLIOS
|
||||
DISTNAME= ${PORTNAME}2-${PORTVERSION}
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
COMMENT= Addressbook for the GNOME 2 desktop
|
||||
WWW= https://www.nicolafragale.org/rubrica/
|
||||
|
||||
LICENSE= GPLv3
|
||||
LICENSE_FILE= ${WRKSRC}/COPYING
|
||||
|
||||
DEPRECATED= Upstream WWW redirects to a different site not related to the application
|
||||
EXPIRATION_DATE= 2024-03-11
|
||||
|
||||
LIB_DEPENDS= libnotify.so:devel/libnotify
|
||||
RUN_DEPENDS= gnome-icon-theme>=0:misc/gnome-icon-theme
|
||||
|
||||
USES= desktop-file-utils gmake gnome libtool localbase pathfix \
|
||||
pkgconfig tar:bzip2
|
||||
GNU_CONFIGURE= yes
|
||||
USE_GNOME= gconf2 gnomeprefix libglade2 intltool
|
||||
USE_LDCONFIG= yes
|
||||
MAKE_ENV= INSTALL_STRIP_FLAG=${STRIP}
|
||||
|
||||
GCONF_SCHEMAS= rubrica2.schemas
|
||||
|
||||
LIBS+= -lm -lgthread-2.0
|
||||
|
||||
PORTDOCS= *
|
||||
|
||||
OPTIONS_DEFINE= DOCS NLS
|
||||
OPTIONS_SUB= yes
|
||||
|
||||
NLS_CONFIGURE_ENABLE= nls
|
||||
NLS_USES= gettext
|
||||
|
||||
post-patch:
|
||||
@${FIND} ${WRKSRC} -name "Makefile.in" | ${XARGS} ${REINPLACE_CMD} -e \
|
||||
's|-Wall -g|-Wall|g ; \
|
||||
s|-Wmissing-prototypes -g|-Wmissing-prototypes|g'
|
||||
@${REINPLACE_CMD} -e '/^SUBDIRS/s|doc||g' ${WRKSRC}/Makefile.in
|
||||
@${REINPLACE_CMD} -e 's|_Modifica|_Edit|' \
|
||||
-e 's|A_iuto|_Help|' \
|
||||
${WRKSRC}/interface/MainWindow.glade
|
||||
@${REINPLACE_CMD} -e \
|
||||
's|^Categories=.*|Categories=GNOME;Application;Office;System;Utility;|' \
|
||||
${WRKSRC}/rubrica2.desktop.in
|
||||
|
||||
post-patch-NLS-off:
|
||||
@${REINPLACE_CMD} -e '/^SUBDIRS/s|po||g' ${WRKSRC}/Makefile.in
|
||||
|
||||
post-install:
|
||||
@${LN} -sf ${LOCALBASE}/share/icons/gnome \
|
||||
${STAGEDIR}${PREFIX}/share/pixmaps/rubrica2/22x22/hicolor
|
||||
|
||||
post-install-DOCS-on:
|
||||
@${MKDIR} ${STAGEDIR}${DOCSDIR}
|
||||
${INSTALL_DATA} ${WRKSRC}/CREDITS ${WRKSRC}/ChangeLog ${STAGEDIR}${DOCSDIR}
|
||||
cd ${WRKSRC}/doc/reference/html && ${COPYTREE_SHARE} . ${STAGEDIR}${DOCSDIR}/libRAL-reference
|
||||
|
||||
.include <bsd.port.mk>
|
|
@ -1,2 +0,0 @@
|
|||
SHA256 (rubrica2-2.1.6.tar.bz2) = 4d9462243af4741e3571c9283f5a29ceb85a19c3dc1192148983c235a212dc9d
|
||||
SIZE (rubrica2-2.1.6.tar.bz2) = 710715
|
|
@ -1,11 +0,0 @@
|
|||
--- src/app.c.orig 2016-01-08 10:28:54 UTC
|
||||
+++ src/app.c
|
||||
@@ -1339,7 +1339,7 @@ rubrica_app_init(RubricaApp* self)
|
||||
|
||||
self->priv->cutted = NULL;
|
||||
self->priv->notify = notify_notification_new("Rubrica Addressbook",
|
||||
- NULL, "info", NULL);
|
||||
+ "info", NULL);
|
||||
self->priv->active_plugin = g_strdup("autodetect");
|
||||
self->priv->manager = r_lib_get_manager();
|
||||
self->priv->print_settings = NULL;
|
|
@ -1,11 +0,0 @@
|
|||
--- src/callbacks.c.orig 2016-01-08 10:29:13 UTC
|
||||
+++ src/callbacks.c
|
||||
@@ -638,7 +638,7 @@ on_info_cb (GtkWidget* button, gpointer
|
||||
"wrap-license", FALSE,
|
||||
NULL);
|
||||
|
||||
- gdk_pixbuf_unref (logo);
|
||||
+ g_object_unref (logo);
|
||||
|
||||
gtk_dialog_run (GTK_DIALOG(about));
|
||||
gtk_widget_destroy (about);
|
|
@ -1,66 +0,0 @@
|
|||
--- src/data_view.c.orig 2016-01-08 10:28:41 UTC
|
||||
+++ src/data_view.c
|
||||
@@ -689,7 +689,7 @@ data_view_set_image(RubricaDataView* vie
|
||||
priv = RUBRICA_DATA_VIEW_GET_PRIVATE(view);
|
||||
|
||||
gtk_image_set_from_pixbuf(GTK_IMAGE(priv->image), pixbuf);
|
||||
- gdk_pixbuf_unref(pixbuf);
|
||||
+ g_object_unref(pixbuf);
|
||||
}
|
||||
|
||||
|
||||
@@ -952,7 +952,7 @@ write_addresses(RubricaDataView* view, R
|
||||
|
||||
data_view_write(body, "\n");
|
||||
data_view_write_pixbuf(body, pixbuf, _("Addresses"));
|
||||
- gdk_pixbuf_unref(pixbuf);
|
||||
+ g_object_unref(pixbuf);
|
||||
|
||||
for (; address; address = r_card_get_next_address(R_CARD(card)))
|
||||
{
|
||||
@@ -1057,8 +1057,7 @@ write_work(RubricaDataView* view, RPerso
|
||||
|
||||
data_view_write(body, "\n");
|
||||
data_view_write_pixbuf(body, pixbuf, _("Work"));
|
||||
- gdk_pixbuf_unref(pixbuf);
|
||||
-
|
||||
+ g_object_unref(pixbuf);
|
||||
data_view_write_line(body, _("Assignment"), assignment, TRUE);
|
||||
data_view_write_line(body, _("Organization"), organization, TRUE);
|
||||
data_view_write_line(body, _("Department"), department, TRUE);
|
||||
@@ -1093,7 +1092,7 @@ write_net (RubricaDataView* view, RCard*
|
||||
|
||||
data_view_write(body, "\n");
|
||||
data_view_write_pixbuf(body, pixbuf, _("Net"));
|
||||
- gdk_pixbuf_unref(pixbuf);
|
||||
+ g_object_unref(pixbuf);
|
||||
|
||||
for (; net; net = r_card_get_next_net_address(R_CARD(card)))
|
||||
{
|
||||
@@ -1165,7 +1164,7 @@ write_telephones(RubricaDataView* view,
|
||||
|
||||
data_view_write(body, "\n");
|
||||
data_view_write_pixbuf(body, pixbuf, _("Telephone"));
|
||||
- gdk_pixbuf_unref(pixbuf);
|
||||
+ g_object_unref(pixbuf);
|
||||
|
||||
for (; tel; tel = r_card_get_next_telephone(R_CARD(card)))
|
||||
{
|
||||
@@ -1210,7 +1209,7 @@ write_notes(RubricaDataView* view, RPers
|
||||
|
||||
data_view_write(body, "\n");
|
||||
data_view_write_pixbuf(body, pixbuf, _("Notes"));
|
||||
- gdk_pixbuf_unref(pixbuf);
|
||||
+ g_object_unref(pixbuf);
|
||||
|
||||
if (has_partner)
|
||||
{
|
||||
@@ -1257,7 +1256,7 @@ write_company_notes(RubricaDataView* vie
|
||||
data_view_write(body, "\n");
|
||||
data_view_write_pixbuf(body, pixbuf, _("Notes"));
|
||||
data_view_write(body, "\n");
|
||||
- gdk_pixbuf_unref(pixbuf);
|
||||
+ g_object_unref(pixbuf);
|
||||
|
||||
data_view_write(body, text);
|
||||
}
|
|
@ -1,30 +0,0 @@
|
|||
--- rubrica2.schemas.in.orig 2010-06-20 14:23:50.000000000 +0200
|
||||
+++ rubrica2.schemas.in 2013-04-03 20:40:05.000000000 +0200
|
||||
@@ -6,7 +6,7 @@
|
||||
<applyto>/apps/rubrica2/file_format</applyto>
|
||||
<owner>rubrica</owner>
|
||||
<type>int</type>
|
||||
- <default>@FILE_FORMAT@</default>
|
||||
+ <default>@RUBRICA_FILE_FORMAT@</default>
|
||||
<locale name="C">
|
||||
<short>rubrica file format</short>
|
||||
</locale>
|
||||
@@ -88,7 +88,7 @@
|
||||
<key>/schemas/apps/rubrica2/file/load_files</key>
|
||||
<applyto>/apps/rubrica2/file/load_files</applyto>
|
||||
<owner>rubrica</owner>
|
||||
- <type>boolean</type>
|
||||
+ <type>bool</type>
|
||||
<default>false</default>
|
||||
<locale name="C">
|
||||
<short>Load addressbooks on startup</short>
|
||||
@@ -100,7 +100,8 @@
|
||||
<applyto>/apps/rubrica2/file/files</applyto>
|
||||
<owner>rubrica</owner>
|
||||
<type>list</type>
|
||||
- <default></default>
|
||||
+ <list_type>string</list_type>
|
||||
+ <default>[]</default>
|
||||
<locale name="C">
|
||||
<short>Files that rubrica will open at startup</short>
|
||||
</locale>
|
|
@ -1,5 +0,0 @@
|
|||
Rubrica is an addressbook manager for the GNOME Environment.
|
||||
It allows you to add personal data (name, surname, address, etc.),
|
||||
web links, irc and email addresses, telephone numbers, job information
|
||||
(company where contact works, company infos, contact's assigment, etc.)
|
||||
and notes.
|
|
@ -1,100 +0,0 @@
|
|||
bin/rubrica2
|
||||
include/libral-1.0/libral/abook.h
|
||||
include/libral-1.0/libral/address.h
|
||||
include/libral-1.0/libral/card.h
|
||||
include/libral-1.0/libral/company.h
|
||||
include/libral-1.0/libral/contact.h
|
||||
include/libral-1.0/libral/csv_engine.h
|
||||
include/libral-1.0/libral/date.h
|
||||
include/libral-1.0/libral/error.h
|
||||
include/libral-1.0/libral/filter.h
|
||||
include/libral-1.0/libral/group.h
|
||||
include/libral-1.0/libral/group_box.h
|
||||
include/libral-1.0/libral/libral.h
|
||||
include/libral-1.0/libral/lookup.h
|
||||
include/libral-1.0/libral/manager.h
|
||||
include/libral-1.0/libral/net.h
|
||||
include/libral-1.0/libral/notes.h
|
||||
include/libral-1.0/libral/personal.h
|
||||
include/libral-1.0/libral/plugin.h
|
||||
include/libral-1.0/libral/ref.h
|
||||
include/libral-1.0/libral/rlib.h
|
||||
include/libral-1.0/libral/telephone.h
|
||||
include/libral-1.0/libral/timeout.h
|
||||
include/libral-1.0/libral/types.h
|
||||
include/libral-1.0/libral/utils.h
|
||||
include/libral-1.0/libral/work.h
|
||||
lib/libral.a
|
||||
lib/libral.so
|
||||
lib/libral.so.1
|
||||
lib/libral.so.1.0.0
|
||||
lib/libral/plugins/libcsvgmail.a
|
||||
lib/libral/plugins/libcsvgmail.so
|
||||
lib/libral/plugins/libcsvgmail.so.1
|
||||
lib/libral/plugins/libcsvgmail.so.1.0.0
|
||||
lib/libral/plugins/libcsvthunderbird.a
|
||||
lib/libral/plugins/libcsvthunderbird.so
|
||||
lib/libral/plugins/libcsvthunderbird.so.1
|
||||
lib/libral/plugins/libcsvthunderbird.so.1.0.1
|
||||
lib/libral/plugins/librubrica.a
|
||||
lib/libral/plugins/librubrica.so
|
||||
lib/libral/plugins/librubrica.so.1
|
||||
lib/libral/plugins/librubrica.so.1.0.1
|
||||
lib/libral/plugins/libvcard.a
|
||||
lib/libral/plugins/libvcard.so
|
||||
lib/libral/plugins/libvcard.so.1
|
||||
lib/libral/plugins/libvcard.so.1.0.1
|
||||
libdata/pkgconfig/libral.pc
|
||||
share/applications/rubrica2.desktop
|
||||
%%NLS%%share/locale/de/LC_MESSAGES/rubrica2.mo
|
||||
%%NLS%%share/locale/fr/LC_MESSAGES/rubrica2.mo
|
||||
%%NLS%%share/locale/it/LC_MESSAGES/rubrica2.mo
|
||||
%%NLS%%share/locale/ru/LC_MESSAGES/rubrica2.mo
|
||||
%%NLS%%share/locale/uk/LC_MESSAGES/rubrica2.mo
|
||||
share/mime-info/rubrica2.keys
|
||||
share/mime-info/rubrica2.mime
|
||||
share/pixmaps/rubrica2/16x16/ccare.png
|
||||
share/pixmaps/rubrica2/16x16/green.png
|
||||
share/pixmaps/rubrica2/16x16/operator.png
|
||||
share/pixmaps/rubrica2/22x22/hicolor
|
||||
share/pixmaps/rubrica2/24x24/stuffs.png
|
||||
share/pixmaps/rubrica2/24x24/university.png
|
||||
share/pixmaps/rubrica2/48x48/all.png
|
||||
share/pixmaps/rubrica2/48x48/bussines.png
|
||||
share/pixmaps/rubrica2/48x48/chat.png
|
||||
share/pixmaps/rubrica2/48x48/contacts.png
|
||||
share/pixmaps/rubrica2/48x48/customer.png
|
||||
share/pixmaps/rubrica2/48x48/flame.png
|
||||
share/pixmaps/rubrica2/48x48/freebsd.png
|
||||
share/pixmaps/rubrica2/48x48/gnu.png
|
||||
share/pixmaps/rubrica2/48x48/hobbies.png
|
||||
share/pixmaps/rubrica2/48x48/keys.png
|
||||
share/pixmaps/rubrica2/48x48/lock.png
|
||||
share/pixmaps/rubrica2/48x48/mailbox.png
|
||||
share/pixmaps/rubrica2/48x48/net.png
|
||||
share/pixmaps/rubrica2/48x48/notes.png
|
||||
share/pixmaps/rubrica2/48x48/phone.png
|
||||
share/pixmaps/rubrica2/48x48/photo.png
|
||||
share/pixmaps/rubrica2/48x48/puzzle.png
|
||||
share/pixmaps/rubrica2/48x48/rate1.png
|
||||
share/pixmaps/rubrica2/48x48/rate2.png
|
||||
share/pixmaps/rubrica2/48x48/rate3.png
|
||||
share/pixmaps/rubrica2/48x48/rate4.png
|
||||
share/pixmaps/rubrica2/48x48/rate5.png
|
||||
share/pixmaps/rubrica2/48x48/role.png
|
||||
share/pixmaps/rubrica2/48x48/rubrica.png
|
||||
share/pixmaps/rubrica2/48x48/search-contact.png
|
||||
share/pixmaps/rubrica2/48x48/sport.png
|
||||
share/pixmaps/rubrica2/48x48/strategies.png
|
||||
share/pixmaps/rubrica2/48x48/tux.png
|
||||
share/pixmaps/rubrica2/scalable/card_photo.svg
|
||||
share/pixmaps/rubrica2/scalable/query.svg
|
||||
%%DATADIR%%2/interface/CompanyCard.glade
|
||||
%%DATADIR%%2/interface/GroupManager.glade
|
||||
%%DATADIR%%2/interface/MainWindow.glade
|
||||
%%DATADIR%%2/interface/Menu.glade
|
||||
%%DATADIR%%2/interface/MenuTrash.glade
|
||||
%%DATADIR%%2/interface/PersonalCard.glade
|
||||
%%DATADIR%%2/interface/Preferences.glade
|
||||
%%DATADIR%%2/interface/Search.glade
|
||||
%%DATADIR%%2/interface/logo.png
|
Loading…
Reference in a new issue