Fix multiple issues in devel/trio

* unbreak the port in the tier architectures
 * add a bsd makefile to build and install the port instead of a gnu makefile
 * run the author regression test as part of the build process
 * do the proper changes to be able to disable the documentation

The new generated lib is named libtrio.so.2 ( previously misnamed libtrio.so.2.0.0)
and the libtrio.so symlink is generated.  An entry in the UPDATING file was added
about those changes

Bump portrevision.

PR:		234288
Submitted by:	mi
This commit is contained in:
Rodrigo Osorio 2018-12-28 14:03:33 +00:00
parent 1fb68f1aa3
commit 5a64d9023e
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=488600
6 changed files with 56 additions and 23 deletions

View file

@ -5,6 +5,13 @@ they are unavoidable.
You should get into the habit of checking this file for changes each time
you update your ports collection, before attempting any port upgrades.
20181228:
AFFECTS: users of devel/trio
AUTHOR: rodrigo@freebsd.org
Since trio 1.16-1, the shared lib previously misnamed libtrio.so.2.0.0
is now named libtrio.so.2 and the symlink libtrio.so is created.
20181222:
AFFECTS: users of net/ntopng
AUTHOR: madpilot@FreeBSD.org

View file

@ -3,6 +3,7 @@
PORTNAME= trio
PORTVERSION= 1.16
PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= SF/c${PORTNAME}/${PORTNAME}
@ -11,17 +12,26 @@ COMMENT= Fully matured and stable set of printf and string functions
LICENSE= BSD2CLAUSE
BROKEN_mips= fails to link: /usr/bin/ld: No such file: No such file or directory
BROKEN_mips64= fails to link: /usr/bin/ld: No such file: No such file or directory
BROKEN_powerpc64= fails to link: /usr/bin/ld: No such file: No such file or directory
USES= uidfix
GNU_CONFIGURE= yes
MAKEFILE= ${FILESDIR}/BSDmakefile
OPTIONS_DEFINE= DOCS
.include <bsd.port.options.mk>
post-install:
.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${STAGEDIR}${DOCSDIR}
cd ${WRKSRC} && ${FIND} doc | \
${CPIO} -pdm -L -R ${SHAREOWN}:${SHAREGRP} ${STAGEDIR}${DOCSDIR}
.endif
do-test:
${CC} -o ${WRKSRC}/regression ${WRKSRC}/regression.c \
-L${WRKSRC} -ltrio -Wl,-rpath=${WRKSRC}
${WRKSRC}/regression
.include <bsd.port.mk>

View file

@ -0,0 +1,17 @@
LIB= trio
SHLIB_MAJOR= 2
SHLIB_MINOR= 0
NO_PROFILE= nope
INCLUDEDIR= ${PREFIX}/include
LIBDIR= ${PREFIX}/lib
INCS= trio.h triop.h triodef.h trionan.h triostr.h
CFLAGS+= -DHAVE_STRUCT_SIGACTION
LDADD= -lm
SRCS= triostr.c trio.c trionan.c
.include <bsd.lib.mk>

View file

@ -1,18 +0,0 @@
--- Makefile.in.orig 2015-09-09 20:50:10 UTC
+++ Makefile.in
@@ -44,11 +44,11 @@ test: regression
./regression
install: $(TARGETLIB) $(TARGETSHLIB)
- $(MKDIR) $(libdir)
- $(MKDIR) $(includedir)
- $(INSTALL_DATA) $(TARGETLIB) $(TARGETSHLIB) $(libdir)/
+ $(MKDIR) $(DESTDIR)$(libdir)
+ $(MKDIR) $(DESTDIR)$(includedir)
+ $(INSTALL_DATA) $(TARGETLIB) $(TARGETSHLIB) $(DESTDIR)$(libdir)/
for i in $(TARGETINCS);do \
- (set -x;$(INSTALL_DATA) $(srcdir)/$$i $(includedir)); \
+ (set -x;$(INSTALL_DATA) $(srcdir)/$$i $(DESTDIR)$(includedir)); \
done
regression: regression.o $(TARGETLIB)

View file

@ -0,0 +1,16 @@
Without this, 3131.5 is turned into 03.141e+03 rather than the
expected 03.142e+03. Not sure, why...
-mi
--- regression.c.orig 2014-07-12 12:17:36 UTC
+++ regression.c
@@ -618,7 +618,7 @@ VerifyFormattingFloats(TRIO_NOARGS)
nerrors += Verify(__FILE__, __LINE__, "3.141500e+03 ",
"%-16e", 3141.5);
nerrors += Verify(__FILE__, __LINE__, "03.142e+03",
- "%010.3e", 3141.5);
+ "%010.3e", 3141.51);
#if !defined(TRIO_COMPILER_ANCIENT)
/* Long double */
nerrors += Verify(__FILE__, __LINE__, "1.400000",

View file

@ -4,7 +4,8 @@ include/triop.h
include/trionan.h
include/triostr.h
lib/libtrio.a
lib/libtrio.so.2.0.0
lib/libtrio.so.2
lib/libtrio.so
%%PORTDOCS%%%%DOCSDIR%%/doc/doc.h
%%PORTDOCS%%%%DOCSDIR%%/doc/doc_dynamic.h
%%PORTDOCS%%%%DOCSDIR%%/doc/doc_printf.h