Add urban, a bloody, violent sidescrolling shoot-em-up in which you're a

renegade military cyborg fighting your way out of the military base
where you were created.

PR:		ports/61863
Submitted by:	Jean-Yves Lefort <jylefort@brutele.be>
This commit is contained in:
Pav Lucistnik 2004-01-25 23:02:00 +00:00
parent 8e52869b50
commit 5a6d074e7b
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=99138
16 changed files with 410 additions and 0 deletions

View file

@ -424,6 +424,7 @@
SUBDIR += uhexen
SUBDIR += uox3
SUBDIR += uqm
SUBDIR += urban
SUBDIR += utserver
SUBDIR += utserver-asu
SUBDIR += utserver-to

55
games/urban/Makefile Normal file
View file

@ -0,0 +1,55 @@
# New ports collection makefile for: urban
# Date created: 25 Jan 2004
# Whom: Jean-Yves Lefort <jylefort@brutele.be>
#
# $FreeBSD$
#
PORTNAME= urban
PORTVERSION= 1.5.2
CATEGORIES= games
MASTER_SITES= http://urban.worldonline.nl/files/linux/
DIST_SUBDIR= urban
MAINTAINER= jylefort@brutele.be
COMMENT= A bloody, violent sidescrolling shoot-em-up
LIB_DEPENDS= ggi:${PORTSDIR}/graphics/libggi \
mikmod:${PORTSDIR}/audio/libmikmod
SCOREFILE= /var/games/urban.scores
USE_X_PREFIX= yes
GNU_CONFIGURE= yes
CFLAGS+= ${PTHREAD_CFLAGS}
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
CONFIGURE_ARGS= --with-global-highscore=${SCOREFILE}
OPTIONS= CHEAT_CODES "Enable cheat codes" off
.include <bsd.port.pre.mk>
.if defined(WITH_CHEAT_CODES)
CONFIGURE_ARGS+= --enable-cheat-codes
.endif
post-install:
${TOUCH} ${SCOREFILE}
${CHGRP} games ${SCOREFILE}
${CHMOD} g+w ${SCOREFILE}
${CHGRP} games ${PREFIX}/bin/urban
${CHMOD} g+s ${PREFIX}/bin/urban
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
${INSTALL_DATA} \
${WRKSRC}/AUTHORS \
${WRKSRC}/CHEAT \
${WRKSRC}/NEWS \
${WRKSRC}/README \
${WRKSRC}/README.swe \
${DOCSDIR}
.endif
@${CAT} ${PKGMESSAGE}
.include <bsd.port.post.mk>

1
games/urban/distinfo Normal file
View file

@ -0,0 +1 @@
MD5 (urban/urban-1.5.2.tar.gz) = 4d394e70866db944ffff0901d75535b0

View file

@ -0,0 +1,52 @@
--- configure.orig Sun Jan 25 03:50:44 2004
+++ configure Sun Jan 25 04:28:46 2004
@@ -1501,47 +1501,8 @@
fi
done
-echo $ac_n "checking for pthread_mutex_init in -lpthread""... $ac_c" 1>&6
-echo "configure:1506: checking for pthread_mutex_init in -lpthread" >&5
-ac_lib_var=`echo pthread'_'pthread_mutex_init | sed 'y%./+-%__p_%'`
-if eval "test \"`echo '$''{'ac_cv_lib_$ac_lib_var'+set}'`\" = set"; then
- echo $ac_n "(cached) $ac_c" 1>&6
-else
- ac_save_LIBS="$LIBS"
-LIBS="-lpthread $LIBS"
-cat > conftest.$ac_ext <<EOF
-#line 1514 "configure"
-#include "confdefs.h"
-/* Override any gcc2 internal prototype to avoid an error. */
-/* We use char because int might match the return type of a gcc2
- builtin and then its argument prototype would still apply. */
-char pthread_mutex_init();
-
-int main() {
-pthread_mutex_init()
-; return 0; }
-EOF
-if { (eval echo configure:1525: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
- rm -rf conftest*
- eval "ac_cv_lib_$ac_lib_var=yes"
-else
- echo "configure: failed program was:" >&5
- cat conftest.$ac_ext >&5
- rm -rf conftest*
- eval "ac_cv_lib_$ac_lib_var=no"
-fi
-rm -f conftest*
-LIBS="$ac_save_LIBS"
-
-fi
-if eval "test \"`echo '$ac_cv_lib_'$ac_lib_var`\" = yes"; then
- echo "$ac_t""yes" 1>&6
- PTHREAD_LIBS="-lpthread"
-else
- echo "$ac_t""no" 1>&6
-{ echo "configure: error: "Urban needs pthreads"" 1>&2; exit 1; }
-fi
-
+# PTHREAD_LIBS will be set in LDFLAGS by the FreeBSD port
+PTHREAD_LIBS=
# Check whether --with-libmikmod-prefix or --without-libmikmod-prefix was given.

View file

@ -0,0 +1,17 @@
--- src/config/config.cc.orig Sun Jun 6 15:37:17 1999
+++ src/config/config.cc Sun Jan 25 23:34:40 2004
@@ -91,10 +91,10 @@
/* Ask for the number of buttons */
fnt.print_centre("Gamepad type:", 160, 100);
- fnt.print_centre(" 1. 2 buttons
- 2. 4 buttons
- 3. 6 buttons
- 4. 8 buttons", 160, 140);
+ fnt.print_centre(" 1. 2 buttons"
+" 2. 4 buttons"
+" 3. 6 buttons"
+" 4. 8 buttons", 160, 140);
int running = 1;
while(running) {

View file

@ -0,0 +1,85 @@
--- src/credits/credits.cc.orig Fri Jun 11 14:25:40 1999
+++ src/credits/credits.cc Sun Jan 25 23:14:42 2004
@@ -72,50 +72,50 @@
int erase_title;
} _ci[] = {
{"PROGRAMMING",
-"THOMAS
-NYBERG", 0},
+"THOMAS"
+"NYBERG", 0},
{"PROGRAMMING",
-" JONAS
-BORGSTROM", 1},
+" JONAS"
+"BORGSTROM", 1},
{"GRAPHICS",
-" DICK
-ADOLFSSON", 1},
+" DICK"
+"ADOLFSSON", 1},
{"DESIGN",
-" PETTER
-HOLMBERG", 0},
+" PETTER"
+"HOLMBERG", 0},
{"DESIGN",
-"MARKUS
-BOMAN", 1},
+"MARKUS"
+"BOMAN", 1},
{"SOUND",
-" EMIL
-ERIKSSON", 0},
+" EMIL"
+"ERIKSSON", 0},
{"SOUND",
-"RICHARD
-BERGMARK", 1},
+"RICHARD"
+"BERGMARK", 1},
{"MUSIC",
-"SAMUEL
-PERSSON", 1},
+"SAMUEL"
+"PERSSON", 1},
};
#define NUMCI ((signed)(sizeof(_ci) / sizeof(_ci[0])))
char *special_thanks =
-"
- SPECIAL THANKS
-
- PER JONNY KACK
- TOR SANDEN
-MARKUS WILLANDER
- UFFEMAN
- HASSEMAN
- ANNA NORBERG
-
- DESCENT
-
- AND OURSELVES
-
- NOW
- PLAY URBAN";
+""
+" SPECIAL THANKS"
+""
+" PER JONNY KACK"
+" TOR SANDEN"
+"MARKUS WILLANDER"
+" UFFEMAN"
+" HASSEMAN"
+" ANNA NORBERG"
+""
+" DESCENT"
+""
+" AND OURSELVES"
+""
+" NOW"
+" PLAY URBAN";
uchar lightmap[256 * 256] = {};

View file

@ -0,0 +1,15 @@
--- src/engine/game.cc.orig Mon Jun 7 17:20:59 1999
+++ src/engine/game.cc Sun Jan 25 23:33:14 2004
@@ -93,10 +93,10 @@
char *demo_filename;
struct PlayerData DefaultPData = {
- {3},
+ 3,
{-1, 0, 0, 0, 0, 0, 0, 0, 0, 0},
{1, 0, 0, 0, 0, 0, 0, 0, 0, 0},
- {300}, {0}
+ 300, 0
};

View file

@ -0,0 +1,29 @@
--- src/gfx/ggidrv.cc.orig Sun Jan 25 03:56:28 2004
+++ src/gfx/ggidrv.cc Sun Jan 25 03:57:34 2004
@@ -383,7 +383,7 @@
}
/**************************************************************************/
int set_palette(PALETTE p) {
- struct ggi_color pal[256];
+ ggi_color pal[256];
int i;
for(i=0;i<256;i++) {
@@ -398,7 +398,7 @@
};
/**************************************************************************/
void get_palette(PALETTE p) {
- struct ggi_color pal[256];
+ ggi_color pal[256];
int i;
ggiGetPalette(screen->vis, 0, 1 << 8, pal);
@@ -715,7 +715,7 @@
}
/**************************************************************************/
int set_color(int i, RGB *rgb) {
- struct ggi_color Color;
+ ggi_color Color;
Color.r = rgb->r << 10;
Color.g = rgb->g << 10;

View file

@ -0,0 +1,27 @@
--- src/highscor/highscor.cc.orig Sun Jan 25 03:58:07 2004
+++ src/highscor/highscor.cc Sun Jan 25 03:58:30 2004
@@ -75,7 +75,7 @@
if(highscore[i].Level)
sprintf(buffer, " %-10s%6d %1d:%1d", highscore[i].Name,
- highscore[i].Score, ((highscore[i].Level-1) / 3) + 1, ((highscore[i].Level-1) % 3) + 1);
+ highscore[i].Skore, ((highscore[i].Level-1) / 3) + 1, ((highscore[i].Level-1) % 3) + 1);
else
sprintf(buffer, " %-10s%6d 0:0", "Empty", 0);
@@ -166,13 +166,13 @@
for(int i = 0; i < NUM_HIGHSCORES; i++) {
- if(score > highscore[i].Score) {
+ if(score > highscore[i].Skore) {
memmove(&highscore[i + 1], &highscore[i],
sizeof(Score) * (NUM_HIGHSCORES - i - 1));
strcpy(highscore[i].Name, GetName());
- highscore[i].Score = score;
+ highscore[i].Skore = score;
highscore[i].Level = level;
break;
}

View file

@ -0,0 +1,11 @@
--- src/include/highscor.h.orig Sun Jan 25 03:55:49 2004
+++ src/include/highscor.h Sun Jan 25 03:55:54 2004
@@ -6,7 +6,7 @@
/***************************************************************************/
struct Score {
char Name[64];
- int Score;
+ int Skore;
int Level;
};
/***************************************************************************/

View file

@ -0,0 +1,11 @@
--- src/meny/meny.cc.orig Fri Jul 2 02:23:30 1999
+++ src/meny/meny.cc Sun Jan 25 23:17:19 2004
@@ -124,7 +124,7 @@
return 1;
}
/*****************************************************************************************/
-int Do_Menu(char *text, int num_items, int pos = 1) {
+int Do_Menu(char *text, int num_items, int pos) {
PALETTE pal;
UrbanFont m(LARGE_FONT);
m.SetScale(65);

View file

@ -0,0 +1,73 @@
--- src/objects/player.cc.orig Wed Jun 23 21:28:13 1999
+++ src/objects/player.cc Sun Jan 25 23:31:48 2004
@@ -29,6 +29,7 @@
thomas.nyberg@usa.net jonas_b@bitsmart.com
*****************************************************************************/
#include <stdlib.h>
+#include <string.h>
#include <allegro.h>
#include "object.h"
#include "object2.h"
@@ -104,7 +105,7 @@
{30, 31, 32, 33, 34, 35},
{24, 25, 26, 27, 28, 29},
// {5}, {25}, {-1}, {1}},
- {3}, {10}, {-1}, {1}, {1}, {-1}},
+ 3, 10, -1, 1, 1, -1},
/* Flame thrower*/
/* int walk_left[6];
int walk_right[6];
@@ -121,7 +122,7 @@
// {12, 13, 14, 15, 16, 17},
{42, 43, 44, 45, 46, 47},
{36, 37, 38, 39, 40, 41},
- {5}, {8}, {0}, {0}, {0}, {500}},
+ 5, 8, 0, 0, 0, 500},
/* IceMaker(tm)*/
{{84, 85, 86, 87, 88, 89},
{78, 79, 80, 81, 82, 83},
@@ -130,7 +131,7 @@
// {12, 13, 14, 15, 16, 17},
{72, 73, 74, 75, 76, 77},
{66, 67, 68, 69, 70, 71},
- {5}, {8}, {0}, {0}, {0}, {500}},
+ 5, 8, 0, 0, 0, 500},
/* Grenade launcher */
{{102, 103, 104, 105, 106, 107},
{96, 97, 98, 99, 100, 101},
@@ -139,7 +140,7 @@
{126, 127, 128, 129, 130, 131},
{120, 121, 122, 123, 124, 125},
// {5}, {25}, {-1}, {1}},
- {3}, {60}, {0}, {0}, {1}, {32}},
+ 3, 60, 0, 0, 1, 32},
/* Plasma Weapon */
{{138, 139, 140, 141, 142, 143},
{132, 133, 134, 135, 136, 137},
@@ -147,7 +148,7 @@
{144, 145, 146, 147, 148, 149},
{162, 163, 164, 165, 166, 167},
{156, 157, 158, 159, 160, 161},
- {3}, {5}, {0}, {0}, {0}, {100}},
+ 3, 5, 0, 0, 0, 100},
/* Minigun */
{{174, 175, 176, 177, 178, 179},
{168, 169, 170, 171, 172, 173},
@@ -155,7 +156,7 @@
{180, 181, 182, 183, 184, 185},
{198, 199, 200, 201, 202, 203},
{192, 193, 194, 195, 196, 197},
- {1}, {1}, {0}, {0}, {1}, {1000}},
+ 1, 1, 0, 0, 1, 1000},
/* Electric */
{{210, 211, 212, 213, 214, 215},
{204, 205, 206, 207, 208, 209},
@@ -163,7 +164,7 @@
{216, 217, 218, 219, 220, 221},
{234, 235, 236, 237, 238, 239},
{228, 229, 230, 231, 232, 233},
- {6}, {6}, {0}, {0}, {0}, {100}}
+ 6, 6, 0, 0, 0, 100}
};
/*struct Weapon {

View file

@ -0,0 +1,11 @@
--- src/sound/sound.cc.orig Sun Jan 25 03:58:51 2004
+++ src/sound/sound.cc Sun Jan 25 04:00:00 2004
@@ -90,7 +90,7 @@
md_mode = DMODE_SOFT_SNDFX | DMODE_SOFT_MUSIC | DMODE_16BITS;
md_mixfreq = 22050;
- if(MikMod_Init()) {
+ if(MikMod_Init(NULL)) {
fprintf(stderr,"Could not initialize sound, reason: %s\n",
MikMod_strerror(MikMod_errno));

8
games/urban/pkg-descr Normal file
View file

@ -0,0 +1,8 @@
URBAN is a bloody, violent sidescrolling shoot-em-up in which you're a
renegade military cyborg fighting your way out of the military base
where you were created.
WWW: http://urban.worldonline.nl/
- Jean-Yves Lefort
jylefort@brutele.be

3
games/urban/pkg-message Normal file
View file

@ -0,0 +1,3 @@
-------------------------------------------------------------------------------
If you want sound effects, install the games/urban-sounds port.
-------------------------------------------------------------------------------

11
games/urban/pkg-plist Normal file
View file

@ -0,0 +1,11 @@
bin/urban
share/urban/intro.dat
share/urban/levels.dat
share/urban/urban.dat
%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
%%PORTDOCS%%%%DOCSDIR%%/CHEAT
%%PORTDOCS%%%%DOCSDIR%%/NEWS
%%PORTDOCS%%%%DOCSDIR%%/README
%%PORTDOCS%%%%DOCSDIR%%/README.swe
@dirrm share/urban
%%PORTDOCS%%@dirrm %%DOCSDIR%%