Reenable for FreeBSD >= 10.4

Use the CONFIG argument to enable experimental features

Submitted by:	jbeich@
This commit is contained in:
Michael Reifenberger 2018-04-28 14:19:25 +00:00
parent e69837290c
commit 5a7e9b17e3
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=468545
2 changed files with 7 additions and 8 deletions

View file

@ -14,8 +14,6 @@ COMMENT= Programmer's solid 3D CAD modeller
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/COPYING
BROKEN_FreeBSD_10= Missing __cxa_thread_atexit
BUILD_DEPENDS= ${LOCALBASE}/bin/flex:textproc/flex \
${LOCALBASE}/include/boost/tuple/tuple.hpp:devel/boost-libs
LIB_DEPENDS= libgmp.so:math/gmp \
@ -41,7 +39,7 @@ USE_QT4= corelib gui opengl moc_build uic_build rcc_build
PLIST_SUB= PORTVERSION=${PORTVERSION}
QMAKE_ENV= EIGENDIR=${LOCALBASE}/include/eigen3
QMAKE_ARGS+= VERSION=${PORTVERSION} \
EXPERIMENTAL=yes \
CONFIG+="experimental" \
QMAKE_LEX=${LOCALBASE}/bin/flex \
QMAKE_YAC=${LOCALBASE}/bin/bison
@ -49,4 +47,10 @@ post-patch:
@${REINPLACE_CMD} -e 's,share/man,man,' \
${WRKSRC}/openscad.pro
.include <bsd.port.options.mk>
.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1003506
BROKEN= no __cxa_thread_atexit() support in FreeBSD libc < 10.4
.endif
.include <bsd.port.mk>

View file

@ -1,10 +1,5 @@
--- openscad.pro.orig 2018-04-19 22:08:08 UTC
+++ openscad.pro
@@ -1,3 +1,4 @@
+CONFIG+=experimental
# Environment variables which can be set to specify library locations:
# MPIRDIR
# MPFRDIR
@@ -105,6 +106,10 @@ mingw* {
CONFIG += qt
QT += widgets concurrent