- Restrict USE_PYTHON range

- Move post-patch: to master port (graphics/ming)
This commit is contained in:
Sunpoet Po-Chuan Hsieh 2012-02-21 14:10:26 +00:00
parent d917feac53
commit 5a99600b60
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=292001
2 changed files with 1 additions and 16 deletions

View file

@ -19,7 +19,7 @@ INSTALL_WRKSRC= ${WRKSRC}/py_ext
PATCH_WRKSRC= ${WRKSRC}/py_ext
PATCHDIR= ${.CURDIR}/files
PLIST= ${.CURDIR}/pkg-plist
USE_PYTHON= yes
USE_PYTHON= -2.7
USE_PYDISTUTILS= yes
MASTERDIR= ${.CURDIR}/../../graphics/ming
@ -27,8 +27,4 @@ SLAVEPORT= py
PYDISTUTILS_PKGNAME= mingc
PYDISTUTILS_PKGVERSION= ${PORTVERSION}
post-patch:
@${REINPLACE_CMD} -e 's|/usr/local/|${LOCALBASE}/|g' ${WRKSRC}/py_ext/setup.py
@${LN} -sf ${LOCALBASE}/include/ming ${WRKSRC}/src
.include "${MASTERDIR}/Makefile"

View file

@ -1,11 +0,0 @@
--- Makefile.in.orig 2011-10-26 15:30:21.000000000 +0800
+++ Makefile.in 2011-11-20 14:11:44.898221010 +0800
@@ -414,7 +414,7 @@
rm -Rf test.swf build
install:
- $(PYTHON) setup.py install --prefix $(prefix) --root "/$(DESTDIR)"
+ $(PYTHON) setup.py install --prefix $(prefix)
test.swf:
$(PYTHON) shape.py