multimedia/libxine is broken on non-i386 architectures, amd64 in
particular. This causes consumers like multimedia/xine and multimedia/kaffeine to also be broken. Try running xine or kaffeine on amd64. Watch it segfault on startup. tjr@ has supplied a patch for it. PR: ports/65885 Submitted by: Tim Robbins <tim@robbins.dropbear.id.au>
This commit is contained in:
parent
b4855dcecf
commit
5abc5b52cd
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=107921
2 changed files with 13 additions and 7 deletions
|
@ -24,10 +24,4 @@ CONFIGURE_ENV= CXXFLAGS="${CFLAGS}"
|
|||
CONFIGURE_TARGET=
|
||||
CONFIGURE_ARGS+= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if ${MACHINE_ARCH} == "amd64"
|
||||
BROKEN= "crashes on start"
|
||||
.endif
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
.include <bsd.port.mk>
|
||||
|
|
12
multimedia/libxine/files/patch-src::xine-utils::memcpy.c
Normal file
12
multimedia/libxine/files/patch-src::xine-utils::memcpy.c
Normal file
|
@ -0,0 +1,12 @@
|
|||
--- src/xine-utils/memcpy.c.orig Thu Apr 22 22:57:12 2004
|
||||
+++ src/xine-utils/memcpy.c Thu Apr 22 22:57:55 2004
|
||||
@@ -428,7 +428,8 @@
|
||||
/* FIXME: implement an equivalent for using optimized memcpy on other
|
||||
architectures */
|
||||
#ifndef _MSC_VER
|
||||
- return times(NULL);
|
||||
+ struct tms xxx;
|
||||
+ return times(&xxx);
|
||||
#else
|
||||
return ((uint64_t)0);
|
||||
#endif /* _MSC_VER */
|
Loading…
Reference in a new issue