MOMspider is a web-roaming robot that specializes in the maintenance
of distributed hypertext infostructures (i.e. wide-area webs). The program is written in Perl and, once customized for your site, should work on any UNIX-based system with Perl 4.036.
This commit is contained in:
parent
645ac20526
commit
5abe104793
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=8215
7 changed files with 124 additions and 0 deletions
30
www/momspider/Makefile
Normal file
30
www/momspider/Makefile
Normal file
|
@ -0,0 +1,30 @@
|
|||
# New ports collection makefile for: dict
|
||||
# Version required: 1.00
|
||||
# Date created: 11 October 1997
|
||||
# Whom: wosch
|
||||
#
|
||||
# $Id$
|
||||
|
||||
DISTNAME= MOMspider-1.00
|
||||
CATEGORIES= www
|
||||
MASTER_SITES= ftp://www.ics.uci.edu/pub/websoft/libwww-perl/ \
|
||||
ftp://www.ics.uci.edu/pub/websoft/MOMspider/ \
|
||||
http://www.freebsd.org/~wosch/src/
|
||||
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} libwww-perl-0.40.tar.gz
|
||||
|
||||
MAINTAINER= wosch@FreeBSD.org
|
||||
|
||||
momdir= ${PREFIX}/momspider
|
||||
wwwdir= libwww-perl-0.40
|
||||
|
||||
do-build:
|
||||
|
||||
do-install:
|
||||
${MKDIR} ${momdir}/${wwwdir}
|
||||
${CP} -r ${WRKSRC}/* ${momdir}
|
||||
${RM} -rf ${WRKSRC}/../${wwwdir}/RCS
|
||||
${CP} -r ${WRKSRC}/../${wwwdir} ${momdir}
|
||||
${INSTALL} -c -o ${BINOWN} -g ${BINGRP} -m ${BINMODE} \
|
||||
${FILESDIR}/momspider.sh ${PREFIX}/bin/momspider
|
||||
|
||||
.include <bsd.port.mk>
|
2
www/momspider/distinfo
Normal file
2
www/momspider/distinfo
Normal file
|
@ -0,0 +1,2 @@
|
|||
MD5 (MOMspider-1.00.tar.gz) = 3e13ca5d837d68430ce95b544e8fc022
|
||||
MD5 (libwww-perl-0.40.tar.gz) = 665610fa3b0c1aa635ed166ea3944bff
|
20
www/momspider/files/momspider.sh
Normal file
20
www/momspider/files/momspider.sh
Normal file
|
@ -0,0 +1,20 @@
|
|||
#!/bin/sh
|
||||
#
|
||||
# wrapper for momspider
|
||||
#
|
||||
# MOMspider is a web-roaming robot that specializes in the maintenance
|
||||
# of distributed hypertext infostructures (i.e. wide-area webs). The
|
||||
# program is written in Perl and, once customized for your site, should
|
||||
# work on any UNIX-based system with Perl 4.036.
|
||||
#
|
||||
# The momspider documentation is in /usr/local/momspider/README.html
|
||||
#
|
||||
# $Id$
|
||||
|
||||
PATH=/bin:/usr/bin; export PATH
|
||||
momhome=/usr/local/momspider
|
||||
|
||||
: ${LIBWWW_PERL=$momhome/libwww-perl-0.40}; export LIBWWW_PERL
|
||||
: ${MOMSPIDER_HOME=$momhome}; export MOMSPIDER_HOME
|
||||
|
||||
exec perl ${MOMSPIDER_HOME}/momspider "$@"
|
11
www/momspider/files/patch-aa
Normal file
11
www/momspider/files/patch-aa
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- momconfig.pl 1997/10/10 22:35:11 1.1
|
||||
+++ momconfig.pl 1997/10/10 22:35:29
|
||||
@@ -78,7 +78,7 @@
|
||||
# which messages should be mailed, and accepts other headers and message
|
||||
# text from stdin.
|
||||
|
||||
-$sendmailCommand = "/usr/lib/sendmail";
|
||||
+$sendmailCommand = "/usr/sbin/sendmail";
|
||||
|
||||
|
||||
# ==========================================================================
|
1
www/momspider/pkg-comment
Normal file
1
www/momspider/pkg-comment
Normal file
|
@ -0,0 +1 @@
|
|||
WWW Spider for multi-owner maintenance.
|
4
www/momspider/pkg-descr
Normal file
4
www/momspider/pkg-descr
Normal file
|
@ -0,0 +1,4 @@
|
|||
MOMspider is a web-roaming robot that specializes in the maintenance
|
||||
of distributed hypertext infostructures (i.e. wide-area webs). The
|
||||
program is written in Perl and, once customized for your site, should
|
||||
work on any UNIX-based system with Perl 4.036.
|
56
www/momspider/pkg-plist
Normal file
56
www/momspider/pkg-plist
Normal file
|
@ -0,0 +1,56 @@
|
|||
momspider/libwww-perl-0.40/LWP_Changes.pl
|
||||
momspider/libwww-perl-0.40/wwwdates.pl
|
||||
momspider/libwww-perl-0.40/wwwerror.pl
|
||||
momspider/libwww-perl-0.40/wwwfile.pl
|
||||
momspider/libwww-perl-0.40/wwwhtml.pl
|
||||
momspider/libwww-perl-0.40/wwwhttp.pl
|
||||
momspider/libwww-perl-0.40/wwwmime.pl
|
||||
momspider/libwww-perl-0.40/wwwurl.pl
|
||||
momspider/libwww-perl-0.40/get
|
||||
momspider/libwww-perl-0.40/testdates
|
||||
momspider/libwww-perl-0.40/mime.types
|
||||
momspider/libwww-perl-0.40/README.html
|
||||
momspider/libwww-perl-0.40/Artistic.txt
|
||||
momspider/libwww-perl-0.40/Makefile
|
||||
momspider/libwww-perl-0.40/INSTALL.txt
|
||||
momspider/libwww-perl-0.40/testescapes
|
||||
momspider/libwww-perl-0.40/testlinks
|
||||
momspider/libwww-perl-0.40/wwwbot.pl
|
||||
momspider/libwww-perl-0.40/testbot
|
||||
momspider/libwww-perl-0.40/wwwmailcap.pl
|
||||
momspider/libwww-perl-0.40/sys_socket_ph.c
|
||||
momspider/libwww-perl-0.40/hostname.pl
|
||||
momspider/libwww-perl-0.40/www.pl
|
||||
momspider/examples/short-email.txt
|
||||
momspider/examples/.momspider-sites
|
||||
momspider/examples/.momspider-avoid
|
||||
momspider/examples/short-instruct
|
||||
momspider/examples/short-index.html
|
||||
momspider/examples/short-outfile.txt
|
||||
momspider/examples/ICS-instruct
|
||||
momspider/examples/.momspider-instruct
|
||||
momspider/docs/extending.html
|
||||
momspider/docs/config.html
|
||||
momspider/docs/www94_paper.ps
|
||||
momspider/docs/instruct.html
|
||||
momspider/docs/usage.html
|
||||
momspider/docs/avoiding.html
|
||||
momspider/docs/metainfo.html
|
||||
momspider/docs/INSTALL.txt
|
||||
momspider/momvisit.pl
|
||||
momspider/momspider
|
||||
momspider/momindex.pl
|
||||
momspider/momhistory.pl
|
||||
momspider/momevent.pl
|
||||
momspider/momemail.pl
|
||||
momspider/momconfig.pl.orig
|
||||
momspider/momconfig.pl
|
||||
momspider/momavoid.pl
|
||||
momspider/README.html
|
||||
momspider/system-sites
|
||||
momspider/MOM_Changes.pl
|
||||
momspider/system-avoid
|
||||
@dirrm momspider/libwww-perl-0.40
|
||||
@dirrm momspider/examples
|
||||
@dirrm momspider/docs
|
||||
@dirrm momspider
|
Loading…
Reference in a new issue