- Fix build.
This commit is contained in:
parent
6b4999bf8f
commit
5ac7ca8068
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=252544
2 changed files with 0 additions and 13 deletions
|
@ -35,10 +35,6 @@ OPTIONS= X11 "Build with X11 support" on \
|
|||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if ${OSVERSION} >= 800501
|
||||
BROKEN= does not build
|
||||
.endif
|
||||
|
||||
.if defined(WITHOUT_X11)
|
||||
PKGNAMESUFFIX= -nox11
|
||||
CONFIGURE_ARGS+=--without-x --with-rubik
|
||||
|
|
|
@ -25,12 +25,3 @@
|
|||
#include <sys/types.h>
|
||||
#include <sys/wait.h>
|
||||
#include <termios.h>
|
||||
@@ -640,7 +640,7 @@
|
||||
/* this is the function selecting files for the scandir
|
||||
on freebsd systems you should change the following line to:
|
||||
int selector(struct dirent *dir) { */
|
||||
-int selector(const struct dirent *dir) {
|
||||
+int selector(struct dirent *dir) {
|
||||
if( strncasecmp(dir->d_name+strlen(dir->d_name)-4,".mp3",4)==0
|
||||
#ifdef HAVE_VORBIS
|
||||
|| strncasecmp(dir->d_name+strlen(dir->d_name)-4,".ogg",4)==0
|
||||
|
|
Loading…
Reference in a new issue