Generated build.ninja is wrong on powerpc64. Replace $(MAKE) with

"make" in CMakeLists.txt.

PR:		232563
Submitted by:	Piotr Kubaj
Approved by:	portmgr (tier-2 blanket)
This commit is contained in:
Mark Linimon 2018-11-05 20:05:42 +00:00
parent f2a697b0a4
commit 5ac8045f09
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=484214
2 changed files with 14 additions and 2 deletions

View file

@ -12,8 +12,6 @@ COMMENT= YAML parser and emitter in C++ matching the YAML 1.2 spec
LICENSE= MIT
BROKEN_powerpc64= fails to build: ninja: build.ninja:386: bad $-escape (literal $ must be written as $$)
USES= cmake
USE_LDCONFIG= yes
CMAKE_ARGS+= -DBUILD_SHARED_LIBS:BOOL=ON -DYAML_CPP_BUILD_TOOLS=0

View file

@ -1,5 +1,19 @@
--- CMakeLists.txt.orig 2013-04-14 03:37:53.000000000 +0400
+++ CMakeLists.txt 2014-09-11 17:37:09.000000000 +0400
@@ -139,11 +139,11 @@ if(CMAKE_COMPILER_IS_GNUCXX)
#
set(CMAKE_CXX_FLAGS "-Wall ${GCC_EXTRA_OPTIONS} -pedantic -Wno-long-long ${CMAKE_CXX_FLAGS}")
#
- add_custom_target(debuggable $(MAKE) clean
+ add_custom_target(debuggable make clean
COMMAND ${CMAKE_COMMAND} -DCMAKE_BUILD_TYPE=Debug ${CMAKE_SOURCE_DIR}
COMMENT "Adjusting settings for debug compilation"
VERBATIM)
- add_custom_target(releasable $(MAKE) clean
+ add_custom_target(releasable make clean
COMMAND ${CMAKE_COMMAND} -DCMAKE_BUILD_TYPE=Release ${CMAKE_SOURCE_DIR}
COMMENT "Adjusting settings for release compilation"
VERBATIM)
@@ -240,7 +240,7 @@
set_target_properties(yaml-cpp PROPERTIES