- Update to 0.5.0
This commit is contained in:
parent
2da18cd389
commit
5ad85ef505
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=363857
5 changed files with 39 additions and 16 deletions
|
@ -2,9 +2,9 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME= bamf
|
||||
PORTVERSION= 0.4.0
|
||||
PORTVERSION= 0.5.0
|
||||
CATEGORIES= sysutils
|
||||
MASTER_SITES= https://launchpadlibrarian.net/140100218/ \
|
||||
MASTER_SITES= https://launchpadlibrarian.net/148968286/ \
|
||||
https://launchpad.net/${PORTNAME}/${PORTVERSION:R}/${PORTVERSION}/+download/
|
||||
|
||||
MAINTAINER= olivierd@FreeBSD.org
|
||||
|
@ -13,11 +13,11 @@ COMMENT= BAMF Application Matching Framework
|
|||
LICENSE= LGPL3
|
||||
LICENSE_FILE= ${WRKSRC}/COPYING.LGPL
|
||||
|
||||
BUILD_DEPENDS= vapigen:${PORTSDIR}/lang/vala-vapigen
|
||||
BUILD_DEPENDS= vapigen:${PORTSDIR}/lang/vala-vapigen \
|
||||
${PYTHON_PKGNAMEPREFIX}libxml2>=2.8.0:${PORTSDIR}/textproc/py-libxml2 \
|
||||
${PYTHON_PKGNAMEPREFIX}libxslt>=1.1.28:${PORTSDIR}/textproc/py-libxslt
|
||||
LIB_DEPENDS= libgtop-2.0.so:${PORTSDIR}/devel/libgtop \
|
||||
libdbus-glib-1.so:${PORTSDIR}/devel/dbus-glib
|
||||
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}libxml2>=2.8.0:${PORTSDIR}/textproc/py-libxml2 \
|
||||
${PYTHON_PKGNAMEPREFIX}libxslt>=1.1.28:${PORTSDIR}/textproc/py-libxslt
|
||||
|
||||
USES= pkgconfig gmake pathfix libtool
|
||||
GNU_CONFIGURE= yes
|
||||
|
@ -31,4 +31,8 @@ CONFIGURE_ARGS+=--disable-webapps \
|
|||
--disable-gtk-doc-html \
|
||||
--without-html-dir
|
||||
|
||||
post-patch:
|
||||
${FIND} ${WRKSRC} -type f -name 'Makefile.in' \
|
||||
| ${XARGS} ${REINPLACE_CMD} -e 's| -Wl,-Bsymbolic-functions||'
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,2 +1,2 @@
|
|||
SHA256 (bamf-0.4.0.tar.gz) = 65d05e0173336a8548bf5f67a940b46f02eb000bf7dc60a05b13fb9ccd7aade4
|
||||
SIZE (bamf-0.4.0.tar.gz) = 550402
|
||||
SHA256 (bamf-0.5.0.tar.gz) = 93b1acced96d32b36270cf18feb2761014ce2226814303c632448f717a8f9113
|
||||
SIZE (bamf-0.5.0.tar.gz) = 579263
|
||||
|
|
|
@ -1,11 +1,11 @@
|
|||
--- ./configure.orig 2013-05-17 14:06:54.189515000 +0000
|
||||
+++ ./configure 2014-04-02 19:19:29.000000000 +0000
|
||||
@@ -14546,7 +14546,7 @@
|
||||
--- ./configure.orig 2013-08-30 16:26:19.388840000 +0000
|
||||
+++ ./configure 2014-08-02 15:44:13.000000000 +0000
|
||||
@@ -14518,7 +14518,7 @@
|
||||
rm -f conf.gtktest
|
||||
|
||||
|
||||
-CFLAGS="$CFLAGS -Wall -Werror -lm"
|
||||
+CFLAGS="$CFLAGS -Wall"
|
||||
-CFLAGS="$CFLAGS -Wall -Werror -Wempty-body -Wformat-security -Winit-self -Warray-bounds -Wimplicit-function-declaration -lm"
|
||||
+CFLAGS="$CFLAGS -Wall -Wformat-security -Winit-self -Wimplicit-function-declaration"
|
||||
|
||||
|
||||
|
||||
|
|
20
sysutils/bamf/files/patch-lib__libbamf-private__Makefile.in
Normal file
20
sysutils/bamf/files/patch-lib__libbamf-private__Makefile.in
Normal file
|
@ -0,0 +1,20 @@
|
|||
--- ./lib/libbamf-private/Makefile.in.orig 2013-08-30 16:26:20.552840000 +0000
|
||||
+++ ./lib/libbamf-private/Makefile.in 2014-08-02 15:33:08.000000000 +0000
|
||||
@@ -705,7 +705,7 @@
|
||||
--interface-prefix org.ayatana.bamf \
|
||||
$<; \
|
||||
# Adding '_' prefix to generated private functions \
|
||||
- $(SED) "s/bamf_dbus/_bamf_dbus/g" -i \
|
||||
+ $(SED) -i "" "s/bamf_dbus/_bamf_dbus/g" \
|
||||
$@ $(shell basename $@ .c).h
|
||||
|
||||
.NOTPARALLEL:
|
||||
@@ -717,7 +717,7 @@
|
||||
--interface-prefix org.ayatana.bamf \
|
||||
$<; \
|
||||
# Adding '_' prefix to generated private functions \
|
||||
- $(SED) "s/bamf_dbus_item/_bamf_dbus_item/g" -i \
|
||||
+ $(SED) -i "" "s/bamf_dbus_item/_bamf_dbus_item/g" \
|
||||
$@ $(shell basename $@ .c).h
|
||||
|
||||
# Tell versions [3.59,3.63) of GNU make to not export all variables.
|
|
@ -1,20 +1,19 @@
|
|||
include/libbamf3/libbamf/bamf-application.h
|
||||
include/libbamf3/libbamf/bamf-control.h
|
||||
include/libbamf3/libbamf/bamf-matcher.h
|
||||
include/libbamf3/libbamf/bamf-tab-source.h
|
||||
include/libbamf3/libbamf/bamf-tab.h
|
||||
include/libbamf3/libbamf/bamf-view.h
|
||||
include/libbamf3/libbamf/bamf-window.h
|
||||
include/libbamf3/libbamf/libbamf.h
|
||||
lib/girepository-1.0/Bamf-3.typelib
|
||||
lib/libbamf3.so
|
||||
lib/libbamf3.so.1
|
||||
lib/libbamf3.so.1.0.0
|
||||
lib/libbamf3.so.2
|
||||
lib/libbamf3.so.2.0.0
|
||||
libdata/pkgconfig/libbamf3.pc
|
||||
libexec/bamf/bamfdaemon
|
||||
share/dbus-1/services/org.ayatana.bamf.service
|
||||
share/gir-1.0/Bamf-3.gir
|
||||
share/vala/vapi/libbamf3.vapi
|
||||
@dirrm libexec/bamf
|
||||
@dirrm include/libbamf3/libbamf
|
||||
@dirrm include/libbamf3
|
||||
@dirrm libexec/bamf
|
||||
|
|
Loading…
Reference in a new issue