- Remove obsolete mupen64plus ports

This commit is contained in:
Jose Alonso Cardenas Marquez 2010-12-13 08:33:44 +00:00
parent 80484528a2
commit 5b0e8fd179
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=266197
5 changed files with 0 additions and 103 deletions

View file

@ -114,7 +114,6 @@
SUBDIR += mupen64-tr64
SUBDIR += mupen64plus
SUBDIR += mupen64plus-audio-sdl
SUBDIR += mupen64plus-base
SUBDIR += mupen64plus-core
SUBDIR += mupen64plus-input-sdl
SUBDIR += mupen64plus-rice

View file

@ -1,20 +0,0 @@
# New ports collection makefile for: mupen64plus-dummyaudio
# Date created: 2008-05-16
# Whom: Jose Alonso Cardenas Marquez <acm@FreeBSD.org>
#
# $FreeBSD$
#
PKGNAMESUFFIX= -dummyaudio
COMMENT= Dummy audio plugin for Mupen64plus
FIXFILES= #
PLUGIN_NAME= dummyaudio
MASTERDIR= ${.CURDIR}/../mupen64plus-base
OPTIONS= #
.include "${MASTERDIR}/Makefile"

View file

@ -1,20 +0,0 @@
# New ports collection makefile for: mupen64plus-dummyvideo
# Date created: 2009-01-13
# Whom: Jose Alonso Cardenas Marquez <acm@FreeBSD.org>
#
# $FreeBSD$
#
PKGNAMESUFFIX= -dummyvideo
COMMENT= Dummy video plugin for Mupen64plus
FIXFILES= #
PLUGIN_NAME= dummyvideo
MASTERDIR= ${.CURDIR}/../mupen64plus-base
OPTIONS= #
.include "${MASTERDIR}/Makefile"

View file

@ -1,23 +0,0 @@
# New ports collection makefile for: mupen64plus-gln64
# Date created: 2008-05-16
# Whom: Jose Alonso Cardenas Marquez <acm@FreeBSD.org>
#
# $FreeBSD$
#
PKGNAMESUFFIX= -gln64
COMMENT= The glN64 graphics plugin for Mupen64plus
USE_GL= yes
USE_SDL= sdl
FIXFILES= glN64/DepthBuffer.cpp
PLUGIN_NAME= glN64
MASTERDIR= ${.CURDIR}/../mupen64plus-base
OPTIONS= #
.include "${MASTERDIR}/Makefile"

View file

@ -1,39 +0,0 @@
--- glN64/Config_gtk2.cpp 2008-12-15 01:42:14.000000000 -0500
+++ glN64/Config_gtk2.cpp 2008-12-15 01:50:17.000000000 -0500
@@ -1,4 +1,3 @@
-#include <features.h>
#include <dlfcn.h>
#include <unistd.h>
#include "../main/winlnxdefs.h"
@@ -44,29 +43,8 @@
}
else
{
-#ifdef __USE_GNU
- Dl_info info;
- void *addr = (void*)GetPluginDir;
- if(dladdr(addr, &info) != 0)
- {
- strncpy(path, info.dli_fname, PATH_MAX);
- *(strrchr(path, '/')) = '\0';
- }
- else
- {
- fprintf(stderr, "(WW) Couldn't get path of .so, trying to get emulator's path\n");
-#endif // __USE_GNU
- if(readlink("/proc/self/exe", path, PATH_MAX) == -1)
- {
- fprintf(stderr, "(WW) readlink() /proc/self/exe failed: %s\n", strerror(errno));
- path[0] = '.';
- path[1] = '\0';
- }
- *(strrchr(path, '/')) = '\0';
- strncat(path, "/plugins", PATH_MAX);
-#ifdef __USE_GNU
- }
-#endif
+ strcpy(path, getenv("HOME"));
+ strncat(path, "/.mupen64plus/plugins", PATH_MAX);
}
return path;
}