- Update to version 1.27.1.

- Remove wrapper script (upstream includes it now)
- Use SDL instead of ALLEGRO since it doesn't build with allegrogl.
- Update pkg-message according to wrapper scripts change.
This commit is contained in:
Alejandro Pulver 2008-04-24 16:41:23 +00:00
parent 756ece651b
commit 5b414193f5
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=211894
7 changed files with 61 additions and 2061 deletions

View file

@ -6,8 +6,7 @@
#
PORTNAME= vavoom
PORTVERSION= 1.26
PORTREVISION= 2
PORTVERSION= 1.27.1
CATEGORIES= games
MASTER_SITES= SF
@ -18,13 +17,11 @@ LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
png.5:${PORTSDIR}/graphics/png
USE_BZIP2= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib"
CMAKE_ARGS= -DCMAKE_INSTALL_PREFIX="${PREFIX}" \
-DCMAKE_C_COMPILER:STRING="${CC}" \
-DCMAKE_CXX_COMPILER:STRING="${CXX}"
OPTIONS= ALLEGRO "Use Allegro for hardware API" off \
EDITING "Install Doom and Vavoom editing tools" off \
FLAC "Enable FLAC support" off \
LAUNCHER "Build GUI launcher" on \
LIBMAD "Enable MP3 support" off \
@ -35,7 +32,7 @@ OPTIONS= ALLEGRO "Use Allegro for hardware API" off \
VORBIS "Enable Ogg Vorbis support" off \
SDL "Use SDL for hardware API" on
SUB_FILES= ${PORTNAME} pkg-message
SUB_FILES= pkg-message
.include <bsd.port.pre.mk>
@ -53,62 +50,59 @@ IGNORE= selected conflicting options ALLEGRO and SDL
.endif
.if defined(WITH_ALLEGRO)
LIB_DEPENDS+= alleg.42:${PORTSDIR}/devel/allegro \
agl.4:${PORTSDIR}/graphics/allegrogl
CONFIGURE_ARGS+=--with-allegro
LIB_DEPENDS+= alleg.42:${PORTSDIR}/devel/allegro
CMAKE_ARGS+= -DWITH_ALLEGRO=Y
.else
CONFIGURE_ARGS+=--without-allegro
.endif
.if defined(WITH_EDITING)
PLIST_SUB+= EDITING=""
.else
PLIST_SUB+= EDITING="@comment "
CMAKE_ARGS+= -DWITH_ALLEGRO=N
.endif
.if defined(WITH_FLAC)
LIB_DEPENDS+= FLAC.10:${PORTSDIR}/audio/flac
CONFIGURE_ARGS+=--with-flac
CMAKE_ARGS+= -DWITH_FLAC=Y
.else
CONFIGURE_ARGS+=--without-flac
CMAKE_ARGS+= -DWITH_FLAC=N
.endif
.if defined(WITH_LAUNCHER)
USE_WX= 2.4+
WX_CONF_ARGS= absolute
CONFIGURE_ARGS+=--enable-launcher
CMAKE_ARGS+= -DENABLE_LAUNCHER=Y \
-DwxWidgets_CONFIG_EXECUTABLE="${WX_CONFIG}"
PLIST_SUB+= LAUNCHER=""
.else
CONFIGURE_ARGS+=--disable-launcher
CMAKE_ARGS+= -DENABLE_LAUNCHER=N
PLIST_SUB+= LAUNCHER="@comment "
.endif
.if defined(WITH_LIBMAD)
LIB_DEPENDS+= mad.2:${PORTSDIR}/audio/libmad
CONFIGURE_ARGS+=--with-libmad
CMAKE_ARGS+= -DWITH_LIBMAD=Y
.else
CONFIGURE_ARGS+=--without-libmad
CMAKE_ARGS+= -DWITH_LIBMAD=N
.endif
.if defined(WITH_MIKMOD)
LIB_DEPENDS+= mikmod.2:${PORTSDIR}/audio/libmikmod
CONFIGURE_ARGS+=--with-mikmod
CMAKE_ARGS+= -DWITH_MIKMOD=Y
.else
CONFIGURE_ARGS+=--without-mikmod
CMAKE_ARGS+= -DWITH_MIKMOD=N
.endif
.if defined(WITH_OPENAL)
LIB_DEPENDS+= openal.0:${PORTSDIR}/audio/openal
CONFIGURE_ARGS+=--with-openal
CMAKE_ARGS+= -DWITH_OPENAL=Y
.else
CONFIGURE_ARGS+=--without-openal
CMAKE_ARGS+= -DWITH_OPENAL=N
.endif
.if defined(WITH_OPENGL)
USE_GL= yes
CONFIGURE_ARGS+=--with-opengl
. if defined(WITH_ALLEGRO)
LIB_DEPENDS+= agl.0:${PORTSDIR}/graphics/allegrogl
BROKEN= please use SDL instead of ALLEGRO, for OPENGL support
. endif
CMAKE_ARGS+= -DWITH_OPENGL=Y
.else
CONFIGURE_ARGS+=--without-opengl
CMAKE_ARGS+= -DWITH_OPENGL=N
.endif
.if defined(WITH_OPTIMIZED_CFLAGS)
@ -117,37 +111,27 @@ CFLAGS+= -O3 -ffast-math -fomit-frame-pointer
.if defined(WITH_VORBIS)
LIB_DEPENDS+= vorbis.4:${PORTSDIR}/audio/libvorbis
CONFIGURE_ARGS+=--with-vorbis
CMAKE_ARGS+= -DWITH_VORBIS=Y
.else
CONFIGURE_ARGS+=--without-vorbis
CMAKE_ARGS+= -DWITH_VORBIS=N
.endif
.if defined(WITH_SDL)
USE_SDL= mixer sdl
CONFIGURE_ARGS+=--with-sdl
CMAKE_ARGS+= -DWITH_SDL=Y
.else
CONFIGURE_ARGS+=--without-sdl
CMAKE_ARGS+= -DWITH_SDL=N
.endif
post-patch:
@${REINPLACE_CMD} -e 's|\.$$host_cpu||' \
${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
@cd ${WRKSRC} && ${SH} fixunix.sh
@${REINPLACE_CMD} -e 's|$$\* $${IWADDIR}|-iwaddir ${DMDIR} $$*|' \
${WRKSRC}/source/CMakeLists.txt
pre-build:
@cd ${WRKSRC} && cmake ${CMAKE_ARGS} .
post-install:
${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME} ${PREFIX}/bin
.if defined(WITH_EDITING)
${INSTALL_PROGRAM} ${WRKSRC}/utils/bin/* ${PREFIX}/libexec/${PORTNAME}
. for f in utils/editing progs
${CP} -r ${WRKSRC}/${f} ${DATADIR}
@${FIND} ${DATADIR}/${f:T} -type d -print0 | \
${XARGS} -0 ${CHMOD} ${BINMODE}
@${FIND} ${DATADIR}/${f:T} -type f -print0 | \
${XARGS} -0 ${CHMOD} ${SHAREMODE}
. endfor
@${FIND} ${DATADIR}/progs -type f -name "Makefile*" -print0 | \
${XARGS} -0 ${REINPLACE_CMD} -i '' -Ee 's|^(VCC =).*|\1 vcc|'
.endif
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/docs/vavoom.txt ${DOCSDIR}

View file

@ -1,3 +1,3 @@
MD5 (vavoom-1.26.tar.bz2) = 4fb8d126faa5b37e0737674338a0f7ca
SHA256 (vavoom-1.26.tar.bz2) = 782b0c3c8f7f3fb32a9ea6f3a61e76c1f99ea956a2313e6f890da98bd66590ef
SIZE (vavoom-1.26.tar.bz2) = 1792895
MD5 (vavoom-1.27.1.tar.bz2) = 0a0d3781cfeb5625d54abf6a1f4da4bc
SHA256 (vavoom-1.27.1.tar.bz2) = 33d3a3012927690a921ca52388850cb007e4a166623cfdb8dc2badddbaad8e54
SIZE (vavoom-1.27.1.tar.bz2) = 1569598

View file

@ -1,29 +0,0 @@
--- source/Makefile.in.orig Thu Oct 4 15:27:31 2007
+++ source/Makefile.in Mon Nov 19 04:25:26 2007
@@ -937,14 +937,14 @@
cd $(top_builddir) && $(MAKE) $(AM_MAKEFLAGS) am--refresh
install-binPROGRAMS: $(bin_PROGRAMS)
@$(NORMAL_INSTALL)
- test -z "$(bindir)" || $(MKDIR_P) "$(DESTDIR)$(bindir)"
+ test -z "$(libexecdir)/vavoom" || $(MKDIR_P) "$(DESTDIR)$(libexecdir)/vavoom"
@list='$(bin_PROGRAMS)'; for p in $$list; do \
p1=`echo $$p|sed 's/$(EXEEXT)$$//'`; \
if test -f $$p \
; then \
f=`echo "$$p1" | sed 's,^.*/,,;$(transform);s/$$/$(EXEEXT)/'`; \
- echo " $(INSTALL_PROGRAM_ENV) $(binPROGRAMS_INSTALL) '$$p' '$(DESTDIR)$(bindir)/$$f'"; \
- $(INSTALL_PROGRAM_ENV) $(binPROGRAMS_INSTALL) "$$p" "$(DESTDIR)$(bindir)/$$f" || exit 1; \
+ echo " $(INSTALL_PROGRAM_ENV) $(binPROGRAMS_INSTALL) '$$p' '$(DESTDIR)$(libexecdir)/vavoom/$$f'"; \
+ $(INSTALL_PROGRAM_ENV) $(binPROGRAMS_INSTALL) "$$p" "$(DESTDIR)$(libexecdir)/vavoom/$$f" || exit 1; \
else :; fi; \
done
@@ -5162,7 +5162,7 @@
install-dvi: install-dvi-recursive
-install-exec-am: install-binPROGRAMS install-binSCRIPTS
+install-exec-am: install-binPROGRAMS
install-html: install-html-recursive

View file

@ -0,0 +1,17 @@
--- ./source/sys_bsd.cpp.orig 2006-09-26 20:32:53.000000000 -0300
+++ ./source/sys_bsd.cpp 2008-04-21 14:45:17.000000000 -0300
@@ -29,13 +29,13 @@
// HEADER FILES ------------------------------------------------------------
-#include "gamedefs.h"
#include <signal.h>
#include <fcntl.h>
#include <unistd.h>
#include <dirent.h>
#include <sys/stat.h>
#include <sys/time.h>
+#include "gamedefs.h"
#ifdef DJGPP
#include <dpmi.h>

View file

@ -2,25 +2,16 @@
Vavoom has been installed.
The wrapper script is named "vavoom" and accepts a "-s" argument to run the
dedicated server instead of the client. It creates/enters ~/.vavoom (if it
does not exist creates symlinks) and runs the programs from there, looking for
additional IWAD files in "%%DMDIR%%".
The real executables (and utils) are in "%%PREFIX%%/libexec/vavoom".
If you enabled the EDITING option the VavoomC source code of the supported
games has been installed to "%%DATADIR%%/progs".
There are 2 wrapper scripts: "vavoom" and "vavoom-dedicated", calling the real
executables (suffixed with ".bin") from the data directory, and using the
common WAD directory.
To run in OpenGL mode add the "-opengl" parameter, and "-openal" for OpenAL.
If you want to install enhaced textures, models or soundtracks use the
If you want to install enhanced textures, models or soundtracks use the
"games/vavoom-extras" port. Note that textures require OPENGL and soundtracks
need VORBIS (build options).
If you enabled LAUNCHER (build option), run "vlaunch" for a launcher GUI.
If updating an old installation, or added/changed extras, run the wrapper with
the "-f" parameter to fix/recreate the symlinks. Then run as normal.
==============================================================================

View file

@ -1,37 +0,0 @@
#!/bin/sh
# The executable needs to run from its data directory, so we mirror it to
# ~/.vavoom (with symlinks) and run it from there.
CMD="vavoom"
WRAPDIR=~/.vavoom
make_symlinks()
{
cd %%DATADIR%%/basev || exit 1
find * -type d -exec mkdir -p ${WRAPDIR}/basev/{} \;
find * -type f -exec ln -sf %%DATADIR%%/basev/{} ${WRAPDIR}/basev/{} \;
}
if [ "$1" = "-s" ]
then
CMD="vavoom-dedicated"
shift
elif [ "$1" = "-f" -a -d ${WRAPDIR} ]
then
echo "Fixing symlinks in ${WRAPDIR} directory." 1>&2
find -L ${WRAPDIR} -type l -delete
make_symlinks
exit 0
fi
if [ -d ${WRAPDIR} ]
then
echo "Using existing ${WRAPDIR} directory." 1>&2
else
echo "Creating ${WRAPDIR} directory." 1>&2
make_symlinks
fi
cd ${WRAPDIR} || exit 1
exec %%PREFIX%%/libexec/vavoom/${CMD} -iwaddir %%DMDIR%% "$@"

File diff suppressed because it is too large Load diff