Bombono DVD is a DVD authoring program.

It is made easy to use and has nice and clean GUI (Gtk).

The main features of Bombono DVD are:
	+excellent MPEG viewer: Timeline and Monitor
	+real WYSIWYG Menu Editor with live thumbnails
	+comfortable Drag-n-Drop support
	+you can author to folder, make ISO-image or burn directly to DVD
	+reauthoring: you can import video from DVD discs.

WWW: http://www.bombono.org
- Stas Timokhin
stast@bsdportal.ru

PR:		138623
Submitted by:	Stas Timokhin <stast@bsdportal.ru>
This commit is contained in:
Dmitry Marakasov 2009-12-22 09:55:35 +00:00
parent 9c5ddf5958
commit 5b7e203296
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=246428
6 changed files with 173 additions and 0 deletions

View file

@ -19,6 +19,7 @@
SUBDIR += beep-media-player
SUBDIR += bmp-extra-plugins
SUBDIR += bmpx
SUBDIR += bombono
SUBDIR += bsdbktr_tvtune
SUBDIR += camserv
SUBDIR += castpodder

View file

@ -0,0 +1,43 @@
# New ports collection makefile for: multimedia/bombono
# Date created: 07 Sep 2009
# Whom: Stas Timokhin <stast@bsdportal.ru>
#
# $FreeBSD$
#
PORTNAME= bombono
PORTVERSION= 0.5.1
CATEGORIES= multimedia
MASTER_SITES= SF/bombono/bombono-dvd/${PORTVERSION} \
http://www.stasyan.com/devel/distfiles/
DISTNAME= bombono-dvd-${PORTVERSION}
MAINTAINER= stast@bsdportal.ru
COMMENT= DVD authoring program
LIB_DEPENDS= gtkmm-2.4.1:${PORTSDIR}/x11-toolkits/gtkmm24 \
xml++-2.6.2:${PORTSDIR}/textproc/libxml++26
BUILD_DEPENDS= GraphicsMagick>=1.1.7:${PORTSDIR}/graphics/GraphicsMagick \
mjpegtools>=1.8.0:${PORTSDIR}/multimedia/mjpegtools \
dvdread-config:${PORTSDIR}/multimedia/libdvdread
RUN_DEPENDS= GraphicsMagick>=1.1.7:${PORTSDIR}/graphics/GraphicsMagick \
mjpegtools>=1.8.0:${PORTSDIR}/multimedia/mjpegtools \
dvdread-config:${PORTSDIR}/multimedia/libdvdread \
dvda-author:${PORTSDIR}/audio/dvda-author \
growisofs:${PORTSDIR}/sysutils/dvd+rw-tools \
toolame:${PORTSDIR}/audio/toolame
USE_BZIP2= yes
USE_GNOME= gtk20 libxml2
USE_GCC= 4.2+
USE_SCONS= yes
SCONS_ENV= CCFLAGS="${CCFLAGS}" CXXFLAGS="${CXXFLAGS}" \
LINKFLAGS="${LINKFLAGS}" PKGCONFIGDIR="${PKGCONFIGDIR}" \
CPPPATH="${CPPPATH}" LIBPATH="${LIBPATH}" PREFIX="${PREFIX}" \
CC="${CC}" CXX="${CXX}" \
DVDREAD_LIBPATH=${LOCALBASE}/lib DVDREAD_INCLUDE=${LOCALBASE}/include
post-patch:
@${REINPLACE_CMD} -e 's|-O2||' ${WRKSRC}/SConstruct
.include <bsd.port.mk>

View file

@ -0,0 +1,3 @@
MD5 (bombono-dvd-0.5.1.tar.bz2) = 0626c604cce6f2030259b041ca45dafd
SHA256 (bombono-dvd-0.5.1.tar.bz2) = 090288d0da4b01a4ab76535bc73e848f1813362827290a9942cc7976a87b31dd
SIZE (bombono-dvd-0.5.1.tar.bz2) = 1699435

View file

@ -0,0 +1,10 @@
--- src/mlib/stream.h.orig 2009-08-24 15:11:47.000000000 +0700
+++ src/mlib/stream.h 2009-08-24 15:12:03.000000000 +0700
@@ -186,6 +186,7 @@
// write(fd, "some text", 9);
// ..
// Причины использования класса io::fd_proxy см. в его описании
+#undef fileno
opaque_file fileno()
{ return opaque_file(this->file()); }

View file

@ -0,0 +1,13 @@
Bombono DVD is a DVD authoring program.
It is made easy to use and has nice and clean GUI (Gtk).
The main features of Bombono DVD are:
+excellent MPEG viewer: Timeline and Monitor
+real WYSIWYG Menu Editor with live thumbnails
+comfortable Drag-n-Drop support
+you can author to folder, make ISO-image or burn directly to DVD
+reauthoring: you can import video from DVD discs.
WWW: http://www.bombono.org
- Stas Timokhin
stast@bsdportal.ru

View file

@ -0,0 +1,103 @@
bin/bombono-dvd
bin/mpeg2demux
share/applications/bombono-dvd.desktop
%%DATADIR%%/resources/about-back.png
%%DATADIR%%/resources/about-front.png
%%DATADIR%%/resources/area-back.jpg
%%DATADIR%%/resources/button/001.ico
%%DATADIR%%/resources/button/002.ico
%%DATADIR%%/resources/button/003.ico
%%DATADIR%%/resources/button/004.ico
%%DATADIR%%/resources/button/005.ico
%%DATADIR%%/resources/button/006.ico
%%DATADIR%%/resources/button/007.ico
%%DATADIR%%/resources/button/008.ico
%%DATADIR%%/resources/button/still.ico
%%DATADIR%%/resources/cap400.png
%%DATADIR%%/resources/copy-n-paste/HelixPlayer_Activity-watch-listen.svg
%%DATADIR%%/resources/copy-n-paste/HelixPlayer_Activity-watch-listen/12.png
%%DATADIR%%/resources/copy-n-paste/HelixPlayer_Activity-watch-listen/16.png
%%DATADIR%%/resources/copy-n-paste/HelixPlayer_Activity-watch-listen/28.png
%%DATADIR%%/resources/dvdmark.png
%%DATADIR%%/resources/emblems/README
%%DATADIR%%/resources/emblems/audio-x-generic.png
%%DATADIR%%/resources/emblems/camera-photo.png
%%DATADIR%%/resources/emblems/media-playback-start.png
%%DATADIR%%/resources/emblems/media-playback-start_mini.png
%%DATADIR%%/resources/emblems/stock_about.png
%%DATADIR%%/resources/emblems/stock_graphic-styles.png
%%DATADIR%%/resources/emblems/stock_navigator-open-toolbar.png
%%DATADIR%%/resources/emblems/tmp/applets-screenshooter.png
%%DATADIR%%/resources/emblems/tmp/application-x-executable.png
%%DATADIR%%/resources/emblems/tmp/applications-multimedia.png
%%DATADIR%%/resources/emblems/tmp/audio-volume-high.png
%%DATADIR%%/resources/emblems/tmp/emblem-new.png
%%DATADIR%%/resources/emblems/tmp/media-optical.png
%%DATADIR%%/resources/emblems/tmp/stock_3dsound.png
%%DATADIR%%/resources/emblems/tmp/stock_animation.png
%%DATADIR%%/resources/emblems/tmp/stock_color.png
%%DATADIR%%/resources/emblems/tmp/stock_draw-circle.png
%%DATADIR%%/resources/emblems/tmp/stock_draw-rounded-square.png
%%DATADIR%%/resources/emblems/tmp/stock_effects-sound.png
%%DATADIR%%/resources/emblems/tmp/stock_form-image-button.png
%%DATADIR%%/resources/emblems/tmp/stock_headphones.png
%%DATADIR%%/resources/emblems/tmp/stock_insert-sound-plugin.png
%%DATADIR%%/resources/emblems/tmp/stock_insert-video-plugin.png
%%DATADIR%%/resources/emblems/tmp/stock_navigator.png
%%DATADIR%%/resources/emblems/tmp/stock_shadow.png
%%DATADIR%%/resources/emblems/tmp/stock_signature.png
%%DATADIR%%/resources/emblems/tmp/stock_tools-macro.png
%%DATADIR%%/resources/emblems/tmp/stock_video-conferencing.png
%%DATADIR%%/resources/emblems/tmp/stock_wallpaper-fill.png
%%DATADIR%%/resources/emblems/tmp/weather-clear-night.png
%%DATADIR%%/resources/emblems/tmp/weather-clear.png
%%DATADIR%%/resources/emblems/video-x-generic.png
%%DATADIR%%/resources/frames/cell/frame.png
%%DATADIR%%/resources/frames/cell/vframe.png
%%DATADIR%%/resources/frames/gradient/frame.png
%%DATADIR%%/resources/frames/gradient/vframe.png
%%DATADIR%%/resources/frames/make_menu.sh
%%DATADIR%%/resources/frames/ogradient/frame.png
%%DATADIR%%/resources/frames/ogradient/vframe.png
%%DATADIR%%/resources/frames/oval/frame.png
%%DATADIR%%/resources/frames/oval/vframe.png
%%DATADIR%%/resources/frames/rect/frame.png
%%DATADIR%%/resources/frames/rect/vframe.png
%%DATADIR%%/resources/frames/roundrect/frame.png
%%DATADIR%%/resources/frames/roundrect/vframe.png
%%DATADIR%%/resources/frames/samples/background.png
%%DATADIR%%/resources/frames/stonerect/frame.png
%%DATADIR%%/resources/frames/stonerect/vframe.png
%%DATADIR%%/resources/gtkrc
%%DATADIR%%/resources/icons/bombono-dvd_128px.png
%%DATADIR%%/resources/icons/bombono-dvd_16px.png
%%DATADIR%%/resources/icons/bombono-dvd_32px.png
%%DATADIR%%/resources/icons/bombono-dvd_48px.png
%%DATADIR%%/resources/icons/bombono-dvd_64px.png
%%DATADIR%%/resources/scons_authoring/ADVD.py
%%DATADIR%%/resources/scons_authoring/README
%%DATADIR%%/resources/scons_authoring/SConsTwin.py
%%DATADIR%%/resources/scons_authoring/SConstruct
%%DATADIR%%/resources/scons_authoring/menu_SConscript
%%DATADIR%%/resources/tool-pointer.png
%%DATADIR%%/resources/tool-text.png
share/pixmaps/bombono-dvd.png
@dirrmtry share/applications
@dirrm %%DATADIR%%/resources/scons_authoring
@dirrm %%DATADIR%%/resources/icons
@dirrm %%DATADIR%%/resources/frames/stonerect
@dirrm %%DATADIR%%/resources/frames/samples
@dirrm %%DATADIR%%/resources/frames/roundrect
@dirrm %%DATADIR%%/resources/frames/rect
@dirrm %%DATADIR%%/resources/frames/oval
@dirrm %%DATADIR%%/resources/frames/ogradient
@dirrm %%DATADIR%%/resources/frames/gradient
@dirrm %%DATADIR%%/resources/frames/cell
@dirrm %%DATADIR%%/resources/frames
@dirrm %%DATADIR%%/resources/emblems/tmp
@dirrm %%DATADIR%%/resources/emblems
@dirrm %%DATADIR%%/resources/copy-n-paste/HelixPlayer_Activity-watch-listen
@dirrm %%DATADIR%%/resources/copy-n-paste
@dirrm %%DATADIR%%/resources/button
@dirrm %%DATADIR%%/resources
@dirrm %%DATADIR%%