Add libxklavier 0.2, an utility library to make XKB stuff easier.
This commit is contained in:
parent
4f164ea731
commit
5bb1ce5458
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=60362
8 changed files with 116 additions and 0 deletions
|
@ -69,6 +69,7 @@
|
|||
SUBDIR += libgnome
|
||||
SUBDIR += libhelp
|
||||
SUBDIR += libsx
|
||||
SUBDIR += libxklavier
|
||||
SUBDIR += linux-gnomelibs
|
||||
SUBDIR += linux-xalf
|
||||
SUBDIR += login.app
|
||||
|
|
27
x11/libxklavier/Makefile
Normal file
27
x11/libxklavier/Makefile
Normal file
|
@ -0,0 +1,27 @@
|
|||
# New ports collection makefile for: libxklavier
|
||||
# Date created: 31 May 2002
|
||||
# Whom: Maxim Sobolev <sobomax@FreeBSD.org>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= libxklavier
|
||||
PORTVERSION= 0.2
|
||||
CATEGORIES= x11
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
|
||||
MASTER_SITE_SUBDIR= gswitchit
|
||||
|
||||
MAINTAINER= sobomax@FreeBSD.org
|
||||
|
||||
LIB_DEPENDS= xml2.5:${PORTSDIR}/textproc/libxml2
|
||||
|
||||
USE_X_PREFIX= yes
|
||||
USE_GMAKE= yes
|
||||
INSTALLS_SHLIB= yes
|
||||
USE_LIBTOOL= yes
|
||||
CONFIGURE_ARGS= --with-xkb-base=${X11BASE}/lib/X11/xkb
|
||||
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
|
||||
LIBS="-L${LOCALBASE}/lib"
|
||||
CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
|
||||
|
||||
.include <bsd.port.mk>
|
1
x11/libxklavier/distinfo
Normal file
1
x11/libxklavier/distinfo
Normal file
|
@ -0,0 +1 @@
|
|||
MD5 (libxklavier-0.2.tar.gz) = fb1167a02fd7a2eb4722e288a45d4e7e
|
31
x11/libxklavier/files/patch-configure
Normal file
31
x11/libxklavier/files/patch-configure
Normal file
|
@ -0,0 +1,31 @@
|
|||
|
||||
$FreeBSD$
|
||||
|
||||
--- configure.orig Wed May 29 22:09:41 2002
|
||||
+++ configure Fri May 31 13:28:42 2002
|
||||
@@ -5464,6 +5464,7 @@
|
||||
|
||||
# This can be used to rebuild libtool when needed
|
||||
LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
|
||||
+$ac_aux_dir/ltconfig $LIBTOOL_DEPS
|
||||
|
||||
# Always use our own libtool.
|
||||
LIBTOOL='$(SHELL) $(top_builddir)/libtool'
|
||||
@@ -5577,7 +5578,7 @@
|
||||
|
||||
#include <stdlib.h>
|
||||
#include <stdio.h>
|
||||
-#include <xmlversion.h>
|
||||
+#include <libxml/xmlversion.h>
|
||||
|
||||
int
|
||||
main()
|
||||
@@ -5688,7 +5689,7 @@
|
||||
#line 5689 "configure"
|
||||
#include "confdefs.h"
|
||||
|
||||
-#include <xmlversion.h>
|
||||
+#include <libxml/xmlversion.h>
|
||||
#include <stdio.h>
|
||||
|
||||
int main() {
|
14
x11/libxklavier/files/patch-doc::html::Makefile.in
Normal file
14
x11/libxklavier/files/patch-doc::html::Makefile.in
Normal file
|
@ -0,0 +1,14 @@
|
|||
|
||||
$FreeBSD$
|
||||
|
||||
--- doc/html/Makefile.in 2002/05/31 10:38:48 1.1
|
||||
+++ doc/html/Makefile.in 2002/05/31 10:39:18
|
||||
@@ -122,7 +122,7 @@
|
||||
|
||||
EXTRA_DIST = $(EXTRA_WEB_FILES) $(HTML_FILES)
|
||||
|
||||
-docdir = $(datadir)/doc/$(PACKAGE)-$(VERSION)/html
|
||||
+docdir = $(datadir)/doc/$(PACKAGE)/html
|
||||
|
||||
doc_DATA = $(EXTRA_DIST)
|
||||
mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
|
1
x11/libxklavier/pkg-comment
Normal file
1
x11/libxklavier/pkg-comment
Normal file
|
@ -0,0 +1 @@
|
|||
An utility library to make XKB stuff easier
|
1
x11/libxklavier/pkg-descr
Normal file
1
x11/libxklavier/pkg-descr
Normal file
|
@ -0,0 +1 @@
|
|||
libxklavier - utility library to make XKB stuff easier.
|
40
x11/libxklavier/pkg-plist
Normal file
40
x11/libxklavier/pkg-plist
Normal file
|
@ -0,0 +1,40 @@
|
|||
include/libxklavier/xklavier.h
|
||||
include/libxklavier/xklavier_config.h
|
||||
lib/libxklavier.a
|
||||
lib/libxklavier.so
|
||||
lib/libxklavier.so.0
|
||||
share/doc/libxklavier/html/annotated.html
|
||||
share/doc/libxklavier/html/doxygen.css
|
||||
share/doc/libxklavier/html/doxygen.gif
|
||||
share/doc/libxklavier/html/files.html
|
||||
share/doc/libxklavier/html/functions.html
|
||||
share/doc/libxklavier/html/globals.html
|
||||
share/doc/libxklavier/html/group__Lookup.html
|
||||
share/doc/libxklavier/html/group__activation.html
|
||||
share/doc/libxklavier/html/group__callbacks.html
|
||||
share/doc/libxklavier/html/group__currents.html
|
||||
share/doc/libxklavier/html/group__debug.html
|
||||
share/doc/libxklavier/html/group__debugerr.html
|
||||
share/doc/libxklavier/html/group__enum.html
|
||||
share/doc/libxklavier/html/group__initterm.html
|
||||
share/doc/libxklavier/html/group__lookup.html
|
||||
share/doc/libxklavier/html/group__settings.html
|
||||
share/doc/libxklavier/html/group__wininfo.html
|
||||
share/doc/libxklavier/html/group__winstate.html
|
||||
share/doc/libxklavier/html/group__xkbevents.html
|
||||
share/doc/libxklavier/html/group__xkbgroup.html
|
||||
share/doc/libxklavier/html/group__xkbinfo.html
|
||||
share/doc/libxklavier/html/index.html
|
||||
share/doc/libxklavier/html/modules.html
|
||||
share/doc/libxklavier/html/structXklState-members.html
|
||||
share/doc/libxklavier/html/structXklState.html
|
||||
share/doc/libxklavier/html/struct__XklConfigItem-members.html
|
||||
share/doc/libxklavier/html/struct__XklConfigItem.html
|
||||
share/doc/libxklavier/html/xklavier_8h-source.html
|
||||
share/doc/libxklavier/html/xklavier_8h.html
|
||||
share/doc/libxklavier/html/xklavier__config_8h-source.html
|
||||
share/doc/libxklavier/html/xklavier__config_8h.html
|
||||
share/doc/libxklavier/html/xklavier__private_8h-source.html
|
||||
@dirrm share/doc/libxklavier/html
|
||||
@dirrm share/doc/libxklavier
|
||||
@dirrm include/libxklavier
|
Loading…
Reference in a new issue