- Clarify LICENSE
- Don't install unneeded docfile - Silence stripping - Switch to options helpers - Regenerate patches with `make makepatch`
This commit is contained in:
parent
d62d4c0873
commit
5bb40b5b56
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=410890
3 changed files with 12 additions and 9 deletions
|
@ -10,17 +10,20 @@ MASTER_SITES= http://asic-linux.com.mx/~izto/checkinstall/files/source/
|
|||
MAINTAINER= ports@FreeBSD.org
|
||||
COMMENT= File creation/modification logger
|
||||
|
||||
LICENSE= GPLv2
|
||||
LICENSE= GPLv2+
|
||||
LICENSE_FILE= ${WRKSRC}/COPYING
|
||||
|
||||
USE_LDCONFIG= yes
|
||||
|
||||
PLIST_FILES= bin/installwatch lib/installwatch.so
|
||||
PORTDOCS= BUGS CHANGELOG INSTALL README TODO
|
||||
PORTDOCS= BUGS CHANGELOG README TODO
|
||||
|
||||
OPTIONS_DEFINE= DOCS
|
||||
|
||||
post-install:
|
||||
${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/installwatch.so
|
||||
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/installwatch.so
|
||||
|
||||
post-install-DOCS-on:
|
||||
@${MKDIR} ${STAGEDIR}${DOCSDIR}
|
||||
cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${STAGEDIR}${DOCSDIR}
|
||||
|
||||
|
|
|
@ -1,5 +1,5 @@
|
|||
--- ./Makefile.orig 2001-12-22 21:55:11.000000000 -0200
|
||||
+++ ./Makefile 2014-02-22 22:45:43.000000000 -0300
|
||||
--- Makefile.orig 2001-12-22 23:55:11 UTC
|
||||
+++ Makefile
|
||||
@@ -4,7 +4,6 @@
|
||||
# Well, the only configurable part is the following variable.
|
||||
# Make sure the directory you specify exists.
|
||||
|
@ -8,7 +8,7 @@
|
|||
|
||||
# End of configurable part
|
||||
|
||||
@@ -16,19 +15,19 @@
|
||||
@@ -16,19 +15,19 @@ LIBDIR=$(PREFIX)/lib
|
||||
all: installwatch.so
|
||||
|
||||
installwatch.so: installwatch.o
|
||||
|
@ -33,7 +33,7 @@
|
|||
|
||||
uninstall:
|
||||
rm $(LIBDIR)/installwatch.so
|
||||
@@ -41,7 +40,7 @@
|
||||
@@ -41,7 +40,7 @@ tarball: clean
|
||||
tar -czvC .. -f ../installwatch-$(VERSION).tar.gz installwatch-$(VERSION)
|
||||
|
||||
test: install
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- installwatch.c.orig
|
||||
--- installwatch.c.orig 2001-12-22 23:55:11 UTC
|
||||
+++ installwatch.c
|
||||
@@ -574,7 +574,7 @@
|
||||
@@ -574,7 +574,7 @@ int open(const char *pathname, int flags
|
||||
|
||||
REFCOUNT;
|
||||
va_start(ap, flags);
|
||||
|
|
Loading…
Reference in a new issue