Netboot produces bootloaders for many NICs, similar to etherboot.
PR: 51075 Submitted by: David Yeske <dyeske@yahoo.com>
This commit is contained in:
parent
7c68e37ee3
commit
5bde7c2f1d
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=79158
6 changed files with 129 additions and 0 deletions
|
@ -335,6 +335,7 @@
|
|||
SUBDIR += net-snmp4
|
||||
SUBDIR += netams
|
||||
SUBDIR += netatalk
|
||||
SUBDIR += netboot
|
||||
SUBDIR += netcat
|
||||
SUBDIR += netdude
|
||||
SUBDIR += netmap
|
||||
|
|
22
net/netboot/Makefile
Normal file
22
net/netboot/Makefile
Normal file
|
@ -0,0 +1,22 @@
|
|||
# New ports collection makefile for: netboot
|
||||
# Date created: 16 Apr 2003
|
||||
# Whom: dyeske@yahoo.com
|
||||
#
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= netboot
|
||||
PORTVERSION= 0.9.8
|
||||
CATEGORIES= net
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
|
||||
MASTER_SITE_SUBDIR= ${PORTNAME}
|
||||
|
||||
MAINTAINER= dyeske@yahoo.com
|
||||
COMMENT= Netboot with Packet or NDIS-2 drivers
|
||||
|
||||
USE_GMAKE= yes
|
||||
GNU_CONFIGURE= yes
|
||||
|
||||
MAN5= netboot.5 netboot.config.5 netboot.drivers.5 netboot.db.5
|
||||
MAN8= mknbi-mgl.8 makerom.8 mknbi-dos.8 mknbi-linux.8
|
||||
|
||||
.include <bsd.port.mk>
|
1
net/netboot/distinfo
Normal file
1
net/netboot/distinfo
Normal file
|
@ -0,0 +1 @@
|
|||
MD5 (netboot-0.9.8.tar.gz) = 2c4c83c3d7743b73247e2acdda79919d
|
41
net/netboot/files/patch-misc::instdrv
Normal file
41
net/netboot/files/patch-misc::instdrv
Normal file
|
@ -0,0 +1,41 @@
|
|||
--- misc/instdrv.orig Sun Dec 15 05:50:10 2002
|
||||
+++ misc/instdrv Mon Mar 17 01:12:06 2003
|
||||
@@ -48,13 +48,8 @@
|
||||
# Get name of driver subdirectory, name of driver file and check for MD5
|
||||
# checksum file
|
||||
#
|
||||
-MD5FILE="`echo "$DRVFILE" | sed 's,\.[^/]\+$,\.md5,'`"
|
||||
-SUBDIR="`echo "$ABSDRVFILE" | sed 's,^.*netdrvr/\([^/]\+\)/.*$,\1,'`"
|
||||
+SUBDIR="`echo "$ABSDRVFILE" | sed 's,^.*netdrvr/\([^/].*\)/.*$,\1,'`"
|
||||
DRVNAME="`echo "$ABSDRVFILE" | sed 's,^.*/\([^/]\+\.[^/]\+\)$,\1,'`"
|
||||
-if [ ! -r "$MD5FILE" ]; then
|
||||
- echo "$0: unable to read MD5 file $MD5FILE"
|
||||
- exit 1
|
||||
-fi
|
||||
|
||||
|
||||
#
|
||||
@@ -68,12 +63,6 @@
|
||||
echo $INSTPROG -d $INSTDIR/netdrvr
|
||||
$INSTPROG -d $INSTDIR/netdrvr
|
||||
fi
|
||||
-SUMFILE="$INSTDIR/netdrvr/MD5SUMS"
|
||||
-if [ ! -f $SUMFILE ]; then
|
||||
- echo "# MD5 checksum file" > $SUMFILE
|
||||
-fi
|
||||
-TMPFILE="${TEMP-/tmp}/MD5SUMS.$$"
|
||||
-trap "rm -f $TMPFILE" 0
|
||||
|
||||
|
||||
#
|
||||
@@ -91,10 +80,5 @@
|
||||
# Install MD5 checksum into checksum database. This involves to first
|
||||
# remove the old entry from the file, and then to append the new entry
|
||||
#
|
||||
-echo "Installing MD5 checksum into $SUMFILE"
|
||||
-MD5="`cat $MD5FILE | sed 's,^\(.\+[ ]\+[ *]\)[^ *].*$,\1,'`"
|
||||
-sed "/^.*$DRVNAME\$/d;\$a\\
|
||||
-$MD5$SUBDIR/$DRVNAME" $SUMFILE >$TMPFILE
|
||||
-$INSTPROG -m 644 $TMPFILE $SUMFILE
|
||||
exit 0
|
||||
|
13
net/netboot/pkg-descr
Normal file
13
net/netboot/pkg-descr
Normal file
|
@ -0,0 +1,13 @@
|
|||
This code produces bootloaders for many cards that can be loaded
|
||||
from a floppy disk or burnt into an EEPROM as raw or hex
|
||||
|
||||
Netboot uses standard DOS drivers (either Packet or NDIS-2), all
|
||||
network cards can be used for which those drivers exist, even PCI
|
||||
and 100MBps cards. In case no such driver has been delivered with
|
||||
a network card it can usually be downloaded from an FTP server of
|
||||
the manufacturer
|
||||
|
||||
WWW: http://netboot.sourceforge.net/
|
||||
|
||||
- David
|
||||
dyeske@yahoo.com
|
51
net/netboot/pkg-plist
Normal file
51
net/netboot/pkg-plist
Normal file
|
@ -0,0 +1,51 @@
|
|||
bin/makerom
|
||||
bin/mknbi-dos
|
||||
bin/mknbi-linux
|
||||
bin/mknbi-mgl
|
||||
lib/netboot/netboot.drivers
|
||||
lib/netboot/binaries/floppy.bin
|
||||
lib/netboot/binaries/floppy86.bin
|
||||
lib/netboot/binaries/kernel.bin
|
||||
lib/netboot/binaries/kernel86.bin
|
||||
lib/netboot/binaries/kernelm.bin
|
||||
lib/netboot/binaries/netndis.bin
|
||||
lib/netboot/binaries/netndis86.bin
|
||||
lib/netboot/binaries/netpkt.bin
|
||||
lib/netboot/binaries/netpkt86.bin
|
||||
lib/netboot/binaries/netundi.bin
|
||||
lib/netboot/binaries/netundi86.bin
|
||||
lib/netboot/binaries/rom.bin
|
||||
lib/netboot/binaries/rom86.bin
|
||||
lib/netboot/netdrvr/pktdrvr/drivers/3c501.com
|
||||
lib/netboot/netdrvr/pktdrvr/drivers/3c503.com
|
||||
lib/netboot/netdrvr/pktdrvr/drivers/3c505.com
|
||||
lib/netboot/netdrvr/pktdrvr/drivers/3c507.com
|
||||
lib/netboot/netdrvr/pktdrvr/drivers/3c509.com
|
||||
lib/netboot/netdrvr/pktdrvr/drivers/3c523.com
|
||||
lib/netboot/netdrvr/pktdrvr/drivers/dc21x4.com
|
||||
lib/netboot/netdrvr/pktdrvr/drivers/de600.com
|
||||
lib/netboot/netdrvr/pktdrvr/drivers/depca.com
|
||||
lib/netboot/netdrvr/pktdrvr/drivers/ee10pkt.com
|
||||
lib/netboot/netdrvr/pktdrvr/drivers/e10ppkt.com
|
||||
lib/netboot/netdrvr/pktdrvr/drivers/e100bpkt.com
|
||||
lib/netboot/netdrvr/pktdrvr/drivers/epropkt.com
|
||||
lib/netboot/netdrvr/pktdrvr/drivers/exos205.com
|
||||
lib/netboot/netdrvr/pktdrvr/drivers/exp16.com
|
||||
lib/netboot/netdrvr/pktdrvr/drivers/hppclan.com
|
||||
lib/netboot/netdrvr/pktdrvr/drivers/hppclanp.com
|
||||
lib/netboot/netdrvr/pktdrvr/drivers/lan595.com
|
||||
lib/netboot/netdrvr/pktdrvr/drivers/ne1000.com
|
||||
lib/netboot/netdrvr/pktdrvr/drivers/ne2.com
|
||||
lib/netboot/netdrvr/pktdrvr/drivers/ne2000.com
|
||||
lib/netboot/netdrvr/pktdrvr/drivers/ne2100.com
|
||||
lib/netboot/netdrvr/pktdrvr/drivers/smc_wd.com
|
||||
lib/netboot/utils/pktwatch.com
|
||||
lib/netboot/utils/romcheck.bin
|
||||
@dirrm lib/netboot/binaries
|
||||
@dirrm lib/netboot/netdrvr/ndis2
|
||||
@dirrm lib/netboot/netdrvr/pktdrvr/drivers
|
||||
@dirrm lib/netboot/netdrvr/pktdrvr
|
||||
@dirrm lib/netboot/netdrvr/undi
|
||||
@dirrm lib/netboot/netdrvr
|
||||
@dirrm lib/netboot/utils
|
||||
@dirrm lib/netboot
|
Loading…
Reference in a new issue