- Update to 1.4.0

- Remove UNIQUE option
- Adjust dependencies (reported by QA script)
This commit is contained in:
Olivier Duchateau 2016-09-15 15:13:15 +00:00
parent 70d698c2c5
commit 5bebf6d215
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=422204
4 changed files with 24 additions and 12 deletions

View file

@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= xfce4-clipman-plugin
PORTVERSION= 1.2.6
PORTREVISION= 2
PORTVERSION= 1.4.0
CATEGORIES= x11 xfce
MASTER_SITES= XFCE/src/panel-plugins/${PORTNAME}/${PORTVERSION:R}
DIST_SUBDIR= xfce4
@ -13,20 +12,19 @@ COMMENT= Clipboard manager for the Xfce panel
LICENSE= GPLv2
OPTIONS_DEFINE= QRCODE UNIQUE
OPTIONS_DEFAULT= UNIQUE
LIB_DEPENDS= libdbus-1.so:devel/dbus \
libdbus-glib-1.so:devel/dbus-glib
OPTIONS_DEFINE= QRCODE
QRCODE_DESC= QR Code support
UNIQUE_DESC= Unique (single instance) support
QRCODE_LIB_DEPENDS= libqrencode.so:graphics/libqrencode
QRCODE_CONFIGURE_ENABLE= libqrencode
UNIQUE_LIB_DEPENDS= libunique-1.0.so:x11-toolkits/unique
UNIQUE_CONFIGURE_ENABLE= unique
GNU_CONFIGURE= yes
USE_GNOME= gtk20 intltool intlhack glib20
USE_GNOME= gtk30 intltool intlhack glib20 cairo
USE_XFCE= panel
USE_XORG= xtst xproto
USES= gettext gmake libtool pkgconfig xfce tar:bzip2
USE_XORG= ice sm x11 xtst xproto
USES= gettext gmake libtool pkgconfig tar:bzip2 xfce:gtk3
INSTALLS_ICONS= yes
.include <bsd.port.mk>

View file

@ -1,2 +1,3 @@
SHA256 (xfce4/xfce4-clipman-plugin-1.2.6.tar.bz2) = 23043f99c3e5257d1f3d68b5ee5125e3469c15620d098e22c6250386197f48a5
SIZE (xfce4/xfce4-clipman-plugin-1.2.6.tar.bz2) = 438346
TIMESTAMP = 1473932421
SHA256 (xfce4/xfce4-clipman-plugin-1.4.0.tar.bz2) = a97671540663df1d90503f73695ac36e16fa2c832be8845ad9402529b8148294
SIZE (xfce4/xfce4-clipman-plugin-1.4.0.tar.bz2) = 471045

View file

@ -0,0 +1,12 @@
--- panel-plugin/Makefile.in.orig 2016-09-15 08:18:26 UTC
+++ panel-plugin/Makefile.in
@@ -1326,7 +1326,8 @@ uninstall-am: uninstall-actionsDATA unin
@INTLTOOL_DESKTOP_RULE@
install-exec-hook:
- $(LN_S) -f $(exec_prefix)/bin/xfce4-popup-clipman $(DESTDIR)$(exec_prefix)/bin/xfce4-popup-clipman-actions
+ cd $(DESTDIR)$(exec_prefix)/bin && \
+ $(LN_S) xfce4-popup-clipman xfce4-popup-clipman-actions
# Tell versions [3.59,3.63) of GNU make to not export all variables.
# Otherwise a system limit (for SysV at least) may be exceeded.

View file

@ -1,6 +1,7 @@
bin/xfce4-clipman
bin/xfce4-clipman-settings
bin/xfce4-popup-clipman
bin/xfce4-popup-clipman-actions
etc/xdg/autostart/xfce4-clipman-plugin-autostart.desktop
etc/xdg/xfce4/panel/xfce4-clipman-actions.xml
lib/xfce4/panel/plugins/libclipman.so