- Update to bzr revision 102364.
- Restore GTK2 option. - Enable IMAGEMAGICK option by default. - Add GNUTLS option. - Fix the issue with bad plist generation and mention it in UPDATING. - Include 'alloca' fix provided by swell.k@gmail.com [1]. PR: ports/149049[1] Submitted by: swell.k@gmail.com[1] Approved by: tabthorpe (mentor)
This commit is contained in:
parent
138a45847e
commit
5c37bd26b0
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=264734
10 changed files with 102 additions and 61 deletions
15
UPDATING
15
UPDATING
|
@ -5,6 +5,21 @@ they are unavoidable.
|
|||
You should get into the habit of checking this file for changes each time
|
||||
you update your ports collection, before attempting any port upgrades.
|
||||
|
||||
20101118:
|
||||
AFFECTS: users of editors/emacs-devel
|
||||
AUTHOR: Ashish SHUKLA <ashish@FreeBSD.org>
|
||||
|
||||
Due to a bug when upgrading from 24.0.50.101606, everything
|
||||
installed by other ports in "${PREFIX}/share/emacs" gets removed.
|
||||
|
||||
Before upgrading:
|
||||
|
||||
* Please backup custom configurations in "${PREFIX}/share/emacs".
|
||||
* After upgrading reinstall any ports that may have had files in the
|
||||
"${PREFIX}/share/emacs" directory.
|
||||
|
||||
Apologies for this inconvenience.
|
||||
|
||||
20101117:
|
||||
AFFECTS: users of net-p2p/transmission-cli and net-p2p/transmission-gtk
|
||||
AUTHOR: Mezz <mezz@FreeBSD.org>
|
||||
|
|
|
@ -26,7 +26,7 @@ CONFLICTS= emacs-19.* emacs-21.* emacs-22.* emacs-23.* \
|
|||
INSTALLS_ICONS= yes
|
||||
|
||||
EMACS_VER= 24.0.50
|
||||
EMACS_REV= 101606
|
||||
EMACS_REV= 102364
|
||||
GNU_CONFIGURE= yes
|
||||
USE_GMAKE= yes
|
||||
USE_XZ= yes
|
||||
|
@ -36,16 +36,17 @@ CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
|
|||
CONFIGURE_ARGS= --localstatedir=/var
|
||||
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
|
||||
|
||||
EMACS_DIRS= ${DATADIR}/${EMACS_VER}/leim ${DATADIR}/${EMACS_VER}/lisp ${DATADIR}/${EMACS_VER}/src \
|
||||
${PREFIX}/libexec/${PORTNAME}
|
||||
|
||||
LICENSE= GPLv3
|
||||
LICENSE_FILE= ${WRKSRC}/COPYING
|
||||
|
||||
MAN1= b2m.1 ctags.1 ebrowse.1 emacs.1 emacsclient.1 etags.1 \
|
||||
MAN1= ctags.1 ebrowse.1 emacs.1 emacsclient.1 etags.1 \
|
||||
grep-changelog.1 rcs-checkin.1
|
||||
MANCOMPRESSED= yes
|
||||
PLIST_SUB= EMACS_VER=${EMACS_VER}
|
||||
|
||||
EMACS_DIRS= ${DATADIR}/${EMACS_VER} ${PREFIX}/libexec/${PORTNAME}
|
||||
|
||||
MAKE_ENV= LC_ALL=C
|
||||
|
||||
INFO= ada-mode auth autotype calc ccmode cl dbus dired-x \
|
||||
|
@ -59,6 +60,7 @@ LATEST_LINK= emacs-devel
|
|||
OPTIONS= DBUS "DBus support" ON \
|
||||
GCONF "GConf support" ON \
|
||||
GIF "GIF Images support" ON \
|
||||
GTK2 "Use GTK+ widgets" ON \
|
||||
JPEG "JPEG images support" ON \
|
||||
M17N "M17N support for text-shaping" ON \
|
||||
MOTIF "Use Motif widgets" OFF \
|
||||
|
@ -76,7 +78,8 @@ OPTIONS= DBUS "DBus support" ON \
|
|||
XIM "X Input Method support" ON \
|
||||
XML "XML Parser support" ON \
|
||||
XPM "XPM images support" ON \
|
||||
IMAGEMAGICK "ImageMagick support" OFF
|
||||
IMAGEMAGICK "ImageMagick support" ON \
|
||||
GNUTLS "GNUTLS support" ON
|
||||
|
||||
.include <bsd.port.options.mk>
|
||||
|
||||
|
@ -210,8 +213,9 @@ CONFIGURE_ARGS+= --without-dbus
|
|||
LIB_DEPENDS+= dbus-1.3:${PORTSDIR}/devel/dbus
|
||||
.endif
|
||||
|
||||
.if defined(WITH_IMAGEMAGICK)
|
||||
CONFIGURE_ARGS+= --with-imagemagick
|
||||
.if defined(WITHOUT_IMAGEMAGICK)
|
||||
CONFIGURE_ARGS+= --without-imagemagick
|
||||
.else
|
||||
LIB_DEPENDS+= MagickCore.4:${PORTSDIR}/graphics/ImageMagick
|
||||
.endif
|
||||
|
||||
|
@ -221,6 +225,12 @@ CONFIGURE_ARGS+= --without-xml2
|
|||
USE_GNOME+= libxml2
|
||||
.endif
|
||||
|
||||
.if defined(WITHOUT_GNUTLS)
|
||||
CONFIGURE_ARGS+= --without-gnutls
|
||||
.else
|
||||
LIB_DEPENDS+= gnutls.40:${PORTSDIR}/security/gnutls
|
||||
.endif
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if ${ARCH} == "ia64"
|
||||
|
@ -236,17 +246,24 @@ post-configure:
|
|||
|
||||
add-plist-data:
|
||||
.for i in ${EMACS_DIRS}
|
||||
@${FIND} ${i} -type f |${SED} -e 's,${PREFIX}/,,g' >>${TMPPLIST}
|
||||
@${FIND} ${i} -type f |${SED} -E -e 's,^${PREFIX}/,,g' >>${TMPPLIST}
|
||||
.endfor
|
||||
@${FIND} ${WRKSRC}/etc -type f |${SED} -E -e 's,^${WRKSRC},${DATADIR_REL}/${EMACS_VER},g' -e '/etc\/(\..*|ChangeLog|DOC)$$/d' >>${TMPPLIST}
|
||||
@${FIND} ${WRKSRC}/etc -type d -depth |${SED} -E -e 's,^${WRKSRC},@dirrm ${DATADIR_REL}/${EMACS_VER},g' >>${TMPPLIST}
|
||||
.for i in ${EMACS_DIRS}
|
||||
@${FIND} ${i} -type d -depth |${SED} -e 's,^${PREFIX}/,@dirrm ,g' >>${TMPPLIST}
|
||||
@${FIND} ${i} -type d -depth |${SED} -E -e 's,^${PREFIX}/,@dirrm ,g' >>${TMPPLIST}
|
||||
.endfor
|
||||
@${ECHO} "@unexec rmdir %D/${DATADIR_REL}/${EMACS_VER} 2>/dev/null || true" >>${TMPPLIST}
|
||||
|
||||
.if defined(WITH_SOURCES)
|
||||
PLIST_SUB+= SOURCES=""
|
||||
|
||||
post-install:
|
||||
@${MKDIR} ${DATADIR}/${EMACS_VER}/src
|
||||
@${INSTALL_DATA} ${WRKSRC}/src/*.[ch] ${DATADIR}/${EMACS_VER}/src
|
||||
@${INSTALL_DATA} ${WRKSRC}/sources.el ${DATADIR}/${EMACS_VER}/site-lisp/site-start.el
|
||||
.else
|
||||
PLIST_SUB+= SOURCES="@comment "
|
||||
.endif
|
||||
|
||||
.if !defined(WITHOUT_X11)
|
||||
|
|
|
@ -1,3 +1,2 @@
|
|||
MD5 (emacs-24.0.50.101606.tar.xz) = f84afaf4824c7d3226eb2030fd08015c
|
||||
SHA256 (emacs-24.0.50.101606.tar.xz) = 3f8a6550f3cea73b3f45af0f9a64b4e4d0067ce30cc5e63caf2a883e81f119da
|
||||
SIZE (emacs-24.0.50.101606.tar.xz) = 22709448
|
||||
SHA256 (emacs-24.0.50.102364.tar.xz) = 7eb2e31c8aabbd130b8e8df03ef1892455cc7a97be6601f62322104e8bec546c
|
||||
SIZE (emacs-24.0.50.102364.tar.xz) = 22792292
|
||||
|
|
|
@ -3,7 +3,7 @@ $FreeBSD$
|
|||
|
||||
--- configure.orig
|
||||
+++ configure
|
||||
@@ -6041,170 +6041,6 @@
|
||||
@@ -6055,170 +6055,6 @@
|
||||
LIBSOUND=
|
||||
fi
|
||||
|
||||
|
|
|
@ -1,20 +1,14 @@
|
|||
--- doc/emacs/Makefile.in.orig 2008-12-09 19:27:59.000000000 +0200
|
||||
+++ doc/emacs/Makefile.in 2008-12-09 19:25:19.000000000 +0200
|
||||
@@ -34,7 +34,7 @@
|
||||
|
||||
$FreeBSD$
|
||||
|
||||
--- doc/emacs/Makefile.in.orig
|
||||
+++ doc/emacs/Makefile.in
|
||||
@@ -39,7 +39,7 @@
|
||||
|
||||
# The makeinfo program is part of the Texinfo distribution.
|
||||
# Use --force so that it generates output even if there are errors.
|
||||
-MAKEINFO = makeinfo --force
|
||||
+MAKEINFO = makeinfo --force --no-split
|
||||
-MAKEINFO = makeinfo --force -I $(srcdir)
|
||||
+MAKEINFO = makeinfo --force --no-split -I $(srcdir)
|
||||
|
||||
INFO_TARGETS = $(infodir)/emacs
|
||||
DVI_TARGETS = emacs.dvi
|
||||
@@ -144,7 +144,7 @@
|
||||
# rm -f Makefile
|
||||
|
||||
maintainer-clean: distclean
|
||||
- for file in $(INFO_TARGETS); do rm -f $${file}*; done
|
||||
+ for file in $(INFO_TARGETS); do rm -f $${file}; done
|
||||
|
||||
|
||||
# Formerly this directory had texindex.c and getopt.c in it
|
||||
TEXI2DVI = texi2dvi
|
||||
TEXI2PDF = texi2pdf
|
||||
|
|
|
@ -1,20 +1,14 @@
|
|||
--- doc/lispintro/Makefile.in.orig 2008-12-09 19:27:59.000000000 +0200
|
||||
+++ doc/lispintro/Makefile.in 2008-12-09 19:25:20.000000000 +0200
|
||||
@@ -33,7 +33,7 @@
|
||||
INFO_TARGETS = ${infodir}/eintr
|
||||
DVI_TARGETS = emacs-lisp-intro.dvi
|
||||
|
||||
$FreeBSD$
|
||||
|
||||
--- doc/lispintro/Makefile.in.orig
|
||||
+++ doc/lispintro/Makefile.in
|
||||
@@ -28,7 +28,7 @@
|
||||
# Directory with the (customized) texinfo.tex file.
|
||||
texinfodir = $(srcdir)/../misc
|
||||
|
||||
-MAKEINFO = makeinfo
|
||||
+MAKEINFO = makeinfo --no-split
|
||||
-MAKEINFO = makeinfo --force -I $(srcdir)
|
||||
+MAKEINFO = makeinfo --no-split --force -I $(srcdir)
|
||||
TEXI2DVI = texi2dvi
|
||||
TEXI2PDF = texi2pdf
|
||||
DVIPS = dvips
|
||||
|
||||
@@ -65,7 +65,7 @@
|
||||
|
||||
maintainer-clean: distclean
|
||||
rm -f *.aux *.cps *.fns *.kys *.pgs *.vrs *.toc
|
||||
- cd $(infodir); rm -f eintr eintr-[1-9]
|
||||
+ cd $(infodir); rm -f eintr
|
||||
|
||||
# Tell versions [3.59,3.63) of GNU make to not export all variables.
|
||||
# Otherwise a system limit (for SysV at least) may be exceeded.
|
||||
|
|
|
@ -1,11 +1,14 @@
|
|||
--- doc/lispref/Makefile.in.orig 2008-12-09 19:27:59.000000000 +0200
|
||||
+++ doc/lispref/Makefile.in 2008-12-09 19:25:20.000000000 +0200
|
||||
|
||||
$FreeBSD$
|
||||
|
||||
--- doc/lispref/Makefile.in.orig
|
||||
+++ doc/lispref/Makefile.in
|
||||
@@ -32,7 +32,7 @@
|
||||
# Directory with emacsver.texi.
|
||||
emacsdir = $(srcdir)/../emacs
|
||||
|
||||
-MAKEINFO = makeinfo --force -I $(emacsdir) -I $(srcdir)
|
||||
+MAKEINFO = makeinfo --no-split --force -I $(emacsdir) -I $(srcdir)
|
||||
TEXI2DVI = texi2dvi
|
||||
SHELL = /bin/sh
|
||||
INSTALL_INFO = install-info
|
||||
-MAKEINFO = makeinfo --force
|
||||
+MAKEINFO = makeinfo --force --no-split
|
||||
|
||||
# List of all the texinfo files in the manual:
|
||||
|
||||
TEXI2PDF = texi2pdf
|
||||
DVIPS = dvips
|
||||
|
|
|
@ -1,11 +1,14 @@
|
|||
--- doc/misc/Makefile.in.orig Tue Jun 23 07:39:39 2009 +0300
|
||||
+++ doc/misc/Makefile.in Tue Jun 23 07:39:41 2009 +0300
|
||||
@@ -34,7 +34,7 @@
|
||||
|
||||
$FreeBSD$
|
||||
|
||||
--- doc/misc/Makefile.in.orig
|
||||
+++ doc/misc/Makefile.in
|
||||
@@ -42,7 +42,7 @@
|
||||
|
||||
# The makeinfo program is part of the Texinfo distribution.
|
||||
# Use --force so that it generates output even if there are errors.
|
||||
-MAKEINFO = makeinfo --force
|
||||
+MAKEINFO = makeinfo --force --no-split
|
||||
-MAKEINFO = makeinfo --force -I$(emacsdir)
|
||||
+MAKEINFO = makeinfo --force --no-split -I$(emacsdir)
|
||||
|
||||
# Also add new entries to INFO_FILES in the top-level Makefile.in.
|
||||
INFO_TARGETS = \
|
||||
|
|
14
editors/emacs-devel/files/patch-src_config.in
Normal file
14
editors/emacs-devel/files/patch-src_config.in
Normal file
|
@ -0,0 +1,14 @@
|
|||
|
||||
$FreeBSD$
|
||||
|
||||
--- src/config.in.orig
|
||||
+++ src/config.in
|
||||
@@ -1171,6 +1171,8 @@
|
||||
|
||||
#ifdef HAVE_ALLOCA_H
|
||||
# include <alloca.h>
|
||||
+#elif __FreeBSD__
|
||||
+#include <stdlib.h>
|
||||
#elif defined __GNUC__
|
||||
# define alloca __builtin_alloca
|
||||
#elif defined _AIX
|
|
@ -1,4 +1,3 @@
|
|||
bin/b2m
|
||||
bin/ctags
|
||||
bin/ebrowse
|
||||
bin/emacs
|
||||
|
@ -8,6 +7,8 @@ bin/etags
|
|||
bin/grep-changelog
|
||||
bin/rcs-checkin
|
||||
share/applications/emacs.desktop
|
||||
%%SOURCES%%%%DATADIR%%/%%EMACS_VER%%/site-lisp/site-start.el
|
||||
%%DATADIR%%/%%EMACS_VER%%/site-lisp/subdirs.el
|
||||
%%DATADIR%%/site-lisp/subdirs.el
|
||||
share/icons/hicolor/128x128/apps/emacs.png
|
||||
share/icons/hicolor/16x16/apps/emacs.png
|
||||
|
@ -20,6 +21,7 @@ share/icons/hicolor/48x48/apps/emacs.png
|
|||
share/icons/hicolor/48x48/apps/emacs22.png
|
||||
share/icons/hicolor/scalable/apps/emacs.svg
|
||||
share/icons/hicolor/scalable/mimetypes/emacs-document.svg
|
||||
@dirrmtry %%DATADIR%%/%%EMACS_VER%%/site-lisp
|
||||
@dirrmtry share/icons/hicolor/scalable/mimetypes
|
||||
@dirrmtry share/icons/hicolor/scalable/apps
|
||||
@dirrmtry share/icons/hicolor/scalable
|
||||
|
|
Loading…
Reference in a new issue