Update to version 1.7.1: update battery file more often; many bugfixes.
See ChangeLog for complete details. PR: ports/62645 Submitted by: arundel@gmx.net (maintainer)
This commit is contained in:
parent
0bd0f73829
commit
5c3d5d1f4e
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=101172
6 changed files with 56 additions and 40 deletions
|
@ -5,8 +5,7 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME= vba
|
||||
PORTVERSION= 1.7
|
||||
PORTREVISION= 1
|
||||
PORTVERSION= 1.7.1
|
||||
CATEGORIES= emulators
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
|
||||
MASTER_SITE_SUBDIR= ${PORTNAME}
|
||||
|
@ -21,7 +20,6 @@ LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png
|
|||
USE_X_PREFIX= yes
|
||||
USE_GMAKE= yes
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ARGS= --without-profiling
|
||||
USE_SDL= yes
|
||||
WRKSRC= ${WRKDIR}/VisualBoyAdvance-${PORTVERSION}
|
||||
|
||||
|
@ -36,8 +34,8 @@ CLAGS+=
|
|||
.endif
|
||||
|
||||
DATA_FILES= ${WRKSRC}/src/VisualBoyAdvance.cfg
|
||||
PROG_FILES= ${WRKSRC}/src/VisualBoyAdvance
|
||||
DOC_FILES= ${WRKSRC}/COPYING ${WRKSRC}/AUTHORS ${WRKSRC}/NEWS ${WRKSRC}/README
|
||||
PROG_FILES= ${WRKSRC}/src/VisualBoyAdvance ${WRKSRC}/src/TestEmu
|
||||
DOC_FILES= COPYING AUTHORS NEWS README ChangeLog INSTALL
|
||||
|
||||
pre-everything::
|
||||
@${ECHO_MSG} ""
|
||||
|
@ -49,18 +47,22 @@ pre-everything::
|
|||
@${ECHO_MSG} "flag."
|
||||
@${ECHO_MSG} ""
|
||||
|
||||
post-extract:
|
||||
rm -rf `find ${WRKSRC} -name '.deps'`
|
||||
|
||||
do-install:
|
||||
${INSTALL} -d ${TARGET_DIR} && \
|
||||
${INSTALL_PROGRAM} ${PROG_FILES} ${TARGET_DIR} && \
|
||||
${INSTALL_DATA} ${DATA_FILES} ${TARGET_DIR} && \
|
||||
${INSTALL} -d ${TARGET_DIR}
|
||||
${INSTALL_PROGRAM} ${PROG_FILES} ${TARGET_DIR}
|
||||
|
||||
.if !exists (${PREFIX}/bin/VisualBoyAdvance.cfg)
|
||||
${INSTALL_DATA} ${DATA_FILES} ${TARGET_DIR}
|
||||
.endif
|
||||
|
||||
post-install:
|
||||
.ifndef(NOPORTDOCS)
|
||||
${MKDIR} ${DOCSDIR}
|
||||
${INSTALL_MAN} ${DOC_FILES} ${DOCSDIR}
|
||||
|
||||
.for filename in ${DOC_FILES}
|
||||
${INSTALL_MAN} ${WRKSRC}/${filename} ${DOCSDIR}
|
||||
.endfor
|
||||
|
||||
.endif
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
|
|
|
@ -1,19 +1,11 @@
|
|||
*** src/SDL.cpp.orig Sun Jan 11 22:20:00 2004
|
||||
--- src/SDL.cpp Sun Jan 11 22:17:23 2004
|
||||
***************
|
||||
*** 625,631 ****
|
||||
}
|
||||
#else
|
||||
#define SDL_CALL_STRETCHER \
|
||||
! asm volatile("call *%%eax"::"a" (stretcher),"S" (src),"D" (dest))
|
||||
#endif
|
||||
#else
|
||||
#define SDL_CALL_STRETCHER \
|
||||
--- 625,631 ----
|
||||
}
|
||||
#else
|
||||
#define SDL_CALL_STRETCHER \
|
||||
! // asm volatile("call *%%eax"::"a" (stretcher),"S" (src),"D" (dest))
|
||||
#endif
|
||||
#else
|
||||
#define SDL_CALL_STRETCHER \
|
||||
--- src/SDL.cpp.orig Sun Feb 8 14:45:01 2004
|
||||
+++ src/SDL.cpp Tue Feb 10 14:45:09 2004
|
||||
@@ -621,7 +621,7 @@
|
||||
}
|
||||
#else
|
||||
#define SDL_CALL_STRETCHER \
|
||||
- asm volatile("call *%%eax"::"a" (stretcher),"S" (src),"D" (dest))
|
||||
+ asm volatile("call *%%eax" : "=a" (stretcher),"=S" (src),"=D" (dest))
|
||||
#endif
|
||||
#else
|
||||
#define SDL_CALL_STRETCHER \
|
||||
|
|
11
emulators/vba/files/patch-ac
Normal file
11
emulators/vba/files/patch-ac
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- src/Makefile.am.orig Sun Feb 1 16:00:46 2004
|
||||
+++ src/Makefile.am Tue Feb 10 15:03:25 2004
|
||||
@@ -18,7 +18,7 @@
|
||||
hq2x.cpp hq2x.h lq2x.h Text.cpp Text.h interp.h
|
||||
|
||||
VisualBoyAdvance_LDADD = gb/libgb.a @VBA_PROF@ @VBA_MMX@
|
||||
-VisualBoyAdvance_LDFLAGS = `sdl-config --libs`
|
||||
+// VisualBoyAdvance_LDFLAGS = ${SDL_CONFIG}
|
||||
|
||||
TestEmu_SOURCES = \
|
||||
TestEmu.cpp 2xSaI.cpp pixel.cpp motionblur.cpp admame.cpp \
|
11
emulators/vba/files/patch-ad
Normal file
11
emulators/vba/files/patch-ad
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- src/Makefile.in.orig Sun Feb 1 16:00:50 2004
|
||||
+++ src/Makefile.in Tue Feb 10 15:03:46 2004
|
||||
@@ -157,7 +157,7 @@
|
||||
|
||||
|
||||
VisualBoyAdvance_LDADD = gb/libgb.a @VBA_PROF@ @VBA_MMX@
|
||||
-VisualBoyAdvance_LDFLAGS = `sdl-config --libs`
|
||||
+// VisualBoyAdvance_LDFLAGS = ${SDL_CONFIG}
|
||||
|
||||
TestEmu_SOURCES = \
|
||||
TestEmu.cpp 2xSaI.cpp pixel.cpp motionblur.cpp admame.cpp \
|
|
@ -1,21 +1,19 @@
|
|||
- configurable GB/GBA keys, including joystick support
|
||||
VisualBoyAdvance is an emulator for Nintendo's Gameboy Advance. It also
|
||||
supports emulation of the Gameboy (classic), Gameboy Pocket, Gameboy Color
|
||||
and Gameboy Advance SP.
|
||||
Some of the main features are:
|
||||
|
||||
- option to use BIOS file
|
||||
- zip/gzip file support
|
||||
- directory selection for save state, battery and screen capture
|
||||
- fullscreen mode (selectable resolution)
|
||||
- video sizes 1x, 2x, 3x and 4x
|
||||
- graphic filters Normal, TV Mode, 2xSaI, Super 2xSaI and more
|
||||
- interframe blending support
|
||||
- same emulation core as VisualBoyAdvance: GB and GBA emulation
|
||||
- built-in ARM/THUMB assembly debugger
|
||||
- 10 save states accesible through keyboard
|
||||
- automatic battery file load/save
|
||||
- auto-fire support
|
||||
- pause, reset through keyboard
|
||||
- 16, 24 and 32 bit desktop support
|
||||
- GDB remote debugging (see below for information)
|
||||
- auto frameskipping and throttle
|
||||
- AGBPrint support for development
|
||||
- RTC support
|
||||
|
||||
WWW: http://vboy.emuhq.com/
|
||||
WWW: http://vba.ngemu.com/
|
||||
|
|
|
@ -1,7 +1,9 @@
|
|||
bin/VisualBoyAdvance
|
||||
bin/VisualBoyAdvance.cfg
|
||||
bin/TestEmu
|
||||
%%PORTDOCS%%%%DOCSDIR%%/COPYING
|
||||
%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
|
||||
%%PORTDOCS%%%%DOCSDIR%%/NEWS
|
||||
%%PORTDOCS%%%%DOCSDIR%%/README
|
||||
%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
|
||||
%%PORTDOCS%%%%DOCSDIR%%/INSTALL
|
||||
@dirrm share/doc/vba
|
||||
|
|
Loading…
Reference in a new issue