www/py-uvicorn: Update to 0.15.0
- Allow build with py-httptools 0.3.0 Changes: https://github.com/encode/uvicorn/releases
This commit is contained in:
parent
a01d0ab334
commit
5c51dc1104
4 changed files with 19 additions and 6 deletions
|
@ -1,7 +1,7 @@
|
|||
# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
|
||||
|
||||
PORTNAME= uvicorn
|
||||
PORTVERSION= 0.14.0
|
||||
PORTVERSION= 0.15.0
|
||||
CATEGORIES= www python
|
||||
MASTER_SITES= CHEESESHOP
|
||||
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
|
||||
|
@ -12,9 +12,10 @@ COMMENT= Lightning-fast ASGI server
|
|||
LICENSE= BSD3CLAUSE
|
||||
LICENSE_FILE= ${WRKSRC}/LICENSE.md
|
||||
|
||||
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}click>=7<8:devel/py-click@${PY_FLAVOR} \
|
||||
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}asgiref>=3.4.0:www/py-asgiref@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}click>=7.0:devel/py-click@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}h11>=0.8:net/py-h11@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}httptools>=0.2.0<0.3:www/py-httptools@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}httptools>=0.2.0<0.4:www/py-httptools@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}python-dotenv>=0.13:www/py-python-dotenv@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}yaml>=5.1:devel/py-yaml@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}uvloop>=0.14.0:devel/py-uvloop@${PY_FLAVOR} \
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
TIMESTAMP = 1622214130
|
||||
SHA256 (uvicorn-0.14.0.tar.gz) = 45ad7dfaaa7d55cab4cd1e85e03f27e9d60bc067ddc59db52a2b0aeca8870292
|
||||
SIZE (uvicorn-0.14.0.tar.gz) = 35445
|
||||
TIMESTAMP = 1632037284
|
||||
SHA256 (uvicorn-0.15.0.tar.gz) = d9a3c0dd1ca86728d3e235182683b4cf94cd53a867c288eaeca80ee781b2caff
|
||||
SIZE (uvicorn-0.15.0.tar.gz) = 39025
|
||||
|
|
11
www/py-uvicorn/files/patch-setup.py
Normal file
11
www/py-uvicorn/files/patch-setup.py
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- setup.py.orig 2021-08-13 17:03:50 UTC
|
||||
+++ setup.py
|
||||
@@ -53,7 +53,7 @@ minimal_requirements = [
|
||||
|
||||
extra_requirements = [
|
||||
"websockets>=9.1",
|
||||
- "httptools==0.2.*",
|
||||
+ "httptools>=0.2.0,<0.4",
|
||||
"uvloop>=0.14.0,!=0.15.0,!=0.15.1; " + env_marker_cpython,
|
||||
"colorama>=0.4;" + env_marker_win,
|
||||
"watchgod>=0.6",
|
|
@ -9,4 +9,5 @@ asyncio frameworks.
|
|||
Uvicorn currently supports HTTP/1.1 and WebSockets. Support for HTTP/2 is
|
||||
planned.
|
||||
|
||||
WWW: https://www.uvicorn.org/
|
||||
WWW: https://github.com/encode/uvicorn
|
||||
|
|
Loading…
Reference in a new issue