- Support staging
- Fix build with clang
This commit is contained in:
parent
3a180982d2
commit
5c5ae4b93e
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=354272
2 changed files with 18 additions and 17 deletions
|
@ -12,33 +12,23 @@ EXTRACT_SUFX= .orig.tar.gz
|
|||
MAINTAINER= ports@FreeBSD.org
|
||||
COMMENT= Warcraft 2 mod that allows you to play Warcraft 2 with Stratagus
|
||||
|
||||
LIB_DEPENDS= png15:${PORTSDIR}/graphics/png
|
||||
LICENSE= GPLv2
|
||||
|
||||
LIB_DEPENDS= libpng15.so:${PORTSDIR}/graphics/png
|
||||
RUN_DEPENDS= stratagus:${PORTSDIR}/games/stratagus
|
||||
|
||||
LICENSE= GPLv2
|
||||
NOT_FOR_ARCHS= sparc64
|
||||
USES= pathfix gmake pkgconfig
|
||||
USE_CSTD= gnu89
|
||||
USE_GNOME= gtk20
|
||||
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
|
||||
SUB_FILES= ${PORTNAME} pkg-message
|
||||
|
||||
MAKE_ARGS+= CFLAGS+="-I${LOCALBASE}/include -I${LOCALBASE}/include/libpng15" LDFLAGS+=-L${LOCALBASE}/lib
|
||||
|
||||
NO_STAGE= yes
|
||||
do-install:
|
||||
${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME} ${PREFIX}/bin
|
||||
cd ${WRKSRC} && \
|
||||
${FIND} campaigns contrib maps scripts -type d \
|
||||
-exec ${MKDIR} "${DATADIR}/{}" \; && \
|
||||
${FIND} campaigns contrib maps scripts -type f \
|
||||
-exec ${INSTALL_DATA} "{}" "${DATADIR}/{}" \;
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/wartool ${DATADIR}
|
||||
${INSTALL_SCRIPT} ${WRKSRC}/build.sh ${DATADIR}
|
||||
|
||||
post-install:
|
||||
@${ECHO_CMD}
|
||||
@${CAT} ${PKGMESSAGE}
|
||||
@${ECHO_CMD}
|
||||
${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
|
||||
cd ${WRKSRC} && ${COPYTREE_SHARE} "campaigns contrib maps scripts" ${STAGEDIR}${DATADIR}
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/wartool ${STAGEDIR}${DATADIR}
|
||||
${INSTALL_SCRIPT} ${WRKSRC}/build.sh ${STAGEDIR}${DATADIR}
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
11
games/wargus/files/patch-wargus.c
Normal file
11
games/wargus/files/patch-wargus.c
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- wargus.c.orig 2010-11-22 03:07:16.000000000 +0300
|
||||
+++ wargus.c 2014-05-16 20:50:55.007540700 +0400
|
||||
@@ -86,7 +86,7 @@
|
||||
int ConsoleMode = 0;
|
||||
#endif
|
||||
|
||||
-inline void error(char * title, char * text) {
|
||||
+void error(char * title, char * text) {
|
||||
|
||||
#ifdef WIN32
|
||||
MessageBox(NULL, text, title, MB_OK | MB_ICONERROR);
|
Loading…
Reference in a new issue