upgrade to 2.6.6
PR: 45440 Submitted by: Ports Fury
This commit is contained in:
parent
757224a982
commit
5c82a290eb
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=70582
6 changed files with 29 additions and 16 deletions
|
@ -6,19 +6,24 @@
|
|||
#
|
||||
|
||||
PORTNAME= xpaint
|
||||
PORTVERSION= 2.6.2
|
||||
PORTVERSION= 2.6.6
|
||||
CATEGORIES= graphics
|
||||
MASTER_SITES= http://home.worldonline.dk/torsten/xpaint/ \
|
||||
ftp://ftp.win.ne.jp/pub/graphics/
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
|
||||
ftp://ftp.ac-grenoble.fr/Office/
|
||||
MASTER_SITE_SUBDIR= sf-${PORTNAME}
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
|
||||
LIB_DEPENDS= tiff.4:${PORTSDIR}/graphics/tiff \
|
||||
png.5:${PORTSDIR}/graphics/png
|
||||
|
||||
WRKSRC= ${WRKDIR}/${PORTNAME}
|
||||
USE_BZIP2= yes
|
||||
USE_IMAKE= yes
|
||||
USE_XPM= yes
|
||||
MAN1= xpaint.1
|
||||
|
||||
post-patch:
|
||||
@${ECHO_CMD} \
|
||||
"SYS_LIBRARIES = XawClientLibs -lm" > ${WRKSRC}/Local.xawdefs
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1 +1 @@
|
|||
MD5 (xpaint-2.6.2.tar.gz) = 9f22460f15a189721573d88454ce3d41
|
||||
MD5 (xpaint-2.6.6.tar.bz2) = 595bcf2dac5525ff757049a63d5e871d
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- Local.config.orig Sun Sep 3 07:02:09 2000
|
||||
+++ Local.config Fri Mar 9 03:26:06 2001
|
||||
@@ -141,10 +141,12 @@
|
||||
--- Local.config.orig Mon Oct 28 17:00:32 2002
|
||||
+++ Local.config Fri Nov 8 23:14:33 2002
|
||||
@@ -151,10 +151,13 @@
|
||||
#endif
|
||||
|
||||
#if defined(FreeBSDArchitecture)
|
||||
|
@ -18,4 +18,5 @@
|
|||
+PNG_INCLUDE = -I${LOCALBASE}/include
|
||||
+PNG_LIB = -L${LOCALBASE}/lib -Wl,-rpath,${LOCALBASE}/lib -lpng -lz
|
||||
+XPM_INCLUDE = -I$(INCDIR)/X11
|
||||
+SHAREDIR = $(LIBDIR)/xpaint
|
||||
#endif
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- readRC.c.orig Sun Sep 3 07:07:09 2000
|
||||
+++ readRC.c Fri Mar 9 03:31:53 2001
|
||||
@@ -30,11 +30,13 @@
|
||||
--- readRC.c.orig Sun Oct 27 16:32:36 2002
|
||||
+++ readRC.c Fri Nov 8 22:50:21 2002
|
||||
@@ -32,11 +32,13 @@
|
||||
#include <unistd.h>
|
||||
#endif
|
||||
|
||||
|
@ -14,7 +14,7 @@
|
|||
|
||||
#define RC_FILENAME ".XPaintrc"
|
||||
|
||||
@@ -64,19 +66,32 @@
|
||||
@@ -73,19 +75,32 @@
|
||||
static FILE *
|
||||
openTemp(char **np)
|
||||
{
|
||||
|
@ -25,7 +25,7 @@
|
|||
char xx[256];
|
||||
|
||||
if ((n = getenv("TMPDIR")) == NULL)
|
||||
n = "/tmp";
|
||||
n = "/tmp";
|
||||
|
||||
+#ifdef HAVE_MKSTEMP
|
||||
+ snprintf(xx, 256, "%s/%s", n, "/XPaintXXXXXXX");
|
||||
|
@ -33,12 +33,12 @@
|
|||
+ n = xx;
|
||||
+#else
|
||||
strcpy(xx, n);
|
||||
strcat(xx, "/XPaintXXXXXXX");
|
||||
strcat(xx, "/XPaint-XXXXXX");
|
||||
n = mktemp(xx);
|
||||
+#endif
|
||||
tempName[++tempIndex] = XtNewString(n);
|
||||
if (np != NULL)
|
||||
*np = tempName[tempIndex];
|
||||
*np = tempName[tempIndex];
|
||||
+#ifdef HAVE_MKSTEMP
|
||||
+ return fdopen(fd, "w");
|
||||
+#else
|
||||
|
|
|
@ -2,4 +2,4 @@ XPaint is a color image editing tool which features most standard paint
|
|||
program options. It allows for the editing of multiple images simultaneously
|
||||
and supports various formats, including PPM, XBM, TIFF, etc.
|
||||
|
||||
WWW: http://home.worldonline.dk/torsten/xpaint/
|
||||
WWW: http://sf-xpaint.sourceforge.net/
|
||||
|
|
|
@ -1,2 +1,9 @@
|
|||
bin/xpaint
|
||||
lib/X11/app-defaults/XPaint
|
||||
lib/X11/xpaint/help/Help
|
||||
lib/X11/xpaint/help/Help_fr
|
||||
lib/X11/xpaint/messages/Messages
|
||||
lib/X11/xpaint/messages/Messages_fr
|
||||
@dirrm lib/X11/xpaint/messages
|
||||
@dirrm lib/X11/xpaint/help
|
||||
@dirrm lib/X11/xpaint
|
||||
|
|
Loading…
Reference in a new issue