Add phantom 1.2, phantomblock generator (converts existing files to

sparse files).

PR:		ports/92156
Submitted by:	Jeffrey H. Johnson <CPE1704TKS@bellsouth.net>
This commit is contained in:
Renato Botelho 2006-01-25 17:04:24 +00:00
parent 2e676175ca
commit 5c869eee44
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=154435
5 changed files with 62 additions and 0 deletions

View file

@ -398,6 +398,7 @@
SUBDIR += personality
SUBDIR += pfstat
SUBDIR += pftop
SUBDIR += phantom
SUBDIR += php4-posix
SUBDIR += php5-posix
SUBDIR += pib

21
sysutils/phantom/Makefile Normal file
View file

@ -0,0 +1,21 @@
# New ports collection makefile for: phantom
# Date created: 22 January 2006
# Whom: Jeffrey H. Johnson <CPE1704TKS@bellsouth.net>
#
# $FreeBSD$
#
PORTNAME= phantom
PORTVERSION= 1.2
CATEGORIES= sysutils
MASTER_SITES= http://www.vanheusden.com/Linux/
EXTRACT_SUFX= .tgz
MAINTAINER= CPE1704TKS@bellsouth.net
COMMENT= Phantomblock generator (converts existing files to sparse files)
ALL_TARGET= all
PLIST_FILES= bin/phantom
.include <bsd.port.mk>

View file

@ -0,0 +1,3 @@
SIZE (phantom-1.2.tgz) = 4425
MD5 (phantom-1.2.tgz) = d790abb0caed787e3c8082340e6e549e
SHA256 (phantom-1.2.tgz) = 9ce7d0d7e6561474a0b4d70f9ae0fb4010ef9b4f012c9018bf9fdca1704ac6c2

View file

@ -0,0 +1,22 @@
--- Makefile.orig Fri Jul 8 05:30:27 2005
+++ Makefile Wed Jan 25 11:27:25 2006
@@ -1,8 +1,8 @@
VERSION=1.2
DEBUG=#-g
-LDFLAGS=$(DEBUG)
-CFLAGS=-O2 -Wall -DVERSION=\"$(VERSION)\" $(DEBUG)
+LDFLAGS+=$(DEBUG)
+CFLAGS+=-DVERSION=\"$(VERSION)\" -DMADV_SEQUENTIAL $(DEBUG)
OBJS=phantom.o
@@ -12,7 +12,7 @@
$(CC) -Wall -W $(OBJS) $(LDFLAGS) -o phantom
install: phantom
- cp phantom $(DESTDIR)/usr/bin
+ ${INSTALL} -m 755 phantom ${PREFIX}/bin
clean:
rm -f $(OBJS) core phantom

View file

@ -0,0 +1,15 @@
This tool removes blocks of 0x00 from files by replacing them with
phantomblocks. That way, a file uses less diskspace while its contents
hasn't changed at all!
BEWARE: after copying these files with tar, cp, cpio or any other tool,
the phantomblocks have been replaced with 0x00-blocks again!
EXAMPLE:
find / -type f -print | xargs -n 1 phantom -r -i
This would go trough the whole harddisk, scan all files and generate
0x00-blocks where necessary.
WWW: http://www.vanheusden.com/Linux/phantom.php