Add new port wmfuzzy: A clock dockapp that uses text and fuzzy approximation
to tell you time. PR: ports/41336 Submitted by: Adam Weinberger <adam@vectors.cx> Reviewed by: Simon 'corecode' Schubert <corecode@corecode.ath.cx>
This commit is contained in:
parent
b6dfc22202
commit
5ca2a5e3a4
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=64069
7 changed files with 65 additions and 0 deletions
|
@ -28,6 +28,7 @@
|
|||
SUBDIR += wmclock
|
||||
SUBDIR += wmdate
|
||||
SUBDIR += wmfishtime
|
||||
SUBDIR += wmfuzzy
|
||||
SUBDIR += wmitime
|
||||
SUBDIR += wmtime
|
||||
SUBDIR += wmtimer
|
||||
|
|
25
x11-clocks/wmfuzzy/Makefile
Normal file
25
x11-clocks/wmfuzzy/Makefile
Normal file
|
@ -0,0 +1,25 @@
|
|||
# New ports collection makefile for: wmfuzzy
|
||||
# Date created: 4 August 2002
|
||||
# Whom: Adam Weinberger <adam@vectors.cx>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= wmfuzzy
|
||||
PORTVERSION= 0.2
|
||||
CATEGORIES= x11-clocks windowmaker
|
||||
MASTER_SITES= http://www.manicai.net/comp/wmfuzzy/
|
||||
EXTRACT_SUFX= .tgz
|
||||
|
||||
MAINTAINER= adam@vectors.cx
|
||||
|
||||
LIB_DEPENDS= gnugetopt.1:${PORTSDIR}/devel/libgnugetopt
|
||||
|
||||
WRKSRC= ${WRKDIR}/${PORTNAME}/src
|
||||
USE_X_PREFIX= yes
|
||||
USE_XPM= yes
|
||||
|
||||
do-install:
|
||||
@${INSTALL_PROGRAM} ${WRKSRC}/wmfuzzy ${PREFIX}/bin
|
||||
|
||||
.include <bsd.port.mk>
|
1
x11-clocks/wmfuzzy/distinfo
Normal file
1
x11-clocks/wmfuzzy/distinfo
Normal file
|
@ -0,0 +1 @@
|
|||
MD5 (wmfuzzy-0.2.tgz) = a1d07243fe343921d61b6edfa83aa127
|
25
x11-clocks/wmfuzzy/files/patch-Makefile
Normal file
25
x11-clocks/wmfuzzy/files/patch-Makefile
Normal file
|
@ -0,0 +1,25 @@
|
|||
--- Makefile.orig Thu Aug 1 18:55:34 2002
|
||||
+++ Makefile Mon Aug 5 13:17:41 2002
|
||||
@@ -12,11 +12,8 @@
|
||||
#group=-g root
|
||||
|
||||
|
||||
-CC = gcc
|
||||
-CFLAGS = -g -Wall
|
||||
-INCDIR = -I/usr/X11R6/include/X11 -I/usr/X11R6/include
|
||||
-DESTDIR= /usr/X11R6
|
||||
-LIBDIR = -L/usr/X11R6/lib
|
||||
+INCDIR = -I${X11BASE}/include/X11 -I${X11BASE}/include -I${LOCALBASE}/include
|
||||
+LIBDIR = -L${X11BASE}/lib -L${LOCALBASE}/lib
|
||||
# for linux
|
||||
LIBS = -lXpm -lX11 -lXext
|
||||
# for Solaris
|
||||
@@ -36,7 +33,7 @@
|
||||
all: ${name}
|
||||
|
||||
${name}: $(OBJS)
|
||||
- $(CC) $(CFLAGS) $(SYSTEM) $(LIBDIR) $(LIBS) $^ -o ${name}
|
||||
+ $(CC) $(CFLAGS) $(SYSTEM) $(LIBDIR) $(LIBS) $(OBJS) -o ${name}
|
||||
|
||||
install: all
|
||||
install ${owner} ${group} -s -m 755 ./${name} ${prefix}/${name}
|
1
x11-clocks/wmfuzzy/pkg-comment
Normal file
1
x11-clocks/wmfuzzy/pkg-comment
Normal file
|
@ -0,0 +1 @@
|
|||
A fuzzy clock WindowMaker dockapp
|
11
x11-clocks/wmfuzzy/pkg-descr
Normal file
11
x11-clocks/wmfuzzy/pkg-descr
Normal file
|
@ -0,0 +1,11 @@
|
|||
wmfuzzy is yet another clock for Windowmaker (so as with ASClock
|
||||
and however many others). The difference between it and all of those
|
||||
(that I know of) is that the it only gives you the approximate time
|
||||
and displays it textually.
|
||||
|
||||
Why? because it seemed a fun idea and let's face it when was the
|
||||
last time you cared it was 22:58 rather than "Five to Eleven?"
|
||||
|
||||
WWW: http://www.manicai.net/comp/wmfuzzy
|
||||
|
||||
-Adam Weinberger adam@vectors.cx
|
1
x11-clocks/wmfuzzy/pkg-plist
Normal file
1
x11-clocks/wmfuzzy/pkg-plist
Normal file
|
@ -0,0 +1 @@
|
|||
bin/wmfuzzy
|
Loading…
Reference in a new issue