emulators/ripes: Update to 2.2.4
Release note: https://github.com/mortbopet/Ripes/wiki/Release-notes#ripes-v224 PR: 261846
This commit is contained in:
parent
030ccb053d
commit
5ceac19058
4 changed files with 17 additions and 90 deletions
|
@ -1,6 +1,6 @@
|
|||
PORTNAME= ripes
|
||||
DISTVERSIONPREFIX= v
|
||||
DISTVERSION= 2.2.3
|
||||
DISTVERSION= 2.2.4
|
||||
CATEGORIES= emulators
|
||||
|
||||
MAINTAINER= mclay@astate.edu
|
||||
|
@ -17,10 +17,15 @@ CMAKE_INSTALL_PREFIX= ${STAGEDIR}${PREFIX}
|
|||
USE_GITHUB= yes
|
||||
GH_ACCOUNT= mortbopet
|
||||
GH_PROJECT= Ripes
|
||||
GH_TUPLE= mortbopet:VSRTL:65ac251:VSRTL/external/VSRTL \
|
||||
GH_TUPLE= mortbopet:VSRTL:83ee187:VSRTL/external/VSRTL \
|
||||
serge1:ELFIO:79fcd11:ELFIO/external/ELFIO \
|
||||
mortbopet:libelfin:49d1653:libelfin/external/libelfin \
|
||||
yhirose:cpp-mmaplib:c517af7:cpp_mmaplib/external/libelfin/external/cpp-mmaplib \
|
||||
pbhogan:Signals:17881fb:Signals/external/VSRTL/external/Signals \
|
||||
USCiLab:cereal:51cbda5:cereal/external/VSRTL/external/cereal \
|
||||
mortbopet:better-enums:52a694b:better_enums/external/VSRTL/external/better-enums
|
||||
|
||||
PORTSCOUT= ignore:continuous-master
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
||||
|
|
|
@ -1,10 +1,14 @@
|
|||
TIMESTAMP = 1638160024
|
||||
SHA256 (mortbopet-Ripes-v2.2.3_GH0.tar.gz) = 321dbe3884a339d859e36c6d5fd1c402c616916c72fba5ead544eef64075e7ca
|
||||
SIZE (mortbopet-Ripes-v2.2.3_GH0.tar.gz) = 14150373
|
||||
SHA256 (mortbopet-VSRTL-65ac251_GH0.tar.gz) = 872b619e5c6f590d94a0ab6fec5e037cc3c948fefe3d3e59f7b5ba3bf9bfe8cc
|
||||
SIZE (mortbopet-VSRTL-65ac251_GH0.tar.gz) = 14500229
|
||||
TIMESTAMP = 1644418852
|
||||
SHA256 (mortbopet-Ripes-v2.2.4_GH0.tar.gz) = fc8c7a047deea8192f57a6b7cc3eb77fe8df431c4ffb8fa605b3b28421db790a
|
||||
SIZE (mortbopet-Ripes-v2.2.4_GH0.tar.gz) = 14386232
|
||||
SHA256 (mortbopet-VSRTL-83ee187_GH0.tar.gz) = 33db4bd36762dc31d0114ad3df2c715841bccb882dbe924286308967fb3ee6c8
|
||||
SIZE (mortbopet-VSRTL-83ee187_GH0.tar.gz) = 14500693
|
||||
SHA256 (serge1-ELFIO-79fcd11_GH0.tar.gz) = 2f2478e48dc20b30fd705e9ae7208ea8ab175b5aa9195d0705142ad6e9054e55
|
||||
SIZE (serge1-ELFIO-79fcd11_GH0.tar.gz) = 4229577
|
||||
SHA256 (mortbopet-libelfin-49d1653_GH0.tar.gz) = 9569d5168c199ec6a7a2b2abe1813a3b59dc70b67aa569cae47308fa84aa49a2
|
||||
SIZE (mortbopet-libelfin-49d1653_GH0.tar.gz) = 85862
|
||||
SHA256 (yhirose-cpp-mmaplib-c517af7_GH0.tar.gz) = 1d3d52dadcd8a9478fa9a728ea6692118f1e3a16a36d8f28b2929d2dce296023
|
||||
SIZE (yhirose-cpp-mmaplib-c517af7_GH0.tar.gz) = 1848
|
||||
SHA256 (pbhogan-Signals-17881fb_GH0.tar.gz) = 7d2c420dc34471519306dd4070c571c74cb129cac782cb0a38ba07f0ba8488f8
|
||||
SIZE (pbhogan-Signals-17881fb_GH0.tar.gz) = 38528
|
||||
SHA256 (USCiLab-cereal-51cbda5_GH0.tar.gz) = efa214cfc850a4a2360baf4419b88c93be2a08b09ff5f9bac604a18498b83cfb
|
||||
|
|
|
@ -1,83 +0,0 @@
|
|||
--- CMakeLists.txt.orig 2022-01-05 13:44:44.993511000 -0600
|
||||
+++ CMakeLists.txt 2022-01-05 14:10:26.330330000 -0600
|
||||
@@ -1,4 +1,4 @@
|
||||
-cmake_minimum_required(VERSION 3.9)
|
||||
+cmake_minimum_required(VERSION 3.13)
|
||||
set(CMAKE_CXX_STANDARD 17)
|
||||
set(CMAKE_CXX_STANDARD_REQUIRED ON)
|
||||
set(CMAKE_POSITION_INDEPENDENT_CODE ON)
|
||||
@@ -9,19 +9,27 @@
|
||||
set_property(GLOBAL PROPERTY RULE_LAUNCH_COMPILE "${CCACHE_PROGRAM}")
|
||||
endif()
|
||||
|
||||
-project(Ripes CXX)
|
||||
+project(Ripes
|
||||
+ LANGUAGES CXX
|
||||
+ DESCRIPTION "A graphical processor simulator and assembly editor for the RISC-V ISA"
|
||||
+ HOMEPAGE_URL "https://github.com/mortbopet/Ripes"
|
||||
+)
|
||||
|
||||
+if(NOT ${CMAKE_SYSTEM_NAME} STREQUAL "Windows")
|
||||
+ include(GNUInstallDirs) #Must exist after declaring a project
|
||||
+endif()
|
||||
+
|
||||
# Error flags on everything but MSVC
|
||||
if(NOT MSVC)
|
||||
set(CMAKE_CXX_FLAGS "-Wextra -Wall \
|
||||
- -Werror=switch -Werror=return-type -Werror=shadow \
|
||||
+ -Werror=switch -Werror=return-type \
|
||||
-Werror=unreachable-code")
|
||||
endif()
|
||||
|
||||
if(MSVC)
|
||||
add_definitions(/bigobj) # Allow big object
|
||||
elseif(MINGW)
|
||||
- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wa,-mbig-obj") # Allow big object
|
||||
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -mbig-obj") # Allow big object
|
||||
endif()
|
||||
|
||||
######################################################################
|
||||
@@ -62,6 +70,7 @@
|
||||
include_directories(${RIPES_LIB} PUBLIC external/VSRTL/external)
|
||||
include_directories(SYSTEM external/ELFIO)
|
||||
include_directories(SYSTEM external/VSRTL/external/Signals)
|
||||
+include_directories(external/libelfin_cmake)
|
||||
include_directories(external)
|
||||
|
||||
option(RIPES_BUILD_VERILATOR_PROCESSORS "Build verilator processors" OFF)
|
||||
@@ -89,6 +98,9 @@
|
||||
endif()
|
||||
|
||||
add_subdirectory(external)
|
||||
+
|
||||
+# Fix the name of the ripes library.
|
||||
+set(RIPES_LIB ripes_lib)
|
||||
add_subdirectory(src)
|
||||
|
||||
option(RIPES_BUILD_TESTS "Build Ripes tests" OFF)
|
||||
@@ -102,4 +114,24 @@
|
||||
# Link Qt libraries
|
||||
target_link_libraries(${APP_NAME} Qt5::Core Qt5::Widgets)
|
||||
# Link Ripes library
|
||||
-target_link_libraries(${APP_NAME} ripes_lib)
|
||||
+target_link_libraries(${APP_NAME} ${RIPES_LIB})
|
||||
+
|
||||
+if(UNIX AND NOT APPLE) #Define the LINUX variable before testing it
|
||||
+ set(LINUX TRUE)
|
||||
+endif()
|
||||
+
|
||||
+if(${LINUX})
|
||||
+ install(TARGETS ${APP_NAME}
|
||||
+ RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR}
|
||||
+ )
|
||||
+elseif(${APPLE})
|
||||
+ install(TARGETS ${APP_NAME}
|
||||
+ RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR}
|
||||
+ BUNDLE DESTINATION ${CMAKE_INSTALL_BINDIR}
|
||||
+ )
|
||||
+endif()
|
||||
+
|
||||
+install(DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR}/appdir/usr/
|
||||
+ DESTINATION ${CMAKE_INSTALL_PREFIX}
|
||||
+)
|
||||
+
|
|
@ -9,3 +9,4 @@
|
|||
/usr/local/share/icons/hicolor/22x22/apps/Ripes.png
|
||||
/usr/local/share/icons/hicolor/32x32/apps/Ripes.png
|
||||
/usr/local/share/icons/hicolor/16x16/apps/Ripes.png
|
||||
/usr/local/share/metainfo/io.github.mortbopet.Ripes.metainfo.xml
|
||||
|
|
Loading…
Reference in a new issue