sysutils/flashrom: fix linker error by LLVM17

PR:		276288
Reported by:	ohartmann@walstatt.org (O. Hartmann), pkg-fallout
MFH:		2024Q1
Sponsored by:	Postgres Professional
This commit is contained in:
Michael Zhilin 2024-02-11 20:18:34 +03:00
parent eab3bfbaf6
commit 5d01dea4a1
3 changed files with 30 additions and 1 deletions

View File

@ -1,7 +1,7 @@
PORTNAME= flashrom
PORTVERSION= 1.3.0
DISTVERSIONPREFIX= v
PORTREVISION= 2
PORTREVISION= 3
CATEGORIES= sysutils
MASTER_SITES= https://download.flashrom.org/releases/

View File

@ -0,0 +1,18 @@
--- libflashrom.map.orig 2024-02-01 08:22:08 UTC
+++ libflashrom.map
@@ -1,7 +1,5 @@ LIBFLASHROM_1.0 {
LIBFLASHROM_1.0 {
global:
- flashrom_board_info;
- flashrom_chipset_info;
flashrom_data_free;
flashrom_flag_get;
flashrom_flag_set;
@@ -9,7 +7,6 @@ LIBFLASHROM_1.0 {
flashrom_flash_getsize;
flashrom_flash_probe;
flashrom_flash_release;
- flashrom_flashchip_info;
flashrom_image_read;
flashrom_image_verify;
flashrom_image_write;

View File

@ -0,0 +1,11 @@
--- meson.build.orig 2023-04-27 13:51:02 UTC
+++ meson.build
@@ -234,7 +234,7 @@ programmer = {
},
'internal' : {
'systems' : systems_hwaccess + ['linux'],
- 'cpu_families' : (host_machine.system() == 'linux' ? [host_machine.cpu_family()] : ['x86', 'x86_64']),
+ 'cpu_families' : (host_machine.system() in ['linux', 'freebsd'] ? [host_machine.cpu_family()] : ['x86', 'x86_64']),
'deps' : [ libpci ],
'groups' : [ group_internal ],
'srcs' : (host_machine.cpu_family() in ['x86', 'x86_64'] ? files(