- Update mail/courier-imap to 4.16.2
- Update mail/sqwebmail to 5.8.3 - Update security/courier-authlib to 0.66.3 - Remove no more needed patch from mail/maildrop Approved by: oliver (maintainer) Differential Revision: https://reviews.freebsd.org/D2975
This commit is contained in:
parent
b029deb842
commit
5d1fa5921a
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=391221
10 changed files with 24 additions and 40 deletions
|
@ -2,7 +2,7 @@
|
||||||
# $FreeBSD$
|
# $FreeBSD$
|
||||||
|
|
||||||
PORTNAME= courier-imap
|
PORTNAME= courier-imap
|
||||||
PORTVERSION= 4.16.1
|
PORTVERSION= 4.16.2
|
||||||
PORTEPOCH= 2
|
PORTEPOCH= 2
|
||||||
CATEGORIES= mail ipv6
|
CATEGORIES= mail ipv6
|
||||||
MASTER_SITES= SF/courier/imap/${PORTVERSION}
|
MASTER_SITES= SF/courier/imap/${PORTVERSION}
|
||||||
|
|
|
@ -1,2 +1,2 @@
|
||||||
SHA256 (courier-imap-4.16.1.tar.bz2) = 51241784f78b7ce8342adf9d4741a2f8ae8ee0641fe7ead4751af8d4019d4204
|
SHA256 (courier-imap-4.16.2.tar.bz2) = 3be244b3c4d3d5c5e33efb37e4cf712ae83cbe21e43c31725e0d996ab4acc387
|
||||||
SIZE (courier-imap-4.16.1.tar.bz2) = 3026062
|
SIZE (courier-imap-4.16.2.tar.bz2) = 3028445
|
||||||
|
|
|
@ -17,6 +17,7 @@
|
||||||
|
|
||||||
PORTNAME= maildrop
|
PORTNAME= maildrop
|
||||||
PORTVERSION= 2.8.3
|
PORTVERSION= 2.8.3
|
||||||
|
PORTREVISION= 1
|
||||||
CATEGORIES= mail
|
CATEGORIES= mail
|
||||||
MASTER_SITES= SF/courier/${PORTNAME}/${PORTVERSION}
|
MASTER_SITES= SF/courier/${PORTNAME}/${PORTVERSION}
|
||||||
|
|
||||||
|
|
|
@ -1,18 +0,0 @@
|
||||||
--- libs/maildrop/main.C.orig 2015-06-20 13:01:36 UTC
|
|
||||||
+++ libs/maildrop/main.C
|
|
||||||
@@ -264,13 +264,13 @@ static int callback_authlib(struct authi
|
|
||||||
void *void_arg)
|
|
||||||
{
|
|
||||||
Maildrop &maildrop=*(Maildrop *)void_arg;
|
|
||||||
-
|
|
||||||
+/*
|
|
||||||
if (auth_mkhomedir(auth))
|
|
||||||
{
|
|
||||||
perror(auth->homedir);
|
|
||||||
exit(1);
|
|
||||||
}
|
|
||||||
-
|
|
||||||
+*/
|
|
||||||
if (VerboseLevel() > 1)
|
|
||||||
{
|
|
||||||
Buffer b;
|
|
|
@ -2,7 +2,7 @@
|
||||||
# $FreeBSD$
|
# $FreeBSD$
|
||||||
|
|
||||||
PORTNAME= sqwebmail
|
PORTNAME= sqwebmail
|
||||||
PORTVERSION= 5.8.2
|
PORTVERSION= 5.8.3
|
||||||
CATEGORIES= mail www
|
CATEGORIES= mail www
|
||||||
MASTER_SITES= SF/courier/webmail/${PORTVERSION}
|
MASTER_SITES= SF/courier/webmail/${PORTVERSION}
|
||||||
|
|
||||||
|
|
|
@ -1,2 +1,2 @@
|
||||||
SHA256 (sqwebmail-5.8.2.tar.bz2) = 5a0a722a8e09b2ab318c91e3a09888564826616d26635799c52b4c545dfde7d9
|
SHA256 (sqwebmail-5.8.3.tar.bz2) = 92b30599dc52ca815357f9c540d9ab69d1d975bb7a41c787c3a4a1066d12855c
|
||||||
SIZE (sqwebmail-5.8.2.tar.bz2) = 3514846
|
SIZE (sqwebmail-5.8.3.tar.bz2) = 3520773
|
||||||
|
|
|
@ -2,7 +2,7 @@
|
||||||
# $FreeBSD$
|
# $FreeBSD$
|
||||||
|
|
||||||
PORTNAME= courier-authlib
|
PORTNAME= courier-authlib
|
||||||
PORTVERSION= 0.66.2
|
PORTVERSION= 0.66.3
|
||||||
PORTREVISION?= 0
|
PORTREVISION?= 0
|
||||||
CATEGORIES?= security mail
|
CATEGORIES?= security mail
|
||||||
.if defined(PKGNAMESUFFIX)
|
.if defined(PKGNAMESUFFIX)
|
||||||
|
|
|
@ -1,2 +1,2 @@
|
||||||
SHA256 (courier-authlib-0.66.2.tar.bz2) = ed104562b6bc6a2c6212d73b647f5526da68cf262e0c1d2c1ee478182b8f87a9
|
SHA256 (courier-authlib-0.66.3.tar.bz2) = 033402a86e334999eaf17c1b722d6f6cc1961fccb5d2ee88342dfd6c5d534961
|
||||||
SIZE (courier-authlib-0.66.2.tar.bz2) = 2081381
|
SIZE (courier-authlib-0.66.3.tar.bz2) = 2085083
|
||||||
|
|
|
@ -587,17 +587,9 @@
|
||||||
+ close(DIR);
|
+ close(DIR);
|
||||||
+}
|
+}
|
||||||
+
|
+
|
||||||
--- userdb/Makefile.in.orig 2013-09-13 12:42:56.000000000 +0200
|
--- userdb/Makefile.in.orig 2015-06-06 14:37:22 UTC
|
||||||
+++ userdb/Makefile.in 2013-10-16 12:27:57.000000000 +0200
|
+++ userdb/Makefile.in
|
||||||
@@ -91,6 +91,7 @@
|
@@ -107,7 +107,7 @@ am__CONFIG_DISTCLEAN_FILES = config.stat
|
||||||
$(top_srcdir)/configure $(am__configure_deps) \
|
|
||||||
$(srcdir)/config.h.in $(srcdir)/userdb.pl.in \
|
|
||||||
$(srcdir)/makeuserdb.in $(srcdir)/pw2userdb.in \
|
|
||||||
+ $(srcdir)/vchkpw2userdb.in \
|
|
||||||
$(top_srcdir)/../depcomp ../AUTHORS ../COPYING ../ChangeLog \
|
|
||||||
../INSTALL ../NEWS ../README ../config.guess ../config.sub \
|
|
||||||
../depcomp ../install-sh ../missing ../ltmain.sh \
|
|
||||||
@@ -105,7 +106,7 @@
|
|
||||||
configure.lineno config.status.lineno
|
configure.lineno config.status.lineno
|
||||||
mkinstalldirs = $(install_sh) -d
|
mkinstalldirs = $(install_sh) -d
|
||||||
CONFIG_HEADER = config.h
|
CONFIG_HEADER = config.h
|
||||||
|
@ -606,7 +598,15 @@
|
||||||
CONFIG_CLEAN_VPATH_FILES =
|
CONFIG_CLEAN_VPATH_FILES =
|
||||||
LTLIBRARIES = $(noinst_LTLIBRARIES)
|
LTLIBRARIES = $(noinst_LTLIBRARIES)
|
||||||
libuserdb_la_LIBADD =
|
libuserdb_la_LIBADD =
|
||||||
@@ -365,7 +366,7 @@
|
@@ -222,6 +222,7 @@ CSCOPE = cscope
|
||||||
|
AM_RECURSIVE_TARGETS = cscope
|
||||||
|
am__DIST_COMMON = $(srcdir)/Makefile.in $(srcdir)/config.h.in \
|
||||||
|
$(srcdir)/makeuserdb.in $(srcdir)/pw2userdb.in \
|
||||||
|
+ $(srcdir)/vchkpw2userdb.in \
|
||||||
|
$(srcdir)/userdb.pl.in $(top_srcdir)/../compile \
|
||||||
|
$(top_srcdir)/../config.guess $(top_srcdir)/../config.sub \
|
||||||
|
$(top_srcdir)/../depcomp $(top_srcdir)/../install-sh \
|
||||||
|
@@ -376,7 +377,7 @@ BUILT_SOURCES = makeuserdb.html.in makeu
|
||||||
userdb.html.in userdb.8.in \
|
userdb.html.in userdb.8.in \
|
||||||
userdbpw.html.in userdbpw.8.in
|
userdbpw.html.in userdbpw.8.in
|
||||||
|
|
||||||
|
@ -615,7 +615,7 @@
|
||||||
noinst_DATA = makeuserdb.html userdb.html userdbpw.html
|
noinst_DATA = makeuserdb.html userdb.html userdbpw.html
|
||||||
userdbpw_SOURCES = userdbpw.c
|
userdbpw_SOURCES = userdbpw.c
|
||||||
userdbpw_LDADD = libuserdb.la @HMACLIB@ @MD5LIB@ @SHA1LIB@ @CRYPTLIBS@
|
userdbpw_LDADD = libuserdb.la @HMACLIB@ @MD5LIB@ @SHA1LIB@ @CRYPTLIBS@
|
||||||
@@ -434,6 +435,8 @@
|
@@ -444,6 +445,8 @@ makeuserdb: $(top_builddir)/config.statu
|
||||||
cd $(top_builddir) && $(SHELL) ./config.status $@
|
cd $(top_builddir) && $(SHELL) ./config.status $@
|
||||||
pw2userdb: $(top_builddir)/config.status $(srcdir)/pw2userdb.in
|
pw2userdb: $(top_builddir)/config.status $(srcdir)/pw2userdb.in
|
||||||
cd $(top_builddir) && $(SHELL) ./config.status $@
|
cd $(top_builddir) && $(SHELL) ./config.status $@
|
||||||
|
|
|
@ -21,6 +21,7 @@ man/man3/auth_generic.3.gz
|
||||||
man/man3/auth_getoption.3.gz
|
man/man3/auth_getoption.3.gz
|
||||||
man/man3/auth_getuserinfo.3.gz
|
man/man3/auth_getuserinfo.3.gz
|
||||||
man/man3/auth_login.3.gz
|
man/man3/auth_login.3.gz
|
||||||
|
man/man3/auth_mkhomedir.3.gz
|
||||||
man/man3/auth_passwd.3.gz
|
man/man3/auth_passwd.3.gz
|
||||||
man/man3/auth_sasl.3.gz
|
man/man3/auth_sasl.3.gz
|
||||||
man/man3/auth_sasl_ex.3.gz
|
man/man3/auth_sasl_ex.3.gz
|
||||||
|
|
Loading…
Reference in a new issue