Chryzodus is a cross-platform graphical program drawing
beautiful and colorful chryzodes. If you do not know what chryzodes are, take a look at http://www.chryzode.org/. Then you will be able to explore the world of chryzodes by yourself using Chryzodus. But one does not even need to know much about chryzodes to use Chryzodus and see beautiful images appear on the screen! PR: ports/83234 Submitted by: Nicola Vitale <nivit@email.it>
This commit is contained in:
parent
3808749df3
commit
5d7dcdec46
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=138937
7 changed files with 78 additions and 0 deletions
|
@ -28,6 +28,7 @@
|
|||
SUBDIR += calcoo
|
||||
SUBDIR += calctool
|
||||
SUBDIR += ccmath
|
||||
SUBDIR += chryzodus
|
||||
SUBDIR += clarence
|
||||
SUBDIR += cln
|
||||
SUBDIR += concorde
|
||||
|
|
31
math/chryzodus/Makefile
Normal file
31
math/chryzodus/Makefile
Normal file
|
@ -0,0 +1,31 @@
|
|||
# New ports collection makefile for: chryzodus
|
||||
# Date created: 2005-07-09
|
||||
# Whom: Nicola Vitale <nivit@email.it>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= chryzodus
|
||||
PORTVERSION= 0.32
|
||||
DISTVERSIONSUFFIX= -src
|
||||
CATEGORIES= math
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
|
||||
MASTER_SITE_SUBDIR= ${PORTNAME}
|
||||
|
||||
MAINTAINER= nivit@email.it
|
||||
COMMENT= A chryzode (http//www.chryzode.org) explorer
|
||||
|
||||
LIB_DEPENDS= alleg.41:${PORTSDIR}/devel/allegro
|
||||
|
||||
WRKSRC= ${WRKDIR}/${PORTNAME}
|
||||
MAKEFILE= makefile.unx
|
||||
|
||||
do-install:
|
||||
@${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin/${PORTNAME}
|
||||
|
||||
.if !defined(NOPORTDOCS)
|
||||
@${MKDIR} ${DOCSDIR}; \
|
||||
${INSTALL_DATA} ${WRKSRC}/doc/* ${DOCSDIR}
|
||||
.endif
|
||||
|
||||
.include <bsd.port.mk>
|
2
math/chryzodus/distinfo
Normal file
2
math/chryzodus/distinfo
Normal file
|
@ -0,0 +1,2 @@
|
|||
MD5 (chryzodus-0.32-src.tar.gz) = d89eafdb85d236bb2c1ed7e3acba37ae
|
||||
SIZE (chryzodus-0.32-src.tar.gz) = 18834
|
12
math/chryzodus/files/patch-gui.cpp
Normal file
12
math/chryzodus/files/patch-gui.cpp
Normal file
|
@ -0,0 +1,12 @@
|
|||
$FreeBSD$
|
||||
--- gui.cpp Tue Jun 29 17:16:38 2004
|
||||
+++ gui.cpp.port Sat Jul 9 21:25:43 2005
|
||||
@@ -121,7 +121,7 @@
|
||||
{
|
||||
// utiliser d_chryzode_proc pour tenir jour la bitmap ??????
|
||||
destroy_bitmap((BITMAP *)main_dialog[MAIN_D_CHRYZODE].dp);
|
||||
- (BITMAP *)main_dialog[MAIN_D_CHRYZODE].dp = create_bitmap(SCREEN_W, SCREEN_H);
|
||||
+ main_dialog[MAIN_D_CHRYZODE].dp = (BITMAP *)create_bitmap(SCREEN_W, SCREEN_H);
|
||||
((Cchryzode *)main_dialog[MAIN_D_CHRYZODE].dp2)->set_bmp((BITMAP *)main_dialog[MAIN_D_CHRYZODE].dp);
|
||||
main_dialog[MAIN_D_CHRYZODE].w = SCREEN_W;
|
||||
main_dialog[MAIN_D_CHRYZODE].h = SCREEN_H;
|
12
math/chryzodus/files/patch-makefile.unx
Normal file
12
math/chryzodus/files/patch-makefile.unx
Normal file
|
@ -0,0 +1,12 @@
|
|||
$FreeBSD$
|
||||
--- makefile.unx Tue Jun 29 17:16:38 2004
|
||||
+++ makefile.unx.port Sat Jul 9 21:43:27 2005
|
||||
@@ -6,7 +6,7 @@
|
||||
#--------------------------------------#
|
||||
|
||||
CXX = g++
|
||||
-CFLAGS = -Wall
|
||||
+CFLAGS = -Wall `allegro-config --cflags`
|
||||
LDFLAGS = -s -lstdc++ `allegro-config --libs`
|
||||
|
||||
OBJECTS = main.o gui.o compute.o
|
10
math/chryzodus/pkg-descr
Normal file
10
math/chryzodus/pkg-descr
Normal file
|
@ -0,0 +1,10 @@
|
|||
Chryzodus is a cross-platform graphical program drawing
|
||||
beautiful and colorful chryzodes.
|
||||
If you do not know what chryzodes are, take a look at
|
||||
http://www.chryzode.org/. Then you will be able to explore
|
||||
the world of chryzodes by yourself using Chryzodus.
|
||||
But one does not even need to know much about chryzodes
|
||||
to use Chryzodus and see beautiful images appear on the screen!
|
||||
|
||||
Author: Florian LHERBETTE
|
||||
WWW: http://chryzodus.sourceforge.net/
|
10
math/chryzodus/pkg-plist
Normal file
10
math/chryzodus/pkg-plist
Normal file
|
@ -0,0 +1,10 @@
|
|||
@comment $FreeBSD$
|
||||
bin/chryzodus
|
||||
%%PORTDOCS%%%%DOCSDIR%%/chryzode.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/file.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/help.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/index.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/keyboard.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/overview.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/zoom.html
|
||||
%%PORTDOCS%%@dirrm %%DOCSDIR%%
|
Loading…
Reference in a new issue