1. Update 3.9.11 --> 3.9.12.

2.  Add installation of etc/screenrc.
3.  Fix hashed password with garbled salt.

#2 Submitted by:	ade
#3 Submitted by:	Phil C <flah@hell.com>
This commit is contained in:
Cy Schubert 2002-09-02 14:14:00 +00:00
parent 7bb30f60b0
commit 5da31a16fe
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=65495
12 changed files with 68 additions and 166 deletions

View file

@ -6,8 +6,7 @@
#
PORTNAME= screen
PORTVERSION= 3.9.11
PORTREVISION= 1
PORTVERSION= 3.9.12
CATEGORIES= misc
MASTER_SITES= ftp://ftp.uni-erlangen.de/pub/utilities/screen/ \
${MASTER_SITE_GNU}
@ -18,4 +17,10 @@ MAINTAINER= cy@FreeBSD.org
GNU_CONFIGURE= yes
MAN1= screen.1
post-install:
@${CP} ${WRKSRC}/etc/etcscreenrc ${PREFIX}/etc/screenrc.sample
@if [ ! -f ${PREFIX}/etc/screenrc ]; then \
cp ${PREFIX}/etc/screenrc.sample ${PREFIX}/etc/screenrc ; \
fi
.include <bsd.port.mk>

View file

@ -1 +1 @@
MD5 (screen-3.9.11.tar.gz) = 19572f92404995e7b2dea8117204dd67
MD5 (screen-3.9.12.tar.gz) = a839984d0d287f9d38735b4cea3004cf

View file

@ -1,12 +0,0 @@
--- doc/screen.texinfo.orig Wed Feb 13 19:37:42 2002
+++ doc/screen.texinfo Tue Feb 19 13:20:28 2002
@@ -4,6 +4,9 @@
@setfilename screen.info
@settitle Screen User's Manual
@dircategory General Commands
+@direntry
+* Screen: (screen). Full-screen window manager.
+@end direntry
@finalout
@setchapternewpage odd
@c %**end of header

View file

@ -1,16 +1,22 @@
--- configure.orig Thu Feb 14 22:11:21 2002
+++ configure Tue Feb 19 13:26:23 2002
@@ -3502,43 +3502,6 @@
--- configure.orig Mon Aug 12 07:34:23 2002
+++ configure Mon Sep 2 07:03:25 2002
@@ -4358,49 +4358,6 @@
echo "$as_me: failed program was:" >&5
cat conftest.$ac_ext >&5
olibs="$LIBS"
-LIBS="-lcurses $olibs"
-{ echo "$as_me:3506: checking libcurses..." >&5
-{ echo "$as_me:$LINENO: checking libcurses..." >&5
-echo "$as_me: checking libcurses..." >&6;}
-cat >conftest.$ac_ext <<_ACEOF
-#line 3509 "configure"
-#line $LINENO "configure"
-#include "confdefs.h"
-
-#ifdef F77_DUMMY_MAIN
-# ifdef __cplusplus
- extern "C"
-# endif
- int F77_DUMMY_MAIN() { return 1; }
-#endif
-int
-main ()
-{
@ -26,25 +32,25 @@
-}
-_ACEOF
-rm -f conftest.$ac_objext conftest$ac_exeext
-if { (eval echo "$as_me:3527: \"$ac_link\"") >&5
-if { (eval echo "$as_me:$LINENO: \"$ac_link\"") >&5
- (eval $ac_link) 2>&5
- ac_status=$?
- echo "$as_me:3530: \$? = $ac_status" >&5
- echo "$as_me:$LINENO: \$? = $ac_status" >&5
- (exit $ac_status); } &&
- { ac_try='test -s conftest$ac_exeext'
- { (eval echo "$as_me:3533: \"$ac_try\"") >&5
- { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
- (eval $ac_try) 2>&5
- ac_status=$?
- echo "$as_me:3536: \$? = $ac_status" >&5
- echo "$as_me:$LINENO: \$? = $ac_status" >&5
- (exit $ac_status); }; }; then
- :
-else
- echo "$as_me: failed program was:" >&5
-cat conftest.$ac_ext >&5
LIBS="-ltermcap $olibs"
{ echo "$as_me:3543: checking libtermcap..." >&5
{ echo "$as_me:$LINENO: checking libtermcap..." >&5
echo "$as_me: checking libtermcap..." >&6;}
@@ -3643,8 +3606,6 @@
@@ -4523,8 +4480,6 @@
rm -f conftest.$ac_objext conftest$ac_exeext conftest.$ac_ext
fi
rm -f conftest.$ac_objext conftest$ac_exeext conftest.$ac_ext
@ -52,8 +58,8 @@
-rm -f conftest.$ac_objext conftest$ac_exeext conftest.$ac_ext
if test "$cross_compiling" = yes; then
{ { echo "$as_me:3650: error: cannot run test program while cross compiling" >&5
@@ -3657,7 +3618,7 @@
{ { echo "$as_me:$LINENO: error: cannot run test program while cross compiling" >&5
@@ -4537,7 +4492,7 @@
main()
{
@ -62,7 +68,7 @@
}
_ACEOF
rm -f conftest$ac_exeext
@@ -3861,18 +3822,15 @@
@@ -4762,18 +4717,15 @@
fi
rm -f conftest*
@ -71,17 +77,17 @@
-p1=`echo $ptys | tr ' ' '\012' | sed -e 's/^.*\(.\)$/\1/g' | sort -u | tr -d '\012'`
+# XXX: hardcoded, since port must be devfs and various setups independent
+
cat >>confdefs.h <<EOF
cat >>confdefs.h <<_ACEOF
-#define PTYRANGE0 "$p0"
+#define PTYRANGE0 "pqrsPQRS"
EOF
_ACEOF
cat >>confdefs.h <<EOF
cat >>confdefs.h <<_ACEOF
-#define PTYRANGE1 "$p1"
+#define PTYRANGE1 "0123456789abcdefghijklmnopqrstuv"
EOF
_ACEOF
-
-fi
{ echo "$as_me:3877: checking default tty permissions/group..." >&5
{ echo "$as_me:$LINENO: checking default tty permissions/group..." >&5
echo "$as_me: checking default tty permissions/group..." >&6;}

View file

@ -1,49 +0,0 @@
--- ./display.c.orig Fri Feb 22 12:56:57 2002
+++ ./display.c Fri Feb 22 13:02:10 2002
@@ -3371,7 +3371,7 @@
{
int font = 0;
j += EncodeChar(buf2 + j, c, D_forecv->c_layer->l_encoding, &font);
- j += EncodeChar(buf2 + j, 0, D_forecv->c_layer->l_encoding, &font);
+ j += EncodeChar(buf2 + j, -1, D_forecv->c_layer->l_encoding, &font);
}
else
j += EncodeChar(buf2 + j, c, D_forecv->c_layer->l_encoding, 0);
--- ./encoding.c.orig Fri Feb 22 12:57:46 2002
+++ ./encoding.c Fri Feb 22 13:01:30 2002
@@ -1032,7 +1032,7 @@
int t, f, l;
debug2("Encoding char %02x for encoding %d\n", c, encoding);
- if (c == 0 && fontp)
+ if (c == -1 && fontp)
{
if (*fontp == 0)
return 0;
@@ -1297,7 +1297,7 @@
continue;
j += EncodeChar(tbuf ? (char *)tbuf + j : 0, c, tenc, &font);
}
- j += EncodeChar(tbuf ? (char *)tbuf + j : 0, 0, tenc, &font);
+ j += EncodeChar(tbuf ? (char *)tbuf + j : 0, -1, tenc, &font);
return j;
}
@@ -1456,7 +1456,7 @@
int *fontp;
{
int f, l;
- f = c >> 16;
+ f = (c == -1) ? 0 : c >> 16;
l = 0;
if (fontp && f != *fontp)
{
@@ -1486,7 +1486,7 @@
l += 3;
}
}
- if (c == 0)
+ if (c == -1)
return l;
if (c & 0xff00)
{

View file

@ -20,3 +20,4 @@ share/screen/utf8encodings/cd
share/screen/utf8encodings/d6
@dirrm share/screen/utf8encodings
@dirrm share/screen
@unexec echo If permanently deleting this package, %%PREFIX%%/etc/screenrc must be removed manually

View file

@ -6,8 +6,7 @@
#
PORTNAME= screen
PORTVERSION= 3.9.11
PORTREVISION= 1
PORTVERSION= 3.9.12
CATEGORIES= misc
MASTER_SITES= ftp://ftp.uni-erlangen.de/pub/utilities/screen/ \
${MASTER_SITE_GNU}
@ -18,4 +17,10 @@ MAINTAINER= cy@FreeBSD.org
GNU_CONFIGURE= yes
MAN1= screen.1
post-install:
@${CP} ${WRKSRC}/etc/etcscreenrc ${PREFIX}/etc/screenrc.sample
@if [ ! -f ${PREFIX}/etc/screenrc ]; then \
cp ${PREFIX}/etc/screenrc.sample ${PREFIX}/etc/screenrc ; \
fi
.include <bsd.port.mk>

View file

@ -1 +1 @@
MD5 (screen-3.9.11.tar.gz) = 19572f92404995e7b2dea8117204dd67
MD5 (screen-3.9.12.tar.gz) = a839984d0d287f9d38735b4cea3004cf

View file

@ -1,12 +0,0 @@
--- doc/screen.texinfo.orig Wed Feb 13 19:37:42 2002
+++ doc/screen.texinfo Tue Feb 19 13:20:28 2002
@@ -4,6 +4,9 @@
@setfilename screen.info
@settitle Screen User's Manual
@dircategory General Commands
+@direntry
+* Screen: (screen). Full-screen window manager.
+@end direntry
@finalout
@setchapternewpage odd
@c %**end of header

View file

@ -1,16 +1,22 @@
--- configure.orig Thu Feb 14 22:11:21 2002
+++ configure Tue Feb 19 13:26:23 2002
@@ -3502,43 +3502,6 @@
--- configure.orig Mon Aug 12 07:34:23 2002
+++ configure Mon Sep 2 07:03:25 2002
@@ -4358,49 +4358,6 @@
echo "$as_me: failed program was:" >&5
cat conftest.$ac_ext >&5
olibs="$LIBS"
-LIBS="-lcurses $olibs"
-{ echo "$as_me:3506: checking libcurses..." >&5
-{ echo "$as_me:$LINENO: checking libcurses..." >&5
-echo "$as_me: checking libcurses..." >&6;}
-cat >conftest.$ac_ext <<_ACEOF
-#line 3509 "configure"
-#line $LINENO "configure"
-#include "confdefs.h"
-
-#ifdef F77_DUMMY_MAIN
-# ifdef __cplusplus
- extern "C"
-# endif
- int F77_DUMMY_MAIN() { return 1; }
-#endif
-int
-main ()
-{
@ -26,25 +32,25 @@
-}
-_ACEOF
-rm -f conftest.$ac_objext conftest$ac_exeext
-if { (eval echo "$as_me:3527: \"$ac_link\"") >&5
-if { (eval echo "$as_me:$LINENO: \"$ac_link\"") >&5
- (eval $ac_link) 2>&5
- ac_status=$?
- echo "$as_me:3530: \$? = $ac_status" >&5
- echo "$as_me:$LINENO: \$? = $ac_status" >&5
- (exit $ac_status); } &&
- { ac_try='test -s conftest$ac_exeext'
- { (eval echo "$as_me:3533: \"$ac_try\"") >&5
- { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
- (eval $ac_try) 2>&5
- ac_status=$?
- echo "$as_me:3536: \$? = $ac_status" >&5
- echo "$as_me:$LINENO: \$? = $ac_status" >&5
- (exit $ac_status); }; }; then
- :
-else
- echo "$as_me: failed program was:" >&5
-cat conftest.$ac_ext >&5
LIBS="-ltermcap $olibs"
{ echo "$as_me:3543: checking libtermcap..." >&5
{ echo "$as_me:$LINENO: checking libtermcap..." >&5
echo "$as_me: checking libtermcap..." >&6;}
@@ -3643,8 +3606,6 @@
@@ -4523,8 +4480,6 @@
rm -f conftest.$ac_objext conftest$ac_exeext conftest.$ac_ext
fi
rm -f conftest.$ac_objext conftest$ac_exeext conftest.$ac_ext
@ -52,8 +58,8 @@
-rm -f conftest.$ac_objext conftest$ac_exeext conftest.$ac_ext
if test "$cross_compiling" = yes; then
{ { echo "$as_me:3650: error: cannot run test program while cross compiling" >&5
@@ -3657,7 +3618,7 @@
{ { echo "$as_me:$LINENO: error: cannot run test program while cross compiling" >&5
@@ -4537,7 +4492,7 @@
main()
{
@ -62,7 +68,7 @@
}
_ACEOF
rm -f conftest$ac_exeext
@@ -3861,18 +3822,15 @@
@@ -4762,18 +4717,15 @@
fi
rm -f conftest*
@ -71,17 +77,17 @@
-p1=`echo $ptys | tr ' ' '\012' | sed -e 's/^.*\(.\)$/\1/g' | sort -u | tr -d '\012'`
+# XXX: hardcoded, since port must be devfs and various setups independent
+
cat >>confdefs.h <<EOF
cat >>confdefs.h <<_ACEOF
-#define PTYRANGE0 "$p0"
+#define PTYRANGE0 "pqrsPQRS"
EOF
_ACEOF
cat >>confdefs.h <<EOF
cat >>confdefs.h <<_ACEOF
-#define PTYRANGE1 "$p1"
+#define PTYRANGE1 "0123456789abcdefghijklmnopqrstuv"
EOF
_ACEOF
-
-fi
{ echo "$as_me:3877: checking default tty permissions/group..." >&5
{ echo "$as_me:$LINENO: checking default tty permissions/group..." >&5
echo "$as_me: checking default tty permissions/group..." >&6;}

View file

@ -1,49 +0,0 @@
--- ./display.c.orig Fri Feb 22 12:56:57 2002
+++ ./display.c Fri Feb 22 13:02:10 2002
@@ -3371,7 +3371,7 @@
{
int font = 0;
j += EncodeChar(buf2 + j, c, D_forecv->c_layer->l_encoding, &font);
- j += EncodeChar(buf2 + j, 0, D_forecv->c_layer->l_encoding, &font);
+ j += EncodeChar(buf2 + j, -1, D_forecv->c_layer->l_encoding, &font);
}
else
j += EncodeChar(buf2 + j, c, D_forecv->c_layer->l_encoding, 0);
--- ./encoding.c.orig Fri Feb 22 12:57:46 2002
+++ ./encoding.c Fri Feb 22 13:01:30 2002
@@ -1032,7 +1032,7 @@
int t, f, l;
debug2("Encoding char %02x for encoding %d\n", c, encoding);
- if (c == 0 && fontp)
+ if (c == -1 && fontp)
{
if (*fontp == 0)
return 0;
@@ -1297,7 +1297,7 @@
continue;
j += EncodeChar(tbuf ? (char *)tbuf + j : 0, c, tenc, &font);
}
- j += EncodeChar(tbuf ? (char *)tbuf + j : 0, 0, tenc, &font);
+ j += EncodeChar(tbuf ? (char *)tbuf + j : 0, -1, tenc, &font);
return j;
}
@@ -1456,7 +1456,7 @@
int *fontp;
{
int f, l;
- f = c >> 16;
+ f = (c == -1) ? 0 : c >> 16;
l = 0;
if (fontp && f != *fontp)
{
@@ -1486,7 +1486,7 @@
l += 3;
}
}
- if (c == 0)
+ if (c == -1)
return l;
if (c & 0xff00)
{

View file

@ -20,3 +20,4 @@ share/screen/utf8encodings/cd
share/screen/utf8encodings/d6
@dirrm share/screen/utf8encodings
@dirrm share/screen
@unexec echo If permanently deleting this package, %%PREFIX%%/etc/screenrc must be removed manually