- Update to 1.0.11

- No more BROKEN
- Support STAGE

PR:		ports/184144
Submitted by:	"Charlie &" <root@portaone.com>
Approved by:	maintainer
This commit is contained in:
Philippe Audeoud 2013-11-22 10:00:08 +00:00
parent 85871aa2c3
commit 5de21b0fe9
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=334566
5 changed files with 23 additions and 29 deletions

View file

@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= isomd5sum
PORTVERSION= 1.0.9
PORTVERSION= 1.0.11
PORTREVISION= 1
CATEGORIES= sysutils
MASTER_SITES= http://git.fedorahosted.org/cgit/isomd5sum.git/snapshot/
@ -12,16 +12,12 @@ COMMENT= Implanting and checking checksums within an ISO9660 image
LICENSE= GPLv2
LIB_DEPENDS= popt.0:${PORTSDIR}/devel/popt
LIB_DEPENDS= popt:${PORTSDIR}/devel/popt
BROKEN= Unfetchable due to checksum mismatch
USES= gmake
USE_BZIP2= yes
USE_PYTHON= yes
MAN1= implantisomd5.1 checkisomd5.1
MAKE_ENV+= PYTHONPREFIX_SITELIBDIR=${PYTHONPREFIX_SITELIBDIR} PYTHON_INCLUDEDIR=${PYTHON_INCLUDEDIR}
NO_STAGE= yes
.include <bsd.port.mk>

View file

@ -1,2 +1,2 @@
SHA256 (isomd5sum-1.0.9.tar.bz2) = 307736e466a84bcf15a34af301d93cba5fcb23f8bd75624dbabdf75d37eeec8d
SIZE (isomd5sum-1.0.9.tar.bz2) = 18143
SHA256 (isomd5sum-1.0.11.tar.bz2) = f37a2ed2a4cd9ac518627d73165c3ca103d09a84986b57fee5865c5aa792c6fe
SIZE (isomd5sum-1.0.11.tar.bz2) = 18120

View file

@ -1,17 +1,17 @@
--- ./Makefile.orig 2012-03-09 21:51:31.000000000 +0200
+++ ./Makefile 2012-10-10 06:07:15.000000000 +0300
--- ./Makefile.orig 2013-07-17 21:42:23.000000000 +0000
+++ ./Makefile 2013-11-21 15:37:41.000000000 +0000
@@ -1,16 +1,16 @@
PYVER := $(shell python -c 'import sys; print sys.version[0:3]')
PYTHON = python$(PYVER)
-PYTHONINCLUDE = /usr/include/$(PYTHON)
+PYTHONINCLUDE = ${PYTHON_INCLUDEDIR}
VERSION=1.0.9
VERSION=1.0.11
-ifneq (,$(filter sparc64 ppc64 x86_64 s390x,$(shell uname -m)))
-ifneq (,$(filter sparc64 ppc64 x86_64 s390x aarch64,$(shell uname -m)))
-LIBDIR = lib64
-else
+#ifneq (,$(filter sparc64 ppc64 x86_64 s390x,$(shell uname -m)))
+#ifneq (,$(filter sparc64 ppc64 x86_64 s390x aarch64,$(shell uname -m)))
+#LIBDIR = lib64
+#else
LIBDIR = lib
@ -23,20 +23,25 @@
OBJECTS = md5.o libimplantisomd5.o checkisomd5.o implantisomd5
SOURCES = $(patsubst %.o,%.c,$(OBJECTS))
@@ -24,10 +24,10 @@
$(CC) -c -O $(CFLAGS) -o $@ $<
@@ -24,39 +24,39 @@
$(CC) $(CPPFLAGS) $(CFLAGS) -c -O -o $@ $<
implantisomd5: implantisomd5.o libimplantisomd5.a
- $(CC) $(CFLAGS) implantisomd5.o libimplantisomd5.a -lpopt -o implantisomd5
+ $(CC) $(CFLAGS) -L${LOCALBASE}/lib implantisomd5.o libimplantisomd5.a -lpopt -o implantisomd5
- $(CC) $(CPPFLAGS) $(CFLAGS) implantisomd5.o libimplantisomd5.a -lpopt $(LDFLAGS) -o implantisomd5
+ $(CC) $(CPPFLAGS) $(CFLAGS) -L${LOCALBASE}/lib implantisomd5.o libimplantisomd5.a -lpopt $(LDFLAGS) -o implantisomd5
checkisomd5: checkisomd5.o libcheckisomd5.a
- $(CC) $(CFLAGS) checkisomd5.o libcheckisomd5.a -lpopt -o checkisomd5
+ $(CC) $(CFLAGS) -L${LOCALBASE}/lib checkisomd5.o libcheckisomd5.a -lpopt -o checkisomd5
- $(CC) $(CPPFLAGS) $(CFLAGS) checkisomd5.o libcheckisomd5.a -lpopt $(LDFLAGS) -o checkisomd5
+ $(CC) $(CPPFLAGS) $(CFLAGS) -L${LOCALBASE}/lib checkisomd5.o libcheckisomd5.a -lpopt $(LDFLAGS) -o checkisomd5
libimplantisomd5.a: libimplantisomd5.a(libimplantisomd5.o md5.o)
@@ -39,24 +39,24 @@
libcheckisomd5.a: libcheckisomd5.a(libcheckisomd5.o md5.o)
pyisomd5sum.so: $(PYOBJS)
- $(CC) $(CPPFLAGS) $(CFLAGS) -shared -g -fpic $(PYOBJS) $(LDFLAGS) -o pyisomd5sum.so
+ $(CC) $(CPPFLAGS) $(CFLAGS) -shared -fpic $(PYOBJS) $(LDFLAGS) -o pyisomd5sum.so
install: all install-bin install-python install-devel
install-bin:

View file

@ -17,12 +17,3 @@
static void byteReverse(unsigned char *buf, unsigned longs);
@@ -157,7 +157,7 @@
MD5_Transform(ctx->buf, (uint32 *) ctx->in);
if (ctx->doByteReverse) byteReverse((unsigned char *) ctx->buf, 4);
memcpy(digest, ctx->buf, 16);
- memset(ctx, 0, sizeof(ctx)); /* In case it's sensitive */
+ memset(ctx, 0, sizeof(*ctx)); /* In case it's sensitive */
}
#ifndef ASM_MD5

View file

@ -1,5 +1,7 @@
bin/implantisomd5
bin/checkisomd5
man/man1/checkisomd5.1.gz
man/man1/implantisomd5.1.gz
include/libimplantisomd5.h
include/libcheckisomd5.h
lib/libimplantisomd5.a