devel/py-colorama: Fix build with Python 3.6
* Backport PR #294 [1] from upstream repository to enable default UTF-8 encoding in setup.py which fixes the build issue with Python 3.6. PR: 252294, 251240 [2] Submitted by: John W. O'Brien [1] Reported by: Dani <i.dani@outlook.com> [2] Reviewed by: koobs, ygy Approved by: portmgr (blanket: build fix)
This commit is contained in:
parent
856b6f6463
commit
5de5b6a46a
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=559722
1 changed files with 26 additions and 0 deletions
26
devel/py-colorama/files/patch-setup.py
Normal file
26
devel/py-colorama/files/patch-setup.py
Normal file
|
@ -0,0 +1,26 @@
|
|||
Default to UTF-8 encoding to fix build with Python 3.6
|
||||
|
||||
Obtained from: https://github.com/tartley/colorama/pull/294/files
|
||||
|
||||
--- setup.py.orig 2020-10-12 21:22:32 UTC
|
||||
+++ setup.py
|
||||
@@ -3,6 +3,7 @@
|
||||
|
||||
from __future__ import with_statement
|
||||
|
||||
+from io import open
|
||||
import os
|
||||
import re
|
||||
try:
|
||||
@@ -14,8 +15,9 @@ except ImportError:
|
||||
NAME = 'colorama'
|
||||
|
||||
|
||||
-def read_file(path):
|
||||
- with open(os.path.join(os.path.dirname(__file__), path)) as fp:
|
||||
+def read_file(path, encoding='utf8'):
|
||||
+ with open(os.path.join(os.path.dirname(__file__), path),
|
||||
+ encoding=encoding) as fp:
|
||||
return fp.read()
|
||||
|
||||
def _get_version_match(content):
|
Loading…
Reference in a new issue