Update to SDL 1.1 (repo-copy from devel/sdl to devel/sdl-devel).

PR:		18188
Submitted by:	maintainer
This commit is contained in:
Will Andrews 2000-04-25 12:43:35 +00:00
parent 1aceb77cc6
commit 5e04d9a046
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=27993
20 changed files with 502 additions and 258 deletions

View file

@ -1,38 +1,56 @@
# New ports collection makefile for: SDL
# Date created: 8 August 1999
# Whom: Andrey Zakhvatov
# Date created: 1 April 2000
# Whom: Maxim Sobolev <sobomax@altavista.net>
#
# $FreeBSD$
#
PORTNAME= sdl
PORTVERSION= 1.0.8
PORTNAME= sdl-devel
PORTVERSION= 1.1.2
CATEGORIES= devel
MASTER_SITES= http://www.devolution.com/~slouken/SDL/release/
DISTNAME= SDL-${PORTVERSION}
MAINTAINER= sobomax@altavista.net
LIB_DEPENDS= esd.2:${PORTSDIR}/audio/esound
LIB_DEPENDS= esd.2:${PORTSDIR}/audio/esound \
aa.1:${PORTSDIR}/graphics/aalib \
${GL_DEPENDS}
BUILD_DEPENDS= nasm:${PORTSDIR}/devel/nasm
USE_GMAKE= yes
USE_XLIB= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= NASM="${LOCALBASE}/bin/nasm" \
LOCALBASE="${LOCALBASE}"
CONFIGURE_ARGS= --enable-video-aalib
CFLAGS+= -D_THREAD_SAFE
.if defined(WITHOUT_GL)
GL_DEPENDS=
CONFIGURE_ARGS+= --disable-video-opengl
.else
GL_DEPENDS= MesaGL.14:${PORTSDIR}/graphics/Mesa3
CONFIGURE_ARGS+= --enable-video-opengl
.endif
post-configure:
@ cd ${WRKSRC} && \
${CP} sdl-config sdl11-config && \
${CP} sdl.m4 sdl11.m4
post-install:
@ ${MKDIR} ${PREFIX}/share/examples/SDL
@ ${INSTALL_DATA} ${WRKSRC}/test/* ${PREFIX}/share/examples/SDL
@ ${MKDIR} ${PREFIX}/share/examples/SDL11
@ ${INSTALL_DATA} ${WRKSRC}/test/* ${PREFIX}/share/examples/SDL11
.if !defined(NOPORTDOCS)
@ ${MKDIR} ${PREFIX}/share/doc/SDL
@ ${MKDIR} ${PREFIX}/share/doc/SDL11
.for file in BUGS COPYING CREDITS README WhatsNew docs.html
@ ${INSTALL_DATA} ${WRKSRC}/${file} ${PREFIX}/share/doc/SDL
@ ${INSTALL_DATA} ${WRKSRC}/${file} ${PREFIX}/share/doc/SDL11
.endfor
@ cd ${WRKSRC}/docs; tar cf - `${ECHO} [^M]*` | \
(cd ${PREFIX}/share/doc/SDL; ${TAR} --unlink -xf - )
(cd ${PREFIX}/share/doc/SDL11; ${TAR} --unlink -xf - )
.endif
.include <bsd.port.mk>

View file

@ -1 +1 @@
MD5 (SDL-1.0.8.tar.gz) = c58bcf59d41181c492a06cd10ce97a6a
MD5 (SDL-1.1.2.tar.gz) = 702a695e74d2e83215b7235bf6ebcd64

View file

@ -1,6 +1,6 @@
--- configure.orig Sat Mar 4 04:58:00 2000
+++ configure Mon Mar 6 13:40:33 2000
@@ -604,9 +604,9 @@
--- configure.orig Fri Mar 31 08:26:24 2000
+++ configure Mon Apr 24 02:09:39 2000
@@ -610,9 +610,9 @@
# libtool versioning
LT_RELEASE=$SDL_MAJOR_VERSION.$SDL_MINOR_VERSION
@ -12,7 +12,25 @@
@@ -4324,7 +4324,7 @@
@@ -2907,7 +2907,7 @@
SDL_CFLAGS=""
-SDL_LIBS="-lSDL"
+SDL_LIBS="-lSDL-1.1"
# Check whether --enable-audio or --disable-audio was given.
@@ -4616,7 +4616,7 @@
echo "$ac_t""$video_opengl" 1>&6
if test x$video_opengl = xyes; then
CFLAGS="$CFLAGS -DHAVE_OPENGL"
- SYSTEM_LIBS="$SYSTEM_LIBS -ldl"
+ SYSTEM_LIBS="$SYSTEM_LIBS"
fi
fi
}
@@ -4649,7 +4649,7 @@
ac_save_libs="$LIBS"
case "$target" in
*-*-freebsd*)
@ -21,20 +39,20 @@
;;
*-*-openbsd*)
pthread_lib="-lc_r"
@@ -4364,7 +4364,7 @@
@@ -4689,7 +4689,7 @@
echo "$ac_t""$use_pthreads" 1>&6
if test x$use_pthreads = xyes; then
CFLAGS="$CFLAGS -D_REENTRANT -DSDL_USE_PTHREADS"
- SDL_CFLAGS="$SDL_CFLAGS -D_REENTRANT"
+ SDL_CFLAGS="$SDL_CFLAGS -D_REENTRANT -D_THREAD_SAFE"
SDL_LIBS="$SDL_LIBS $pthread_lib"
fi
fi
@@ -4953,6 +4953,7 @@
echo $ac_n "checking whether semun is defined in /usr/include/sys/sem.h""... $ac_c" 1>&6
echo "configure:4696: checking whether semun is defined in /usr/include/sys/sem.h" >&5
@@ -5356,6 +5356,7 @@
;;
*-*-freebsd*)
ARCH=freebsd
+ CheckNASM
CheckESD
CheckX11
CheckPTHREAD
CheckAAlib

View file

@ -0,0 +1,26 @@
--- src/main/Makefile.in.orig Sun Apr 23 22:37:43 2000
+++ src/main/Makefile.in Sun Apr 23 22:45:12 2000
@@ -109,7 +109,7 @@
ARCH_SUBDIRS = beos linux macos win32
# Build a separate library containing the main() entry point.
-lib_LIBRARIES = libSDLmain.a
+lib_LIBRARIES = libSDLmain-1.1.a
MAINLIB_ARCH_SRCS = SDL_main.c
@@ -257,10 +257,10 @@
maintainer-clean-libtool:
-libSDLmain.a: $(libSDLmain_a_OBJECTS) $(libSDLmain_a_DEPENDENCIES)
- -rm -f libSDLmain.a
- $(AR) cru libSDLmain.a $(libSDLmain_a_OBJECTS) $(libSDLmain_a_LIBADD)
- $(RANLIB) libSDLmain.a
+libSDLmain-1.1.a: $(libSDLmain_a_OBJECTS) $(libSDLmain_a_DEPENDENCIES)
+ -rm -f libSDLmain-1.1.a
+ $(AR) cru libSDLmain-1.1.a $(libSDLmain_a_OBJECTS) $(libSDLmain_a_LIBADD)
+ $(RANLIB) libSDLmain-1.1.a
mostlyclean-noinstLTLIBRARIES:

View file

@ -0,0 +1,11 @@
--- include/Makefile.in.orig Sun Apr 23 22:34:25 2000
+++ include/Makefile.in Sun Apr 23 22:34:43 2000
@@ -106,7 +106,7 @@
with_gcc = @with_gcc@
with_gnu_ld = @with_gnu_ld@
-libSDLincludedir = $(includedir)/SDL
+libSDLincludedir = $(includedir)/SDL11
# Which header files to install
libSDLinclude_HEADERS = SDL.h SDL_active.h SDL_audio.h SDL_byteorder.h SDL_cdrom.h SDL_copying.h SDL_endian.h SDL_error.h SDL_events.h SDL_joystick.h SDL_keyboard.h SDL_keysym.h SDL_main.h SDL_mouse.h SDL_mutex.h SDL_quit.h SDL_rwops.h SDL_syswm.h SDL_thread.h SDL_timer.h SDL_types.h SDL_version.h SDL_video.h begin_code.h close_code.h

View file

@ -0,0 +1,20 @@
--- Makefile.in.orig Fri Mar 31 08:31:12 2000
+++ Makefile.in Mon Apr 24 00:29:07 2000
@@ -113,7 +113,7 @@
DIST_SUBDIRS = $(SUBDIRS) docs
# SDL runtime configuration script
-bin_SCRIPTS = sdl-config
+bin_SCRIPTS = sdl11-config
# All the rest of the distributed files
EXTRA_DIST = BUGS COPYING CREDITS INSTALL README README-SDL.txt README.Win32 README.MacOS VisualC.html VisualC.zip CWprojects.sea.hqx MPWmake.sea.hqx WhatsNew docs.html sdl.m4 autogen.sh strip_fPIC.sh
@@ -121,7 +121,7 @@
# M4 macro file for inclusion with autoconf
m4datadir = $(datadir)/aclocal
-m4data_DATA = sdl.m4
+m4data_DATA = sdl11.m4
# Create a CVS snapshot that people can run update -d on
CVSROOT = :pserver:guest@cvs.lokigames.com:/cvs

View file

@ -0,0 +1,20 @@
--- sdl-config.in.orig Sun Apr 23 22:23:24 2000
+++ sdl-config.in Sun Apr 23 22:24:14 2000
@@ -5,7 +5,7 @@
exec_prefix_set=no
usage="\
-Usage: sdl-config [--prefix[=DIR]] [--exec-prefix[=DIR]] [--version] [--libs] [--cflags]"
+Usage: sdl11-config [--prefix[=DIR]] [--exec-prefix[=DIR]] [--version] [--libs] [--cflags]"
if test $# -eq 0; then
echo "${usage}" 1>&2
@@ -42,7 +42,7 @@
if test @includedir@ != /usr/include ; then
includes=-I@includedir@
fi
- echo $includes -I@includedir@/SDL @SDL_CFLAGS@
+ echo $includes -I@includedir@/SDL11 @SDL_CFLAGS@
;;
--libs)
if [ "`uname`" = "SunOS" ]; then

View file

@ -1 +1 @@
Cross-platform multi-media development API
Cross-platform multi-media development API (developm. vers.)

View file

@ -1,3 +1,5 @@
Unstable development version of the SDL library.
This library is designed to make it easy to write games that run on UNIX,
Win32 and BeOS using the various native high-performance media interfaces,
(for video, audio, etc) and presenting a single source-code level API to

View file

@ -1,110 +1,117 @@
bin/sdl-config
include/SDL/SDL.h
include/SDL/SDL_active.h
include/SDL/SDL_audio.h
include/SDL/SDL_byteorder.h
include/SDL/SDL_cdrom.h
include/SDL/SDL_copying.h
include/SDL/SDL_endian.h
include/SDL/SDL_error.h
include/SDL/SDL_events.h
include/SDL/SDL_keyboard.h
include/SDL/SDL_keysym.h
include/SDL/SDL_main.h
include/SDL/SDL_mouse.h
include/SDL/SDL_mutex.h
include/SDL/SDL_quit.h
include/SDL/SDL_rwops.h
include/SDL/SDL_syswm.h
include/SDL/SDL_thread.h
include/SDL/SDL_timer.h
include/SDL/SDL_types.h
include/SDL/SDL_version.h
include/SDL/SDL_video.h
include/SDL/begin_code.h
include/SDL/close_code.h
lib/libSDL-1.0.so
lib/libSDL-1.0.so.2
lib/libSDL.a
lib/libSDL.la
lib/libSDL.so
lib/libSDLmain.a
bin/sdl11-config
include/SDL11/SDL.h
include/SDL11/SDL_active.h
include/SDL11/SDL_audio.h
include/SDL11/SDL_byteorder.h
include/SDL11/SDL_cdrom.h
include/SDL11/SDL_copying.h
include/SDL11/SDL_endian.h
include/SDL11/SDL_error.h
include/SDL11/SDL_events.h
include/SDL11/SDL_joystick.h
include/SDL11/SDL_keyboard.h
include/SDL11/SDL_keysym.h
include/SDL11/SDL_main.h
include/SDL11/SDL_mouse.h
include/SDL11/SDL_mutex.h
include/SDL11/SDL_quit.h
include/SDL11/SDL_rwops.h
include/SDL11/SDL_syswm.h
include/SDL11/SDL_thread.h
include/SDL11/SDL_timer.h
include/SDL11/SDL_types.h
include/SDL11/SDL_version.h
include/SDL11/SDL_video.h
include/SDL11/begin_code.h
include/SDL11/close_code.h
lib/libSDL-1.1.so.2
lib/libSDL-1.1.a
lib/libSDL-1.1.la
lib/libSDL-1.1.so
lib/libSDLmain-1.1.a
@exec /sbin/ldconfig -m %B
@unexec /sbin/ldconfig -R
share/aclocal/sdl.m4
share/doc/SDL/BUGS
share/doc/SDL/COPYING
share/doc/SDL/CREDITS
share/doc/SDL/README
share/doc/SDL/WhatsNew
share/doc/SDL/audio/examples.html
share/doc/SDL/audio/funclist.html
share/doc/SDL/audio/functions.html
share/doc/SDL/audio/index.html
share/doc/SDL/cdrom/examples.html
share/doc/SDL/cdrom/funclist.html
share/doc/SDL/cdrom/functions.html
share/doc/SDL/cdrom/index.html
share/doc/SDL/docs.html
share/doc/SDL/events/examples.html
share/doc/SDL/events/functions.html
share/doc/SDL/events/index.html
share/doc/SDL/events/keysym.html
share/doc/SDL/images/rainbow.gif
share/doc/SDL/index.html
share/doc/SDL/threads/index.html
share/doc/SDL/time/examples.html
share/doc/SDL/time/funclist.html
share/doc/SDL/time/functions.html
share/doc/SDL/time/index.html
share/doc/SDL/video/examples.html
share/doc/SDL/video/funclist.html
share/doc/SDL/video/functions.html
share/doc/SDL/video/index.html
share/examples/SDL/COPYING
share/examples/SDL/Makefile.am
share/examples/SDL/Makefile.in
share/examples/SDL/README
share/examples/SDL/acinclude.m4
share/examples/SDL/aclocal.m4
share/examples/SDL/autogen.sh
share/examples/SDL/checkkeys.c
share/examples/SDL/config.guess
share/examples/SDL/config.sub
share/examples/SDL/configure
share/examples/SDL/configure.in
share/examples/SDL/graywin.c
share/examples/SDL/icon.bmp
share/examples/SDL/install-sh
share/examples/SDL/loopwave.c
share/examples/SDL/missing
share/examples/SDL/mkinstalldirs
share/examples/SDL/picture.xbm
share/examples/SDL/sample.bmp
share/examples/SDL/sample.wav
share/examples/SDL/testalpha.c
share/examples/SDL/testbitmap.c
share/examples/SDL/testcdrom.c
share/examples/SDL/testerror.c
share/examples/SDL/testhread.c
share/examples/SDL/testkeys.c
share/examples/SDL/testlock.c
share/examples/SDL/testsprite.c
share/examples/SDL/testtimer.c
share/examples/SDL/testtypes.c
share/examples/SDL/testver.c
share/examples/SDL/testvidinfo.c
share/examples/SDL/testwin.c
share/examples/SDL/testwm.c
share/examples/SDL/threadwin.c
@dirrm share/examples/SDL
@dirrm share/doc/SDL/video
@dirrm share/doc/SDL/time
@dirrm share/doc/SDL/threads
@dirrm share/doc/SDL/opengl
@dirrm share/doc/SDL/images
@dirrm share/doc/SDL/events
@dirrm share/doc/SDL/cdrom
@dirrm share/doc/SDL/audio
@dirrm share/doc/SDL
@dirrm include/SDL
share/aclocal/sdl11.m4
share/doc/SDL11/BUGS
share/doc/SDL11/COPYING
share/doc/SDL11/CREDITS
share/doc/SDL11/README
share/doc/SDL11/WhatsNew
share/doc/SDL11/audio/examples.html
share/doc/SDL11/audio/funclist.html
share/doc/SDL11/audio/functions.html
share/doc/SDL11/audio/index.html
share/doc/SDL11/cdrom/examples.html
share/doc/SDL11/cdrom/funclist.html
share/doc/SDL11/cdrom/functions.html
share/doc/SDL11/cdrom/index.html
share/doc/SDL11/docs.html
share/doc/SDL11/events/examples.html
share/doc/SDL11/events/functions.html
share/doc/SDL11/events/index.html
share/doc/SDL11/events/keysym.html
share/doc/SDL11/images/rainbow.gif
share/doc/SDL11/index.html
share/doc/SDL11/opengl/examples.html
share/doc/SDL11/opengl/funclist.html
share/doc/SDL11/opengl/functions.html
share/doc/SDL11/opengl/index.html
share/doc/SDL11/threads/index.html
share/doc/SDL11/time/examples.html
share/doc/SDL11/time/funclist.html
share/doc/SDL11/time/functions.html
share/doc/SDL11/time/index.html
share/doc/SDL11/video/examples.html
share/doc/SDL11/video/funclist.html
share/doc/SDL11/video/functions.html
share/doc/SDL11/video/index.html
share/examples/SDL11/COPYING
share/examples/SDL11/Makefile.am
share/examples/SDL11/Makefile.in
share/examples/SDL11/README
share/examples/SDL11/acinclude.m4
share/examples/SDL11/aclocal.m4
share/examples/SDL11/autogen.sh
share/examples/SDL11/checkkeys.c
share/examples/SDL11/config.guess
share/examples/SDL11/config.sub
share/examples/SDL11/configure
share/examples/SDL11/configure.in
share/examples/SDL11/graywin.c
share/examples/SDL11/icon.bmp
share/examples/SDL11/install-sh
share/examples/SDL11/loopwave.c
share/examples/SDL11/missing
share/examples/SDL11/mkinstalldirs
share/examples/SDL11/picture.xbm
share/examples/SDL11/sample.bmp
share/examples/SDL11/sample.wav
share/examples/SDL11/testalpha.c
share/examples/SDL11/testbitmap.c
share/examples/SDL11/testcdrom.c
share/examples/SDL11/testerror.c
share/examples/SDL11/testgl.c
share/examples/SDL11/testhread.c
share/examples/SDL11/testjoystick.c
share/examples/SDL11/testkeys.c
share/examples/SDL11/testlock.c
share/examples/SDL11/testsprite.c
share/examples/SDL11/testtimer.c
share/examples/SDL11/testtypes.c
share/examples/SDL11/testver.c
share/examples/SDL11/testvidinfo.c
share/examples/SDL11/testwin.c
share/examples/SDL11/testwm.c
share/examples/SDL11/torturethread.c
share/examples/SDL11/threadwin.c
@dirrm share/examples/SDL11
@dirrm share/doc/SDL11/video
@dirrm share/doc/SDL11/time
@dirrm share/doc/SDL11/threads
@dirrm share/doc/SDL11/opengl
@dirrm share/doc/SDL11/images
@dirrm share/doc/SDL11/events
@dirrm share/doc/SDL11/cdrom
@dirrm share/doc/SDL11/audio
@dirrm share/doc/SDL11
@dirrm include/SDL11

View file

@ -1,38 +1,56 @@
# New ports collection makefile for: SDL
# Date created: 8 August 1999
# Whom: Andrey Zakhvatov
# Date created: 1 April 2000
# Whom: Maxim Sobolev <sobomax@altavista.net>
#
# $FreeBSD$
#
PORTNAME= sdl
PORTVERSION= 1.0.8
PORTNAME= sdl-devel
PORTVERSION= 1.1.2
CATEGORIES= devel
MASTER_SITES= http://www.devolution.com/~slouken/SDL/release/
DISTNAME= SDL-${PORTVERSION}
MAINTAINER= sobomax@altavista.net
LIB_DEPENDS= esd.2:${PORTSDIR}/audio/esound
LIB_DEPENDS= esd.2:${PORTSDIR}/audio/esound \
aa.1:${PORTSDIR}/graphics/aalib \
${GL_DEPENDS}
BUILD_DEPENDS= nasm:${PORTSDIR}/devel/nasm
USE_GMAKE= yes
USE_XLIB= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= NASM="${LOCALBASE}/bin/nasm" \
LOCALBASE="${LOCALBASE}"
CONFIGURE_ARGS= --enable-video-aalib
CFLAGS+= -D_THREAD_SAFE
.if defined(WITHOUT_GL)
GL_DEPENDS=
CONFIGURE_ARGS+= --disable-video-opengl
.else
GL_DEPENDS= MesaGL.14:${PORTSDIR}/graphics/Mesa3
CONFIGURE_ARGS+= --enable-video-opengl
.endif
post-configure:
@ cd ${WRKSRC} && \
${CP} sdl-config sdl11-config && \
${CP} sdl.m4 sdl11.m4
post-install:
@ ${MKDIR} ${PREFIX}/share/examples/SDL
@ ${INSTALL_DATA} ${WRKSRC}/test/* ${PREFIX}/share/examples/SDL
@ ${MKDIR} ${PREFIX}/share/examples/SDL11
@ ${INSTALL_DATA} ${WRKSRC}/test/* ${PREFIX}/share/examples/SDL11
.if !defined(NOPORTDOCS)
@ ${MKDIR} ${PREFIX}/share/doc/SDL
@ ${MKDIR} ${PREFIX}/share/doc/SDL11
.for file in BUGS COPYING CREDITS README WhatsNew docs.html
@ ${INSTALL_DATA} ${WRKSRC}/${file} ${PREFIX}/share/doc/SDL
@ ${INSTALL_DATA} ${WRKSRC}/${file} ${PREFIX}/share/doc/SDL11
.endfor
@ cd ${WRKSRC}/docs; tar cf - `${ECHO} [^M]*` | \
(cd ${PREFIX}/share/doc/SDL; ${TAR} --unlink -xf - )
(cd ${PREFIX}/share/doc/SDL11; ${TAR} --unlink -xf - )
.endif
.include <bsd.port.mk>

View file

@ -1 +1 @@
MD5 (SDL-1.0.8.tar.gz) = c58bcf59d41181c492a06cd10ce97a6a
MD5 (SDL-1.1.2.tar.gz) = 702a695e74d2e83215b7235bf6ebcd64

View file

@ -1,6 +1,6 @@
--- configure.orig Sat Mar 4 04:58:00 2000
+++ configure Mon Mar 6 13:40:33 2000
@@ -604,9 +604,9 @@
--- configure.orig Fri Mar 31 08:26:24 2000
+++ configure Mon Apr 24 02:09:39 2000
@@ -610,9 +610,9 @@
# libtool versioning
LT_RELEASE=$SDL_MAJOR_VERSION.$SDL_MINOR_VERSION
@ -12,7 +12,25 @@
@@ -4324,7 +4324,7 @@
@@ -2907,7 +2907,7 @@
SDL_CFLAGS=""
-SDL_LIBS="-lSDL"
+SDL_LIBS="-lSDL-1.1"
# Check whether --enable-audio or --disable-audio was given.
@@ -4616,7 +4616,7 @@
echo "$ac_t""$video_opengl" 1>&6
if test x$video_opengl = xyes; then
CFLAGS="$CFLAGS -DHAVE_OPENGL"
- SYSTEM_LIBS="$SYSTEM_LIBS -ldl"
+ SYSTEM_LIBS="$SYSTEM_LIBS"
fi
fi
}
@@ -4649,7 +4649,7 @@
ac_save_libs="$LIBS"
case "$target" in
*-*-freebsd*)
@ -21,20 +39,20 @@
;;
*-*-openbsd*)
pthread_lib="-lc_r"
@@ -4364,7 +4364,7 @@
@@ -4689,7 +4689,7 @@
echo "$ac_t""$use_pthreads" 1>&6
if test x$use_pthreads = xyes; then
CFLAGS="$CFLAGS -D_REENTRANT -DSDL_USE_PTHREADS"
- SDL_CFLAGS="$SDL_CFLAGS -D_REENTRANT"
+ SDL_CFLAGS="$SDL_CFLAGS -D_REENTRANT -D_THREAD_SAFE"
SDL_LIBS="$SDL_LIBS $pthread_lib"
fi
fi
@@ -4953,6 +4953,7 @@
echo $ac_n "checking whether semun is defined in /usr/include/sys/sem.h""... $ac_c" 1>&6
echo "configure:4696: checking whether semun is defined in /usr/include/sys/sem.h" >&5
@@ -5356,6 +5356,7 @@
;;
*-*-freebsd*)
ARCH=freebsd
+ CheckNASM
CheckESD
CheckX11
CheckPTHREAD
CheckAAlib

View file

@ -0,0 +1,26 @@
--- src/main/Makefile.in.orig Sun Apr 23 22:37:43 2000
+++ src/main/Makefile.in Sun Apr 23 22:45:12 2000
@@ -109,7 +109,7 @@
ARCH_SUBDIRS = beos linux macos win32
# Build a separate library containing the main() entry point.
-lib_LIBRARIES = libSDLmain.a
+lib_LIBRARIES = libSDLmain-1.1.a
MAINLIB_ARCH_SRCS = SDL_main.c
@@ -257,10 +257,10 @@
maintainer-clean-libtool:
-libSDLmain.a: $(libSDLmain_a_OBJECTS) $(libSDLmain_a_DEPENDENCIES)
- -rm -f libSDLmain.a
- $(AR) cru libSDLmain.a $(libSDLmain_a_OBJECTS) $(libSDLmain_a_LIBADD)
- $(RANLIB) libSDLmain.a
+libSDLmain-1.1.a: $(libSDLmain_a_OBJECTS) $(libSDLmain_a_DEPENDENCIES)
+ -rm -f libSDLmain-1.1.a
+ $(AR) cru libSDLmain-1.1.a $(libSDLmain_a_OBJECTS) $(libSDLmain_a_LIBADD)
+ $(RANLIB) libSDLmain-1.1.a
mostlyclean-noinstLTLIBRARIES:

View file

@ -0,0 +1,11 @@
--- include/Makefile.in.orig Sun Apr 23 22:34:25 2000
+++ include/Makefile.in Sun Apr 23 22:34:43 2000
@@ -106,7 +106,7 @@
with_gcc = @with_gcc@
with_gnu_ld = @with_gnu_ld@
-libSDLincludedir = $(includedir)/SDL
+libSDLincludedir = $(includedir)/SDL11
# Which header files to install
libSDLinclude_HEADERS = SDL.h SDL_active.h SDL_audio.h SDL_byteorder.h SDL_cdrom.h SDL_copying.h SDL_endian.h SDL_error.h SDL_events.h SDL_joystick.h SDL_keyboard.h SDL_keysym.h SDL_main.h SDL_mouse.h SDL_mutex.h SDL_quit.h SDL_rwops.h SDL_syswm.h SDL_thread.h SDL_timer.h SDL_types.h SDL_version.h SDL_video.h begin_code.h close_code.h

View file

@ -0,0 +1,20 @@
--- Makefile.in.orig Fri Mar 31 08:31:12 2000
+++ Makefile.in Mon Apr 24 00:29:07 2000
@@ -113,7 +113,7 @@
DIST_SUBDIRS = $(SUBDIRS) docs
# SDL runtime configuration script
-bin_SCRIPTS = sdl-config
+bin_SCRIPTS = sdl11-config
# All the rest of the distributed files
EXTRA_DIST = BUGS COPYING CREDITS INSTALL README README-SDL.txt README.Win32 README.MacOS VisualC.html VisualC.zip CWprojects.sea.hqx MPWmake.sea.hqx WhatsNew docs.html sdl.m4 autogen.sh strip_fPIC.sh
@@ -121,7 +121,7 @@
# M4 macro file for inclusion with autoconf
m4datadir = $(datadir)/aclocal
-m4data_DATA = sdl.m4
+m4data_DATA = sdl11.m4
# Create a CVS snapshot that people can run update -d on
CVSROOT = :pserver:guest@cvs.lokigames.com:/cvs

View file

@ -0,0 +1,20 @@
--- sdl-config.in.orig Sun Apr 23 22:23:24 2000
+++ sdl-config.in Sun Apr 23 22:24:14 2000
@@ -5,7 +5,7 @@
exec_prefix_set=no
usage="\
-Usage: sdl-config [--prefix[=DIR]] [--exec-prefix[=DIR]] [--version] [--libs] [--cflags]"
+Usage: sdl11-config [--prefix[=DIR]] [--exec-prefix[=DIR]] [--version] [--libs] [--cflags]"
if test $# -eq 0; then
echo "${usage}" 1>&2
@@ -42,7 +42,7 @@
if test @includedir@ != /usr/include ; then
includes=-I@includedir@
fi
- echo $includes -I@includedir@/SDL @SDL_CFLAGS@
+ echo $includes -I@includedir@/SDL11 @SDL_CFLAGS@
;;
--libs)
if [ "`uname`" = "SunOS" ]; then

View file

@ -1 +1 @@
Cross-platform multi-media development API
Cross-platform multi-media development API (developm. vers.)

View file

@ -1,3 +1,5 @@
Unstable development version of the SDL library.
This library is designed to make it easy to write games that run on UNIX,
Win32 and BeOS using the various native high-performance media interfaces,
(for video, audio, etc) and presenting a single source-code level API to

View file

@ -1,110 +1,117 @@
bin/sdl-config
include/SDL/SDL.h
include/SDL/SDL_active.h
include/SDL/SDL_audio.h
include/SDL/SDL_byteorder.h
include/SDL/SDL_cdrom.h
include/SDL/SDL_copying.h
include/SDL/SDL_endian.h
include/SDL/SDL_error.h
include/SDL/SDL_events.h
include/SDL/SDL_keyboard.h
include/SDL/SDL_keysym.h
include/SDL/SDL_main.h
include/SDL/SDL_mouse.h
include/SDL/SDL_mutex.h
include/SDL/SDL_quit.h
include/SDL/SDL_rwops.h
include/SDL/SDL_syswm.h
include/SDL/SDL_thread.h
include/SDL/SDL_timer.h
include/SDL/SDL_types.h
include/SDL/SDL_version.h
include/SDL/SDL_video.h
include/SDL/begin_code.h
include/SDL/close_code.h
lib/libSDL-1.0.so
lib/libSDL-1.0.so.2
lib/libSDL.a
lib/libSDL.la
lib/libSDL.so
lib/libSDLmain.a
bin/sdl11-config
include/SDL11/SDL.h
include/SDL11/SDL_active.h
include/SDL11/SDL_audio.h
include/SDL11/SDL_byteorder.h
include/SDL11/SDL_cdrom.h
include/SDL11/SDL_copying.h
include/SDL11/SDL_endian.h
include/SDL11/SDL_error.h
include/SDL11/SDL_events.h
include/SDL11/SDL_joystick.h
include/SDL11/SDL_keyboard.h
include/SDL11/SDL_keysym.h
include/SDL11/SDL_main.h
include/SDL11/SDL_mouse.h
include/SDL11/SDL_mutex.h
include/SDL11/SDL_quit.h
include/SDL11/SDL_rwops.h
include/SDL11/SDL_syswm.h
include/SDL11/SDL_thread.h
include/SDL11/SDL_timer.h
include/SDL11/SDL_types.h
include/SDL11/SDL_version.h
include/SDL11/SDL_video.h
include/SDL11/begin_code.h
include/SDL11/close_code.h
lib/libSDL-1.1.so.2
lib/libSDL-1.1.a
lib/libSDL-1.1.la
lib/libSDL-1.1.so
lib/libSDLmain-1.1.a
@exec /sbin/ldconfig -m %B
@unexec /sbin/ldconfig -R
share/aclocal/sdl.m4
share/doc/SDL/BUGS
share/doc/SDL/COPYING
share/doc/SDL/CREDITS
share/doc/SDL/README
share/doc/SDL/WhatsNew
share/doc/SDL/audio/examples.html
share/doc/SDL/audio/funclist.html
share/doc/SDL/audio/functions.html
share/doc/SDL/audio/index.html
share/doc/SDL/cdrom/examples.html
share/doc/SDL/cdrom/funclist.html
share/doc/SDL/cdrom/functions.html
share/doc/SDL/cdrom/index.html
share/doc/SDL/docs.html
share/doc/SDL/events/examples.html
share/doc/SDL/events/functions.html
share/doc/SDL/events/index.html
share/doc/SDL/events/keysym.html
share/doc/SDL/images/rainbow.gif
share/doc/SDL/index.html
share/doc/SDL/threads/index.html
share/doc/SDL/time/examples.html
share/doc/SDL/time/funclist.html
share/doc/SDL/time/functions.html
share/doc/SDL/time/index.html
share/doc/SDL/video/examples.html
share/doc/SDL/video/funclist.html
share/doc/SDL/video/functions.html
share/doc/SDL/video/index.html
share/examples/SDL/COPYING
share/examples/SDL/Makefile.am
share/examples/SDL/Makefile.in
share/examples/SDL/README
share/examples/SDL/acinclude.m4
share/examples/SDL/aclocal.m4
share/examples/SDL/autogen.sh
share/examples/SDL/checkkeys.c
share/examples/SDL/config.guess
share/examples/SDL/config.sub
share/examples/SDL/configure
share/examples/SDL/configure.in
share/examples/SDL/graywin.c
share/examples/SDL/icon.bmp
share/examples/SDL/install-sh
share/examples/SDL/loopwave.c
share/examples/SDL/missing
share/examples/SDL/mkinstalldirs
share/examples/SDL/picture.xbm
share/examples/SDL/sample.bmp
share/examples/SDL/sample.wav
share/examples/SDL/testalpha.c
share/examples/SDL/testbitmap.c
share/examples/SDL/testcdrom.c
share/examples/SDL/testerror.c
share/examples/SDL/testhread.c
share/examples/SDL/testkeys.c
share/examples/SDL/testlock.c
share/examples/SDL/testsprite.c
share/examples/SDL/testtimer.c
share/examples/SDL/testtypes.c
share/examples/SDL/testver.c
share/examples/SDL/testvidinfo.c
share/examples/SDL/testwin.c
share/examples/SDL/testwm.c
share/examples/SDL/threadwin.c
@dirrm share/examples/SDL
@dirrm share/doc/SDL/video
@dirrm share/doc/SDL/time
@dirrm share/doc/SDL/threads
@dirrm share/doc/SDL/opengl
@dirrm share/doc/SDL/images
@dirrm share/doc/SDL/events
@dirrm share/doc/SDL/cdrom
@dirrm share/doc/SDL/audio
@dirrm share/doc/SDL
@dirrm include/SDL
share/aclocal/sdl11.m4
share/doc/SDL11/BUGS
share/doc/SDL11/COPYING
share/doc/SDL11/CREDITS
share/doc/SDL11/README
share/doc/SDL11/WhatsNew
share/doc/SDL11/audio/examples.html
share/doc/SDL11/audio/funclist.html
share/doc/SDL11/audio/functions.html
share/doc/SDL11/audio/index.html
share/doc/SDL11/cdrom/examples.html
share/doc/SDL11/cdrom/funclist.html
share/doc/SDL11/cdrom/functions.html
share/doc/SDL11/cdrom/index.html
share/doc/SDL11/docs.html
share/doc/SDL11/events/examples.html
share/doc/SDL11/events/functions.html
share/doc/SDL11/events/index.html
share/doc/SDL11/events/keysym.html
share/doc/SDL11/images/rainbow.gif
share/doc/SDL11/index.html
share/doc/SDL11/opengl/examples.html
share/doc/SDL11/opengl/funclist.html
share/doc/SDL11/opengl/functions.html
share/doc/SDL11/opengl/index.html
share/doc/SDL11/threads/index.html
share/doc/SDL11/time/examples.html
share/doc/SDL11/time/funclist.html
share/doc/SDL11/time/functions.html
share/doc/SDL11/time/index.html
share/doc/SDL11/video/examples.html
share/doc/SDL11/video/funclist.html
share/doc/SDL11/video/functions.html
share/doc/SDL11/video/index.html
share/examples/SDL11/COPYING
share/examples/SDL11/Makefile.am
share/examples/SDL11/Makefile.in
share/examples/SDL11/README
share/examples/SDL11/acinclude.m4
share/examples/SDL11/aclocal.m4
share/examples/SDL11/autogen.sh
share/examples/SDL11/checkkeys.c
share/examples/SDL11/config.guess
share/examples/SDL11/config.sub
share/examples/SDL11/configure
share/examples/SDL11/configure.in
share/examples/SDL11/graywin.c
share/examples/SDL11/icon.bmp
share/examples/SDL11/install-sh
share/examples/SDL11/loopwave.c
share/examples/SDL11/missing
share/examples/SDL11/mkinstalldirs
share/examples/SDL11/picture.xbm
share/examples/SDL11/sample.bmp
share/examples/SDL11/sample.wav
share/examples/SDL11/testalpha.c
share/examples/SDL11/testbitmap.c
share/examples/SDL11/testcdrom.c
share/examples/SDL11/testerror.c
share/examples/SDL11/testgl.c
share/examples/SDL11/testhread.c
share/examples/SDL11/testjoystick.c
share/examples/SDL11/testkeys.c
share/examples/SDL11/testlock.c
share/examples/SDL11/testsprite.c
share/examples/SDL11/testtimer.c
share/examples/SDL11/testtypes.c
share/examples/SDL11/testver.c
share/examples/SDL11/testvidinfo.c
share/examples/SDL11/testwin.c
share/examples/SDL11/testwm.c
share/examples/SDL11/torturethread.c
share/examples/SDL11/threadwin.c
@dirrm share/examples/SDL11
@dirrm share/doc/SDL11/video
@dirrm share/doc/SDL11/time
@dirrm share/doc/SDL11/threads
@dirrm share/doc/SDL11/opengl
@dirrm share/doc/SDL11/images
@dirrm share/doc/SDL11/events
@dirrm share/doc/SDL11/cdrom
@dirrm share/doc/SDL11/audio
@dirrm share/doc/SDL11
@dirrm include/SDL11