saferpay is a command line tool for online payment.

At the moment it is
used in europe, mostly germany and switzerland.

Submitted by:	Martin Blapp <mb@imp.ch>
This commit is contained in:
Alexander Langer 2001-09-06 22:39:15 +00:00
parent 8091bed6f3
commit 5e47245ef9
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=47483
12 changed files with 210 additions and 0 deletions

View file

@ -168,6 +168,7 @@
SUBDIR += ruby-pam
SUBDIR += ruby-ssl
SUBDIR += ruby-tcpwrap
SUBDIR += saferpay
SUBDIR += saint
SUBDIR += scanssh
SUBDIR += seahorse

View file

@ -0,0 +1,43 @@
# New ports collection makefile for: saferpay
# Date created: 06 September 2001
# Whom: mb@imp.ch
#
# $FreeBSD$
#
PORTNAME= saferpay
PORTVERSION= 1.2.2
CATEGORIES= security
MASTER_SITES= http://www.saferpay.com/download/
DISTFILES= ${PORTNAME}_${PORTVERSION}_linux-g++_src.tar.gz
MAINTAINER= mb@imp.ch
MAKEFILE= ${WRKSRC}/saferpay/Makefile
USE_OPENSSL= yes
INSTALLS_SHLIB= yes
WRKSRC= ${WRKDIR}
pre-patch:
@${CHMOD} 644 ${MAKEFILE}
@${CP} ${MAKEFILE} ${MAKEFILE}.orig
@${SED} -e 's%.$$%%' < ${MAKEFILE}.orig > ${MAKEFILE}
.if !defined(WITH_P5_API)
pre-build:
@${ECHO} "-----------------------------------------------------"
@${ECHO} You are building now the saferpay command line tool.
@${ECHO} If you like to install the perl API too, break this
@${ECHO} installation and start it again with WITH_P5_API=YES.
@${ECHO} "-----------------------------------------------------"
.else
pre-build:
PLIST= ${PKGDIR}/pkg-plist.p5
post-build:
@(cd ${INSTALL_WRKSRC} && ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} xs)
post-install:
@(cd ${INSTALL_WRKSRC} && ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} installxs)
.endif
.include <bsd.port.mk>

View file

@ -0,0 +1 @@
MD5 (saferpay_1.2.2_linux-g++_src.tar.gz) = 0fe9c85bd09cabcd7a8204b141d9ec9f

View file

@ -0,0 +1,74 @@
--- saferpay/Makefile.orig Thu Sep 6 00:19:01 2001
+++ saferpay/Makefile Thu Sep 6 00:21:22 2001
@@ -1,47 +1,35 @@
-PREFIX = /usr
-SSLEAYDIR = SSLeay-0.9.0
-SSLEAY = $(SSLEAYDIR)-patch1
-
all:
- make SSLeay
- cp ./ssl/$(SSLEAYDIR)/libssl.a ./ssl
- cp ./ssl/$(SSLEAYDIR)/libcrypto.a ./ssl
- make -f idpapp.mk
- cp ./out/libidpapp.s* $(PREFIX)/lib
- make -f saferpay.mk
- cp idpapi.h ./out
- cp idperrc.h ./out
- cp ./out/settings.template ./out/settings.xml
-
-SSLeay:
- cd ssl; gunzip -c $(SSLEAY).tar.gz > $(SSLEAY).tar; tar xf $(SSLEAY).tar; cd $(SSLEAYDIR); perl Configure linux-elf; make; cd ..; cd ..;
+ gmake -f idpapp.mk -C saferpay
+ gmake -f saferpay.mk -C saferpay
clean:
- make -f idpapp.mk clean
- make -f saferpay.mk clean
- -rm -R ssl/$(SSLEAYDIR)
- -rm ssl/$(SSLEAY).tar;
+ gmake -f idpapp.mk -C saferpay clean
+ gmake -f saferpay.mk -C saferpay clean
xs: all
- perl -e 'system("cd perl/MessageObject\nperl Makefile.PL\nmake");'
- perl -e 'system("cd perl/MessageFactory\nperl Makefile.PL\nmake");'
- perl -e 'system("cd perl/ConfigurationSetup\nperl Makefile.PL\nmake");'
+ perl -e 'system("cd saferpay/perl/MessageObject\nperl Makefile.PL\nmake");'
+ perl -e 'system("cd saferpay/perl/MessageFactory\nperl Makefile.PL\nmake");'
+ perl -e 'system("cd saferpay/perl/ConfigurationSetup\nperl Makefile.PL\nmake");'
testxs:
- make -C perl/ConfigurationSetup test
- make -C perl/MessageFactory test
+ gmake -C saferpay/perl/ConfigurationSetup test
+ gmake -C saferpay/perl/MessageFactory test
installxs:
- make -C perl/ConfigurationSetup install
- make -C perl/MessageFactory install
- make -C perl/MessageObject install
+ gmake -C saferpay/perl/ConfigurationSetup install
+ gmake -C saferpay/perl/MessageFactory install
+ gmake -C saferpay/perl/MessageObject install
cleanxs:
- make -C perl/ConfigurationSetup clean
- make -C perl/MessageFactory clean
- make -C perl/MessageObject clean
-
-
-
-
-
+ gmake -C saferpay/perl/ConfigurationSetup clean
+ gmake -C saferpay/perl/MessageFactory clean
+ gmake -C saferpay/perl/MessageObject clean
+
+install:
+ install -C saferpay/out/libidpapp.so.1.0.0 $(PREFIX)/lib/libidpapp.so.1
+ install -C saferpay/idpapi.h $(PREFIX)/include
+ install -C saferpay/idperrc.h $(PREFIX)/include
+ install -m 0555 -C saferpay/out/saferpay $(PREFIX)/bin
+ mkdir -p $(PREFIX)/share/examples/saferpay/
+ install -C saferpay/out/settings.template $(PREFIX)/share/examples/saferpay/
+ ln -s -f $(PREFIX)/lib/libidpapp.so.1 $(PREFIX)/lib/libidpapp.so

View file

@ -0,0 +1,15 @@
--- saferpay/idpapp.mk.orig Thu Dec 14 18:54:02 2000
+++ saferpay/idpapp.mk Mon Jul 30 13:33:48 2001
@@ -11,10 +11,10 @@
CXX = g++
CFLAGS = -pipe -DUNIX -DHAVE_UNISTD_H -DHAVE_STDLIB_H -O2 -fPIC
CXXFLAGS= -pipe -DUNIX -O2 -fPIC
-INCPATH = -I"./xml" -I"./jni" -I"./ssl" -I"./sxfc"
+INCPATH = -I"./xml" -I"./jni" -I"/usr/include/openssl/" -I"./sxfc"
LINK = g++
LFLAGS = -fPIC -shared -Wl,-soname,libidpapp.so.1
-LIBS = ./ssl/libssl.a ./ssl/libcrypto.a
+LIBS = /usr/lib/libssl.a /usr/lib/libcrypto.a
AR = ar cqs
RANLIB =
MOC = $(QTDIR)/bin/moc

View file

@ -0,0 +1,11 @@
--- saferpay/idphttp.cpp.orig Wed Jan 10 15:23:12 2001
+++ saferpay/idphttp.cpp Mon Jul 30 13:33:13 2001
@@ -368,7 +368,7 @@
public:
SslConnection()
{
- SSLeay_add_ssl_algorithms();
+ SSL_library_init();
SSL_load_error_strings();
ctx = SSL_CTX_new(SSLv23_method());

View file

@ -0,0 +1,11 @@
--- saferpay/saferpay.c.orig Wed Sep 5 17:05:15 2001
+++ saferpay/saferpay.c Wed Sep 5 17:05:27 2001
@@ -3,7 +3,7 @@
#include <stdio.h>
#include <errno.h>
#include <string.h>
-#include <malloc.h>
+#include <stdlib.h>
#include "idpapi.h"
#include "idperrc.h"

View file

@ -0,0 +1,11 @@
--- saferpay/saferpay.mk.orig Fri Sep 7 00:16:00 2001
+++ saferpay/saferpay.mk Fri Sep 7 00:16:10 2001
@@ -13,7 +13,7 @@
CXXFLAGS= -pipe -O2
INCPATH =
LINK = g++
-LFLAGS =
+LFLAGS = -Lout
LIBS = -lidpapp
MOC = $(QTDIR)/bin/moc

View file

@ -0,0 +1,2 @@
saferpay is a command line tool for online payment. At the moment it is
used in europe, mostly germany and switzerland.

View file

@ -0,0 +1,9 @@
Saferpay is a online payment software with P5 API and a
command line tool. At the moment it is used in europe,
mostly germany and switzerland.
The saferpay command line tool offers web shop operators
all the equipment they need so that they can collect
payment online quickly and easily on the Internet.
WWW: http://www.saferpay.com

View file

@ -0,0 +1,5 @@
lib/libidpapp.so
lib/libidpapp.so.1
bin/saferpay
share/examples/saferpay/settings.template
@dirrm share/examples/saferpay

View file

@ -0,0 +1,27 @@
lib/libidpapp.so
lib/libidpapp.so.1
bin/saferpay
share/examples/saferpay/settings.template
@dirrm share/examples/saferpay
lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/soplex/saferpay/ConfigurationSetup/.packlist
lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/soplex/saferpay/ConfigurationSetup/ConfigurationSetup.so
lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/soplex/saferpay/ConfigurationSetup/ConfigurationSetup.bs
lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/soplex/saferpay/ConfigurationSetup.pm
lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/soplex/saferpay/MessageFactory/.packlist
lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/soplex/saferpay/ConfigurationSetup/autosplit.ix
lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/soplex/saferpay/MessageFactory/MessageFactory.so
lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/soplex/saferpay/MessageFactory/MessageFactory.bs
lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/soplex/saferpay/MessageFactory.pm
lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/soplex/saferpay/MessageFactory/autosplit.ix
lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/soplex/saferpay/MessageObject/.packlist
lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/soplex/saferpay/MessageObject/MessageObject.so
lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/soplex/saferpay/MessageObject/MessageObject.bs
lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/soplex/saferpay/MessageObject.pm
lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/soplex/saferpay/MessageObject/autosplit.ix
lib/perl5/5.00503/man/man3/soplex::saferpay::MessageFactory.3
lib/perl5/5.00503/man/man3/soplex::saferpay::MessageObject.3
@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/soplex/saferpay/ConfigurationSetup
@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/soplex/saferpay/MessageObject
@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/soplex/saferpay/MessageFactory
@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/soplex/saferpay
@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/soplex