Upgrade to 1.0.4.
This commit is contained in:
parent
16c237e988
commit
5e656be4fd
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=172318
5 changed files with 16 additions and 47 deletions
|
@ -6,7 +6,7 @@
|
|||
#
|
||||
|
||||
PORTNAME= libzdb
|
||||
PORTVERSION= 1.0.3
|
||||
PORTVERSION= 1.0.4
|
||||
CATEGORIES= databases
|
||||
MASTER_SITES= http://www.tildeslash.com/libzdb/dist/
|
||||
|
||||
|
@ -16,6 +16,7 @@ COMMENT= Thread-safe connection pool library
|
|||
GNU_CONFIGURE= yes
|
||||
USE_GMAKE= yes
|
||||
USE_AUTOTOOLS= libtool:15
|
||||
USE_GNOME= gnometarget
|
||||
INSTALLS_SHLIB= yes
|
||||
CONFIGURE_ENV= CPPFLAGS="${PTHREAD_CFLAGS}"
|
||||
|
||||
|
@ -41,6 +42,6 @@ CONFIGURE_ARGS+= --without-sqlite
|
|||
.endif
|
||||
|
||||
post-patch:
|
||||
${REINPLACE_CMD} 's,%%PTHREAD_LIBS%%,${PTHREAD_LIBS},g' ${WRKSRC}/configure
|
||||
@${REINPLACE_CMD} 's,%%PTHREAD_LIBS%%,${PTHREAD_LIBS},g' ${WRKSRC}/configure
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
MD5 (libzdb-1.0.3.tar.gz) = 0f87108b4a27a2bc6fc0cb013e104d0b
|
||||
SHA256 (libzdb-1.0.3.tar.gz) = dec47324c7ad94190c3d72fff9e7bb88ff12ce23096ca9602dcb57d6da5afcdb
|
||||
SIZE (libzdb-1.0.3.tar.gz) = 486561
|
||||
MD5 (libzdb-1.0.4.tar.gz) = ac61dde8fde854dca394dd56a7fd55a7
|
||||
SHA256 (libzdb-1.0.4.tar.gz) = a14549e7a700ccbca35bec192101bc64e23d98e324ae95eb6d8f4a56f400c918
|
||||
SIZE (libzdb-1.0.4.tar.gz) = 499729
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- configure.orig Fri Mar 17 01:22:59 2006
|
||||
+++ configure Fri Jun 9 10:08:08 2006
|
||||
@@ -18909,10 +18909,10 @@
|
||||
--- configure.orig Fri Aug 25 15:22:45 2006
|
||||
+++ configure Wed Aug 30 06:02:33 2006
|
||||
@@ -19263,10 +19263,10 @@
|
||||
|
||||
|
||||
# This can be used to rebuild libtool when needed
|
||||
|
@ -13,7 +13,7 @@
|
|||
|
||||
# Prevent multiple expansion
|
||||
|
||||
@@ -18947,7 +18947,7 @@
|
||||
@@ -19361,7 +19361,7 @@
|
||||
echo $ECHO_N "(cached) $ECHO_C" >&6
|
||||
else
|
||||
ac_check_lib_save_LIBS=$LIBS
|
||||
|
@ -22,7 +22,7 @@
|
|||
cat >conftest.$ac_ext <<_ACEOF
|
||||
/* confdefs.h. */
|
||||
_ACEOF
|
||||
@@ -19010,7 +19010,7 @@
|
||||
@@ -19424,7 +19424,7 @@
|
||||
#define HAVE_LIBPTHREAD 1
|
||||
_ACEOF
|
||||
|
||||
|
@ -31,16 +31,16 @@
|
|||
|
||||
else
|
||||
{ { echo "$as_me:$LINENO: error: POSIX thread library is required" >&5
|
||||
@@ -19185,7 +19185,7 @@
|
||||
@@ -19599,7 +19599,7 @@
|
||||
_ACEOF
|
||||
|
||||
mysql="yes"
|
||||
- if test -r "$with_mysql/lib/libmysqlclient.a"; then
|
||||
+ if test -r "$with_mysql/lib/mysql/libmysqlclient.a"; then
|
||||
DB_CPPFLAGS="$DB_CPPFLAGS -I$with_mysql/include"
|
||||
DB_LDFLAGS="$DB_LDFLAGS -L$with_mysql/lib/ -lmysqlclient"
|
||||
DBCPPFLAGS="$DBCPPFLAGS -I$with_mysql/include"
|
||||
DBLDFLAGS="$DBLDFLAGS -L$with_mysql/lib/ -lmysqlclient"
|
||||
else
|
||||
@@ -20268,7 +20268,7 @@
|
||||
@@ -20657,7 +20657,7 @@
|
||||
|
||||
# If the compiler is gcc, tune warnings and make the char type unsigned
|
||||
if test "x$GCC" = "xyes"; then
|
||||
|
@ -48,4 +48,4 @@
|
|||
+ #CFLAGS="$CFLAGS -Wall -Wunused -Wno-unused-label -funsigned-char";
|
||||
# does this compiler support -Wno-pointer-sign ?
|
||||
svd_CFLAGS="$CFLAGS"
|
||||
CFLAGS="-Wno-pointer-sign $CFLAGS"
|
||||
CFLAGS="$CFLAGS -Wno-pointer-sign"
|
||||
|
|
|
@ -1,13 +0,0 @@
|
|||
--- src/db/ConnectionPool.c.orig Fri Jun 9 10:11:12 2006
|
||||
+++ src/db/ConnectionPool.c Fri Jun 9 10:11:19 2006
|
||||
@@ -319,8 +319,9 @@
|
||||
|
||||
static int fillPool(T P) {
|
||||
int i;
|
||||
- P->error= NULL;
|
||||
Connection_T con;
|
||||
+
|
||||
+ P->error= NULL;
|
||||
for(i= 0; i < P->initialConnections; i++) {
|
||||
if(! (con= Connection_new(P, &P->error))) {
|
||||
if(i>0) {
|
|
@ -1,19 +0,0 @@
|
|||
--- test/pool.c.orig Fri Jun 9 10:12:00 2006
|
||||
+++ test/pool.c Fri Jun 9 10:12:17 2006
|
||||
@@ -270,7 +270,6 @@
|
||||
int main(void) {
|
||||
URL_T url;
|
||||
char buf[BSIZE];
|
||||
- ZBDEBUG= TRUE;
|
||||
char *help= "Please enter a valid database connection URL and press ENTER\n"
|
||||
"E.g. sqlite:///tmp/sqlite.db?synchronous=off&show_datatypes=off\n"
|
||||
"E.g. mysql://localhost:3306/test?user=root&password=root\n"
|
||||
@@ -278,6 +277,8 @@
|
||||
printf("============> Start Connection Pool Tests\n\n");
|
||||
printf("This test will create and drop a table called zild_t in the database\n");
|
||||
printf("%s", help);
|
||||
+
|
||||
+ ZBDEBUG= TRUE;
|
||||
while(fgets(buf, BSIZE, stdin)) {
|
||||
if(*buf == '.')
|
||||
break;
|
Loading…
Reference in a new issue