New port: devel/libdbusmenu-qt5.

This is the Qt5 version of devel/libdbusmenu-qt. They both come from the
same tarball, so the differences between both ports are minimal at this
point.

From pkg-descr:
  A library that provides Qt5 implementation of the DBusMenu protocol.
  The DBusMenu protocol makes it possible for applications to export
  and import their menus over DBus.

  WWW: https://launchpad.net/libdbusmenu-qt

Submitted by:	Tobias C. Berner <tcberner@gmail.com>
This commit is contained in:
Raphael Kubo da Costa 2015-06-25 16:52:55 +00:00
parent 8c6b78ad37
commit 5eab44ec9d
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=390587
6 changed files with 167 additions and 0 deletions

View file

@ -1039,6 +1039,7 @@
SUBDIR += libdatrie
SUBDIR += libdbusmenu
SUBDIR += libdbusmenu-qt
SUBDIR += libdbusmenu-qt5
SUBDIR += libdevq
SUBDIR += libdfui
SUBDIR += libdict

View file

@ -0,0 +1,42 @@
# Created by: Tobias Berner <tcberner@gmail.com>
# $FreeBSD$
PORTNAME= libdbusmenu-qt5
PORTVERSION= ${MAJOR_VER}.${SNAPSHOT_VER:S/.//g}
CATEGORIES= devel
MASTER_SITES= http://archive.ubuntu.com/ubuntu/pool/main/libd/${PORTNAME:C/5//}/
DISTNAME= ${PORTNAME:C/5//}_${MAJOR_VER}+${SNAPSHOT_VER}.orig
MAINTAINER= kde@FreeBSD.org
COMMENT= Qt5 implementation of the DBusMenu protocol
LICENSE= LGPL20
MAJOR_VER= 0.9.3
SNAPSHOT_VER= 15.10.20150604
WRKSRC= ${WRKDIR}/${PORTNAME:C/5//}-${MAJOR_VER}+${SNAPSHOT_VER}
USE_QT5= buildtools_build core dbus qmake_build widgets
USES= compiler:c++11-lib cmake:outsource
CMAKE_ARGS= -DUSE_QT4:BOOL=FALSE -DUSE_QT5:BOOL=TRUE
USE_LDCONFIG= yes
OPTIONS_DEFINE= DOXYGEN
OPTIONS_SUB= YES
DOXYGEN_DESC= Build documentation (requires doxygen)
DOXYGEN_CMAKE_ON= -DWITH_DOC:BOOL=TRUE
DOXYGEN_CMAKE_OFF= -DWITH_DOC:BOOL=FALSE
DOXYGEN_BUILD_DEPENDS= doxygen:${PORTSDIR}/devel/doxygen
.if defined(PACKAGE_BUILDING)
OPTIONS_DEFAULT+= DOXYGEN
.endif
post-patch:
@${REINPLACE_CMD} -e '/add_subdirectory(tests)/ d' \
-e '/add_subdirectory(tools)/ d' \
${WRKSRC}/CMakeLists.txt
.include <bsd.port.mk>

View file

@ -0,0 +1,2 @@
SHA256 (libdbusmenu-qt_0.9.3+15.10.20150604.orig.tar.gz) = dd87926003be6455420a077dd8edb29f5dac428b9b299b2bd73a1c29c2126328
SIZE (libdbusmenu-qt_0.9.3+15.10.20150604.orig.tar.gz) = 46318

View file

@ -0,0 +1,20 @@
--- CMakeLists.txt
+++ CMakeLists.txt
@@ -86,7 +86,7 @@ add_dependencies(distcheck dist)
configure_file(dbusmenu-qt.pc.in ${CMAKE_BINARY_DIR}/dbusmenu-${QT_SUFFIX}.pc @ONLY)
install(FILES ${CMAKE_BINARY_DIR}/dbusmenu-${QT_SUFFIX}.pc
- DESTINATION ${LIB_DESTINATION}/pkgconfig
+ DESTINATION libdata/pkgconfig
)
add_subdirectory(src)
@@ -103,7 +106,7 @@ if(WITH_DOC)
)
install(DIRECTORY ${CMAKE_BINARY_DIR}/html/
- DESTINATION share/doc/libdbusmenu-${QT_SUFFIX}-doc
+ DESTINATION share/doc/libdbusmenu-${QT_SUFFIX}
)
endif(WITH_DOC)

View file

@ -0,0 +1,5 @@
A library that provides Qt5 implementation of the DBusMenu protocol.
The DBusMenu protocol makes it possible for applications to export
and import their menus over DBus.
WWW: https://launchpad.net/libdbusmenu-qt

View file

@ -0,0 +1,97 @@
include/dbusmenu-qt5/dbusmenu_export.h
include/dbusmenu-qt5/dbusmenu_version.h
include/dbusmenu-qt5/dbusmenuexporter.h
include/dbusmenu-qt5/dbusmenuimporter.h
lib/cmake/dbusmenu-qt5/dbusmenu-qt5-config-version.cmake
lib/cmake/dbusmenu-qt5/dbusmenu-qt5-config.cmake
lib/cmake/dbusmenu-qt5/dbusmenu-qt5-targets-%%CMAKE_BUILD_TYPE%%.cmake
lib/cmake/dbusmenu-qt5/dbusmenu-qt5-targets.cmake
lib/libdbusmenu-qt5.so
lib/libdbusmenu-qt5.so.2
lib/libdbusmenu-qt5.so.2.6.0
libdata/pkgconfig/dbusmenu-qt5.pc
%%DOXYGEN%%%%DOCSDIR%%/annotated.html
%%DOXYGEN%%%%DOCSDIR%%/arrowdown.png
%%DOXYGEN%%%%DOCSDIR%%/arrowright.png
%%DOXYGEN%%%%DOCSDIR%%/bc_s.png
%%DOXYGEN%%%%DOCSDIR%%/bdwn.png
%%DOXYGEN%%%%DOCSDIR%%/classDBusMenuExporter-members.html
%%DOXYGEN%%%%DOCSDIR%%/classDBusMenuExporter.html
%%DOXYGEN%%%%DOCSDIR%%/classDBusMenuExporter.png
%%DOXYGEN%%%%DOCSDIR%%/classDBusMenuImporter-members.html
%%DOXYGEN%%%%DOCSDIR%%/classDBusMenuImporter.html
%%DOXYGEN%%%%DOCSDIR%%/classDBusMenuImporter.png
%%DOXYGEN%%%%DOCSDIR%%/classes.html
%%DOXYGEN%%%%DOCSDIR%%/closed.png
%%DOXYGEN%%%%DOCSDIR%%/dbusmenu__export_8h_source.html
%%DOXYGEN%%%%DOCSDIR%%/dbusmenuexporter_8h_source.html
%%DOXYGEN%%%%DOCSDIR%%/dbusmenuimporter_8h_source.html
%%DOXYGEN%%%%DOCSDIR%%/deprecated.html
%%DOXYGEN%%%%DOCSDIR%%/dir_ed734dd83c75a5bf0f40de74f2cf1710.html
%%DOXYGEN%%%%DOCSDIR%%/dir_f9aacaab10bdb962cb8a14d49fe5b06f.html
%%DOXYGEN%%%%DOCSDIR%%/doc.png
%%DOXYGEN%%%%DOCSDIR%%/doxygen.css
%%DOXYGEN%%%%DOCSDIR%%/doxygen.png
%%DOXYGEN%%%%DOCSDIR%%/dynsections.js
%%DOXYGEN%%%%DOCSDIR%%/files.html
%%DOXYGEN%%%%DOCSDIR%%/folderclosed.png
%%DOXYGEN%%%%DOCSDIR%%/folderopen.png
%%DOXYGEN%%%%DOCSDIR%%/functions.html
%%DOXYGEN%%%%DOCSDIR%%/functions_func.html
%%DOXYGEN%%%%DOCSDIR%%/hierarchy.html
%%DOXYGEN%%%%DOCSDIR%%/index.html
%%DOXYGEN%%%%DOCSDIR%%/jquery.js
%%DOXYGEN%%%%DOCSDIR%%/nav_f.png
%%DOXYGEN%%%%DOCSDIR%%/nav_g.png
%%DOXYGEN%%%%DOCSDIR%%/nav_h.png
%%DOXYGEN%%%%DOCSDIR%%/open.png
%%DOXYGEN%%%%DOCSDIR%%/pages.html
%%DOXYGEN%%%%DOCSDIR%%/search/all_0.html
%%DOXYGEN%%%%DOCSDIR%%/search/all_0.js
%%DOXYGEN%%%%DOCSDIR%%/search/all_1.html
%%DOXYGEN%%%%DOCSDIR%%/search/all_1.js
%%DOXYGEN%%%%DOCSDIR%%/search/all_2.html
%%DOXYGEN%%%%DOCSDIR%%/search/all_2.js
%%DOXYGEN%%%%DOCSDIR%%/search/all_3.html
%%DOXYGEN%%%%DOCSDIR%%/search/all_3.js
%%DOXYGEN%%%%DOCSDIR%%/search/all_4.html
%%DOXYGEN%%%%DOCSDIR%%/search/all_4.js
%%DOXYGEN%%%%DOCSDIR%%/search/all_5.html
%%DOXYGEN%%%%DOCSDIR%%/search/all_5.js
%%DOXYGEN%%%%DOCSDIR%%/search/all_6.html
%%DOXYGEN%%%%DOCSDIR%%/search/all_6.js
%%DOXYGEN%%%%DOCSDIR%%/search/classes_0.html
%%DOXYGEN%%%%DOCSDIR%%/search/classes_0.js
%%DOXYGEN%%%%DOCSDIR%%/search/close.png
%%DOXYGEN%%%%DOCSDIR%%/search/functions_0.html
%%DOXYGEN%%%%DOCSDIR%%/search/functions_0.js
%%DOXYGEN%%%%DOCSDIR%%/search/functions_1.html
%%DOXYGEN%%%%DOCSDIR%%/search/functions_1.js
%%DOXYGEN%%%%DOCSDIR%%/search/functions_2.html
%%DOXYGEN%%%%DOCSDIR%%/search/functions_2.js
%%DOXYGEN%%%%DOCSDIR%%/search/functions_3.html
%%DOXYGEN%%%%DOCSDIR%%/search/functions_3.js
%%DOXYGEN%%%%DOCSDIR%%/search/functions_4.html
%%DOXYGEN%%%%DOCSDIR%%/search/functions_4.js
%%DOXYGEN%%%%DOCSDIR%%/search/functions_5.html
%%DOXYGEN%%%%DOCSDIR%%/search/functions_5.js
%%DOXYGEN%%%%DOCSDIR%%/search/functions_6.html
%%DOXYGEN%%%%DOCSDIR%%/search/functions_6.js
%%DOXYGEN%%%%DOCSDIR%%/search/mag_sel.png
%%DOXYGEN%%%%DOCSDIR%%/search/nomatches.html
%%DOXYGEN%%%%DOCSDIR%%/search/pages_0.html
%%DOXYGEN%%%%DOCSDIR%%/search/pages_0.js
%%DOXYGEN%%%%DOCSDIR%%/search/search.css
%%DOXYGEN%%%%DOCSDIR%%/search/search.js
%%DOXYGEN%%%%DOCSDIR%%/search/search_l.png
%%DOXYGEN%%%%DOCSDIR%%/search/search_m.png
%%DOXYGEN%%%%DOCSDIR%%/search/search_r.png
%%DOXYGEN%%%%DOCSDIR%%/search/searchdata.js
%%DOXYGEN%%%%DOCSDIR%%/splitbar.png
%%DOXYGEN%%%%DOCSDIR%%/sync_off.png
%%DOXYGEN%%%%DOCSDIR%%/sync_on.png
%%DOXYGEN%%%%DOCSDIR%%/tab_a.png
%%DOXYGEN%%%%DOCSDIR%%/tab_b.png
%%DOXYGEN%%%%DOCSDIR%%/tab_h.png
%%DOXYGEN%%%%DOCSDIR%%/tab_s.png
%%DOXYGEN%%%%DOCSDIR%%/tabs.css