- Update to 0.1.1
PR: 126177 Submitted by: Ilya Bakulin <webmaster@kibab.com> (maintainer)
This commit is contained in:
parent
d0b7717b64
commit
5eca12ed52
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=217959
4 changed files with 35 additions and 26 deletions
|
@ -6,17 +6,16 @@
|
|||
#
|
||||
|
||||
PORTNAME= qutim
|
||||
PORTVERSION= 0.1
|
||||
PORTVERSION= 0.1.1
|
||||
CATEGORIES= net-im
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
|
||||
MASTER_SITE_SUBDIR= ${PORTNAME}
|
||||
DISTNAME= qutIM-${PORTVERSION}
|
||||
MASTER_SITES= http://qutim.org/download/ \
|
||||
http://dl.kibab.com/distfiles/qutim/ \
|
||||
ftp://ftp.inferra.ru/pub/qutIM/
|
||||
DISTNAME= qutim_${PORTVERSION}
|
||||
|
||||
MAINTAINER= webmaster@kibab.com
|
||||
COMMENT= A Qt4-based lightweight ICQ client with advanced features
|
||||
|
||||
WRKSRC= ${WRKDIR}/qutIM
|
||||
USE_BZIP2= yes
|
||||
USE_GMAKE= yes
|
||||
USE_QT_VER= 4
|
||||
QT_COMPONENTS= gui network xml moc_build qmake_build rcc_build uic_build
|
||||
|
@ -27,6 +26,6 @@ pre-build:
|
|||
cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${QMAKE} -o Makefile qutIM.pro
|
||||
|
||||
do-install:
|
||||
@${INSTALL_PROGRAM} ${WRKSRC}/qutIM ${PREFIX}/bin
|
||||
@${INSTALL_PROGRAM} ${WRKSRC}/build/bin/qutIM ${PREFIX}/bin
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
MD5 (qutIM-0.1.tar.bz2) = da28697dfba1d345b0cc45e0cc3e7cad
|
||||
SHA256 (qutIM-0.1.tar.bz2) = cc67e9c19a0dbf52826550b4f98bdf50d50c905785e0d66e54a28a53d95a66f6
|
||||
SIZE (qutIM-0.1.tar.bz2) = 359666
|
||||
MD5 (qutim_0.1.1.tar.gz) = 0c43b30c1f428d0557f9d68f6cb4cff2
|
||||
SHA256 (qutim_0.1.1.tar.gz) = db62de671d9d6d5462dc2330ba9039cc1db74169eeefad8a2d3bc5609967df3c
|
||||
SIZE (qutim_0.1.1.tar.gz) = 805600
|
||||
|
|
26
net-im/qutim/files/patch-protocol-oscar-icq-contactlist.cpp
Normal file
26
net-im/qutim/files/patch-protocol-oscar-icq-contactlist.cpp
Normal file
|
@ -0,0 +1,26 @@
|
|||
--- protocol/oscar/icq/contactlist.cpp.orig 2008-07-22 19:34:21.000000000 +0400
|
||||
+++ protocol/oscar/icq/contactlist.cpp 2008-07-22 20:14:46.000000000 +0400
|
||||
@@ -16,6 +16,7 @@
|
||||
//#include <QtGui>
|
||||
#include <QTcpSocket>
|
||||
#include <QNetworkProxy>
|
||||
+#include <sys/time.h>
|
||||
#include "treegroupitem.h"
|
||||
#include "treebuddyitem.h"
|
||||
#include "icqmessage.h"
|
||||
@@ -1559,8 +1560,14 @@
|
||||
msg->message = codec->toUnicode(socket->read(length - 1));
|
||||
|
||||
QDateTime curTime = QDateTime::currentDateTime();
|
||||
+
|
||||
+ // Use POSIX-compatible way to get daylight saving correction
|
||||
+ struct timeval tp;
|
||||
+ struct timezone tzp;
|
||||
+ gettimeofday(&tp, &tzp);
|
||||
+
|
||||
int offset = (curTime.toLocalTime().time().hour() - curTime.toUTC().time().hour()) * 3600 +
|
||||
- (curTime.toLocalTime().time().minute() - curTime.toUTC().time().minute()) * 60 - daylight * 3600;
|
||||
+ (curTime.toLocalTime().time().minute() - curTime.toUTC().time().minute()) * 60 - tzp.tz_dsttime * 3600;
|
||||
offlineDateTime = offlineDateTime.addSecs(offset);
|
||||
|
||||
msg->date = offlineDateTime;
|
|
@ -1,16 +0,0 @@
|
|||
diff -ur qutIM/src/qutim.cpp qutIM.mine/src/qutim.cpp
|
||||
--- src/qutim.cpp 2008-06-11 16:11:00.000000000 +0400
|
||||
+++ src/qutim.cpp 2008-06-15 21:49:52.000000000 +0400
|
||||
@@ -59,10 +59,10 @@
|
||||
offlineList = NULL;
|
||||
setAttribute(Qt::WA_AlwaysShowToolTips, true);
|
||||
setFocus(Qt::ActiveWindowFocusReason);
|
||||
+ createActions();
|
||||
+ createTrayIcon();
|
||||
if ( QSystemTrayIcon::isSystemTrayAvailable() )
|
||||
{
|
||||
- createActions();
|
||||
- createTrayIcon();
|
||||
trayIcon->show();
|
||||
connect(trayIcon, SIGNAL(activated(QSystemTrayIcon::ActivationReason)),
|
||||
this, SLOT(trayActivated(QSystemTrayIcon::ActivationReason)));
|
Loading…
Reference in a new issue