Update to 0.8.7.
This commit is contained in:
parent
fa04bfa24f
commit
5ed34e420a
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=44791
7 changed files with 15 additions and 99 deletions
|
@ -6,8 +6,7 @@
|
|||
#
|
||||
|
||||
PORTNAME= bomberinstinct
|
||||
PORTVERSION= 0.8.21
|
||||
PORTREVISION= 1
|
||||
PORTVERSION= 0.8.7
|
||||
CATEGORIES= games
|
||||
MASTER_SITES= http://harpe.dptmaths.ens-cachan.fr/U/gesbert/dl/
|
||||
DISTNAME= BomberInstinct-${PORTVERSION}
|
||||
|
@ -16,23 +15,17 @@ MAINTAINER= sobomax@FreeBSD.org
|
|||
|
||||
LIB_DEPENDS= SDL_mixer.2:${PORTSDIR}/audio/sdl_mixer
|
||||
|
||||
WRKSRC= ${WRKDIR}/BomberInstinct
|
||||
WRKSRC= ${WRKDIR}/${DISTNAME}
|
||||
|
||||
SDL_CONFIG?= ${LOCALBASE}/bin/sdl11-config
|
||||
|
||||
USE_GMAKE= yes
|
||||
MAKE_ENV= SDL_CONFIG="${SDL_CONFIG}"
|
||||
USE_LIBTOOL= yes
|
||||
CONFIGURE_ENV= SDL_CONFIG="${SDL_CONFIG}" \
|
||||
CPPFLAGS="-I${LOCALBASE}/include" \
|
||||
LDFLAGS="-L${LOCALBASE}/lib"
|
||||
|
||||
pre-patch:
|
||||
@find ${WRKSRC} -name "*.[ch]" | xargs ${PERL} -pi -e 's|<SDL/|<|g'
|
||||
|
||||
do-install:
|
||||
@${INSTALL_PROGRAM} ${WRKSRC}/bi ${PREFIX}/bin
|
||||
@${INSTALL_PROGRAM} ${WRKSRC}/Nived/nived ${PREFIX}/bin
|
||||
@${INSTALL_PROGRAM} ${WRKSRC}/Spred/spred ${PREFIX}/bin
|
||||
@${MKDIR} ${PREFIX}/share/BomberInstinct
|
||||
@${INSTALL_DATA} ${WRKSRC}/bi.cfg ${PREFIX}/share/BomberInstinct
|
||||
@cd ${WRKSRC}; tar cf - Decors Sprites Niveaux Bruitages | \
|
||||
(cd ${PREFIX}/share/BomberInstinct; ${TAR} --unlink -xf - )
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1 +1 @@
|
|||
MD5 (BomberInstinct-0.8.21.tar.gz) = 2d738fc73574b497a1e154b4eeeb2d4a
|
||||
MD5 (BomberInstinct-0.8.7.tar.gz) = 1ea1ad0463669aafb733d3e921c85421
|
||||
|
|
|
@ -1,37 +0,0 @@
|
|||
# This file contains the template for Makeflags
|
||||
|
||||
SYSTEM = FreeBSD
|
||||
FEATURES = -DASYNCHRONOUS_IO -DUSE_POSIX_SIGNALS -DUNSIGNED_AUDIO_DATA -DFORCE_XSHM -DNETPLAY
|
||||
|
||||
LOGIC = netlogic
|
||||
|
||||
XPMINCLUDE =
|
||||
XPMLINKDIR =
|
||||
|
||||
BINDIR = ${PREFIX}/bin
|
||||
LIBDIR = ${PREFIX}/share/Maelstrom
|
||||
DATAFILES = Images/*.icon Images/*.cicn "Maelstrom Fonts" \
|
||||
"Maelstrom Sounds" "Maelstrom Sprites"
|
||||
|
||||
OBJS = main.o framebuf.o v_framebuf.o x11_framebuf.o vga_framebuf.o \
|
||||
dga_framebuf.o fontserv.o sound.o Mac_Resource.o imagedump.o \
|
||||
init.o $(LOGIC)/$(LOGIC).o \
|
||||
controls.o scores.o dialog.o fastrand.o netscore.o checksum.o \
|
||||
Utils.o shared.o myerror.o
|
||||
SOUNDOBJS = Maelstrom_sound.o Mac_Resource.o soundres.o mixer.o shared.o myerror.o
|
||||
|
||||
X11INCLUDE = -I${X11BASE}/include
|
||||
INCLUDES = -I$(LOGIC) $(X11INCLUDE) $(XPMINCLUDE)
|
||||
CFLAGS += $(INCLUDES) $(FEATURES) \
|
||||
-pedantic -DSYSTEM=\"$(SYSTEM)\" -DLIBDIR=\"$(LIBDIR)\"
|
||||
EXTRALIBS =
|
||||
X11LINKDIR = -L${X11BASE}/lib
|
||||
X11LIBS = -lXpm $(XPMLINKDIR) -lX11 -lXext $(X11LINKDIR)
|
||||
CSUMLIB =
|
||||
LIBS = $(EXTRALIBS) $(X11LIBS) $(CSUMLIB)
|
||||
SOUNDLIBS =
|
||||
|
||||
INSTALL = install
|
||||
|
||||
all: $(MAELSTROM)
|
||||
|
|
@ -1,26 +0,0 @@
|
|||
|
||||
$FreeBSD$
|
||||
|
||||
--- Makefile.orig Wed Dec 27 19:04:26 2000
|
||||
+++ Makefile Sat Mar 10 12:51:44 2001
|
||||
@@ -24,14 +24,15 @@
|
||||
ifeq ($(LOCAL),1)
|
||||
DATADIR = $(HOME)/BomberInstinct
|
||||
else
|
||||
- DATADIR = /usr/local/share/BomberInstinct
|
||||
+ DATADIR = $(PREFIX)/share/BomberInstinct
|
||||
endif
|
||||
|
||||
- BINDIR = /usr/local/bin
|
||||
- CC = gcc
|
||||
- CFLAGS := $(shell sdl-config --cflags) -Wall -O3\
|
||||
+ BINDIR = $(PREFIX)/bin
|
||||
+ CC? = gcc
|
||||
+ CFLAGS_ := $(shell $(SDL_CONFIG) --cflags) -Wall \
|
||||
-D$(CIBLE) -DDIR=\"$(DATADIR)\" -DVERSION=\"$(VERSION)\"
|
||||
- LIBS := $(shell sdl-config --libs) -lSDL_mixer -lm #-lSDL_image --static
|
||||
+ CFLAGS += $(CFLAGS_)
|
||||
+ LIBS := $(shell $(SDL_CONFIG) --libs) -lSDL_mixer -lsmpeg -lm #-lSDL_image --static
|
||||
endif
|
||||
OBJS = sprites.o niveaux.o pouvoirs.o evenements.o options.o son.o intro.o gamelogic.o SFont/SFont.o
|
||||
ifeq ($(DEBUG),1)
|
|
@ -1,14 +0,0 @@
|
|||
|
||||
$FreeBSD$
|
||||
|
||||
--- bi.cfg 2001/03/10 16:10:10 1.1
|
||||
+++ bi.cfg 2001/03/10 16:10:29
|
||||
@@ -8,7 +8,7 @@
|
||||
POINTDAVANCE=1
|
||||
CHANGEPERSOS=0
|
||||
MODEJEU=0
|
||||
-LANGUE=0
|
||||
+LANGUE=1
|
||||
|
||||
NIVEAU=laby.niv
|
||||
NIVEAU=manon.niv
|
|
@ -5,4 +5,4 @@ vertically and horizontally, but it's much more strategical because you have to
|
|||
do with the elements of a maze (arrows, tunnels, teleportations, and many
|
||||
more...), and with the special powers of each character.
|
||||
|
||||
WWW: http://harpe.dptmaths.ens-cachan.fr/U/gesbert/download.html
|
||||
WWW: http://www.bomberinstinct.org/index_en.html
|
||||
|
|
|
@ -1,14 +1,17 @@
|
|||
bin/bi
|
||||
bin/nived
|
||||
bin/spred
|
||||
share/BomberInstinct/Bruitages/boing.wav
|
||||
share/BomberInstinct/Bruitages/bonus.wav
|
||||
share/BomberInstinct/Bruitages/bouton.wav
|
||||
share/BomberInstinct/Bruitages/choix.s3m
|
||||
share/BomberInstinct/Bruitages/debut.wav
|
||||
share/BomberInstinct/Bruitages/ecrantit.wav
|
||||
share/BomberInstinct/Bruitages/expl.wav
|
||||
share/BomberInstinct/Bruitages/fin.wav
|
||||
share/BomberInstinct/Bruitages/fontaine.wav
|
||||
share/BomberInstinct/Bruitages/grosrire.wav
|
||||
share/BomberInstinct/Bruitages/intro.s3m
|
||||
share/BomberInstinct/Bruitages/mort.wav
|
||||
share/BomberInstinct/Bruitages/pouv.wav
|
||||
share/BomberInstinct/Bruitages/rire.wav
|
||||
share/BomberInstinct/Bruitages/teleport.wav
|
||||
share/BomberInstinct/Decors/Bande.bmp
|
||||
share/BomberInstinct/Decors/Barbare.bmp
|
||||
|
@ -27,6 +30,7 @@ share/BomberInstinct/Decors/mode_0.bmp
|
|||
share/BomberInstinct/Decors/mode_1.bmp
|
||||
share/BomberInstinct/Decors/mode_2.bmp
|
||||
share/BomberInstinct/Niveaux/choix.niv
|
||||
share/BomberInstinct/Niveaux/cs.niv
|
||||
share/BomberInstinct/Niveaux/dedale.niv
|
||||
share/BomberInstinct/Niveaux/electr.g
|
||||
share/BomberInstinct/Niveaux/enfer.niv
|
||||
|
@ -73,13 +77,9 @@ share/BomberInstinct/Sprites/grotte.spr
|
|||
share/BomberInstinct/Sprites/infos.spr
|
||||
share/BomberInstinct/Sprites/intro.spr
|
||||
share/BomberInstinct/Sprites/louis.spr
|
||||
share/BomberInstinct/Sprites/maagus.spr
|
||||
share/BomberInstinct/Sprites/magus.spr
|
||||
share/BomberInstinct/Sprites/menu.spr
|
||||
share/BomberInstinct/Sprites/miroirs.spr
|
||||
share/BomberInstinct/Sprites/murlave.spr
|
||||
share/BomberInstinct/Sprites/murnul.spr
|
||||
share/BomberInstinct/Sprites/neruis.spr
|
||||
share/BomberInstinct/Sprites/nived.spr
|
||||
share/BomberInstinct/Sprites/pschit.spr
|
||||
share/BomberInstinct/Sprites/puce.spr
|
||||
|
|
Loading…
Reference in a new issue