New port: games/barony

Barony is a 3D, first-person roguelike.  The goal of the game is
to descend to the bottom of a dark dungeon known as the Devil's
Bastion and destroy an undead lich named Baron Herx, who terrorized
the peaceful town of Hamlet in life and is now harboring a curse
against the land from beyond the grave.  To aid you in your quest
are friendly humans who have been eeking out a rough life within
the dungeon for generations, as well as any friends you can bring
with you in real life: Barony is the first of its kind as a
first-person roguelike in that it fully supports cooperative
multiplayer for up to four players.

WWW: http://www.baronygame.com/

PR:		227353
Submitted by:	David Carlier <devnexen@gmail.com>
Reviewed by:	amdmi3, jbeich, tobik
Differential Revision:	https://reviews.freebsd.org/D15310
This commit is contained in:
Tobias Kortkamp 2018-08-14 19:29:27 +00:00
parent d83895f028
commit 5eddc066b8
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=477198
7 changed files with 101 additions and 0 deletions

View file

@ -74,6 +74,7 @@
SUBDIR += ballerburg
SUBDIR += banihstypos
SUBDIR += barbie_seahorse_adventures
SUBDIR += barony
SUBDIR += barrage
SUBDIR += bass
SUBDIR += bastet

42
games/barony/Makefile Normal file
View file

@ -0,0 +1,42 @@
# $FreeBSD$
PORTNAME= barony
DISTVERSIONPREFIX= v
DISTVERSION= 3.1.4
CATEGORIES= games
MAINTAINER= devnexen@gmail.com
COMMENT= 3D roguelike game
LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/GPL.3.0.txt
LIB_DEPENDS= libogg.so:audio/libogg \
libpng.so:graphics/png \
libvorbisfile.so:audio/libvorbis
USES= cmake compiler:c++11-lib openal localbase:ldflags pkgconfig
USE_GITHUB= yes
GH_ACCOUNT= TurningWheel
GH_PROJECT= Barony
USE_GL= gl glu
USE_SDL= sdl2 image2 net2 ttf2
CMAKE_ON= OPENAL_ENABLED DATA_DIR
CMAKE_ARGS= -DEDITOR_EXE_NAME:STRING="barony-editor"
LDFLAGS+= -Wl,--as-needed
LLD_UNSAFE= yes # cf. PR 226980
SUB_FILES= barony.sh pkg-message
PLIST_FILES= bin/barony \
bin/barony-editor \
libexec/barony \
${DATADIR}/lang/en.ttf \
${DATADIR}/lang/en.txt
post-install:
${MV} ${STAGEDIR}${PREFIX}/bin/barony ${STAGEDIR}${PREFIX}/libexec
${INSTALL_SCRIPT} ${WRKDIR}/barony.sh ${STAGEDIR}${PREFIX}/bin/barony
.include <bsd.port.mk>

3
games/barony/distinfo Normal file
View file

@ -0,0 +1,3 @@
TIMESTAMP = 1524914514
SHA256 (TurningWheel-Barony-v3.1.4_GH0.tar.gz) = bcf7522636a2dc21fdda47114f8d9c0eec78ca2c41613e896310e6110fbf04c4
SIZE (TurningWheel-Barony-v3.1.4_GH0.tar.gz) = 53299453

View file

@ -0,0 +1,6 @@
#!/bin/sh
# Temporary solution until the next version
mkdir -p ~/.barony
cd ~/.barony || { echo "Can't cd into ~/.barony" >&2; exit 1; }
exec %%PREFIX%%/libexec/barony "$@"

View file

@ -0,0 +1,12 @@
--- CMakeLists.txt.orig 2018-08-14 17:54:04 UTC
+++ CMakeLists.txt
@@ -64,8 +64,7 @@ if( NOT WIN32 )
set(CMAKE_C_FLAGS_DEBUG "${CMAKE_C_FLAGS_DEBUG} -Wall -pg -ffast-math -funroll-loops -fstrict-aliasing")
#set(CMAKE_CXX_FLAGS_DEBUG "${CMAKE_CXX_FLAGS_DEBUG} -Wall -pg -fsanitize=address -fno-omit-frame-pointer -fsanitize=undefined -fno-sanitize-recover -Wreturn-type -Werror=return-type")
set(CMAKE_CXX_FLAGS_DEBUG "${CMAKE_CXX_FLAGS_DEBUG} -Wall -pg")
- set(CMAKE_C_FLAGS_RELEASE "${CMAKE_C_FLAGS_RELEASE} -O3 -ffast-math -funroll-loops -fstrict-aliasing")
- set(CMAKE_CXX_FLAGS_RELEASE "${CMAKE_CXX_FLAGS_RELEASE} -O3")
+ set(CMAKE_C_FLAGS_RELEASE "${CMAKE_C_FLAGS_RELEASE} -ffast-math -funroll-loops -fstrict-aliasing")
endif()
if (APPLE)
set (Apple 1)

View file

@ -0,0 +1,25 @@
Barony requires the original game files from Barony: Blessed Edition
(e.g. 3.1.x) to work properly. These can come from the GOG.com
or the Steam versions of the game.
If using the GOG.com version, you should download the Linux version
barony_cursed_edition_en_3_1_4_20342.sh and use the unzip command
line to extract the data.
The files will be in a directory named data/noarch/game. You can
move the contents of this directory to the %%DATADIR%%
directory for a global install. You will also need to fix the
permissions on the files.
The easiest way to do this is to follow these steps:
$ unzip barony_cursed_edition_en_3_1_4_20342.sh
$ sudo cp -R data/noarch/game/* %%DATADIR%%
$ sudo find %%DATADIR%% -type d ! -perm 755 -exec chmod 755 {} \;
As an alternative, the game assets can be placed into a personal folder
of your choice and the game can be launched with the -datadir= option,
for example:
$ barony -datadir=$HOME/.barony
You do not have to fix file permissions in this case.

12
games/barony/pkg-descr Normal file
View file

@ -0,0 +1,12 @@
Barony is a 3D, first-person roguelike. The goal of the game is
to descend to the bottom of a dark dungeon known as the Devil's
Bastion and destroy an undead lich named Baron Herx, who terrorized
the peaceful town of Hamlet in life and is now harboring a curse
against the land from beyond the grave. To aid you in your quest
are friendly humans who have been eeking out a rough life within
the dungeon for generations, as well as any friends you can bring
with you in real life: Barony is the first of its kind as a
first-person roguelike in that it fully supports cooperative
multiplayer for up to four players.
WWW: http://www.baronygame.com/